• When I log into Admin, first page is slow or it just hangs forever.

    FIRST ... is the slowness *only* for the admin area? If you also see the *same* slowness in your storefront, this FAQ does not apply to your situation.

    Slowness logging in to the Admin area

    When you first log in to the Admin area, Zen Cart attempts to talk to the Zen Cart versioning server to see if updates are available. If it can't find the server (maybe your server can't talk to the internet?) then it is possible that you'll see your admin access hang for a minute or so.

    There are 2 approaches to addressing this:

    1. When you DO log into the admin area, turn off version checking here:
    Admin> Config> My Store> Show if version update available ... set this to 0/false/off.


    2. IF AND ONLY IF you can't log into the admin area AT ALL, try editing the /admin/includes/local/skip-version-check.ini file and set the version-check line to "off":
    version_check=off

    Updating the INI file as described bypasses this auto-check.

     

    Additional Information

    If the slowness or other problems you're experiencing are also happening on other pages, then the Zen Cart version server is not the problem.

    If your webserver is having trouble talking to the Zen Cart version server, either because it's slow, or not responding at all, talk to your hosting company about why your server cannot access ping.zen-cart.com ... perhaps there's a DNS problem on your server.


    ANOTHER ERROR that may be solved by the same solution is this: "The specified CGI application misbehaved by not returning a complete set of HTTP headers." This would be on a Windows XP host.