Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2007
    Posts
    87
    Plugin Contributions
    0

    Default Error when upgrading

    I am getting this error when upgrading.

    1062 Duplicate entry 'Customers who have never completed a purchase' for key 2
    in:
    [INSERT INTO query_builder (query_category, query_name, query_description , query_string) VALUES ('email,newsletters', 'Customers who have never completed a purchase', 'For sending newsletter to all customers who registered but have never completed a purchase', 'SELECT DISTINCT c.customers_email_address as customers_email_address, c.customers_lastname as customers_lastname, c.customers_firstname as customers_firstname FROM TABLE_CUSTOMERS c LEFT JOIN TABLE_ORDERS o ON c.customers_id=o.customers_id WHERE o.date_purchased IS NULL');]

    Any thoughts here,

    I am working in my local environment btw.

    Bill

  2. #2
    Join Date
    Aug 2005
    Posts
    26,493
    Plugin Contributions
    9

    Default Re: Error when upgrading

    Getting this when doing what?
    Upgrading from what to what?
    Are you using the zc_install database upgrade?
    Zen-Venom Get Bitten
    Get Your Business Found

  3. #3
    Join Date
    Jan 2007
    Posts
    87
    Plugin Contributions
    0

    Default Re: Error when upgrading

    Sorry for lack of info,

    I am upgrading from 1.3.7 to 1.3.8
    It happens when I choose the 1.3.7 to 1.3.8 upgrade check box and hit upgrade database now.
    And yes I am using the zc_install database upgrade, from the upgrade button that shows up after the license page.

    Bill

  4. #4
    Join Date
    Aug 2005
    Posts
    26,493
    Plugin Contributions
    9

    Default Re: Error when upgrading

    I am upgrading from 1.3.7 to 1.3.8
    Are there any added modules to your install and/or patches that have been applied?
    Zen-Venom Get Bitten
    Get Your Business Found

  5. #5
    Join Date
    Jan 2007
    Posts
    87
    Plugin Contributions
    0

    Default Re: Error when upgrading

    Thanks for the reply,

    I have the better categories and the backup db modules.
    I was however able to get the site upgraded.
    I had overlooked the restore db from 1.3.7 into the 1.3.8 new db.
    I am testing it now and it seems okay, just a few minor things.
    Since I had been planning on doing a layout change this was a good time to upgrade, I was also about to patch the PayPal as well, Iwas getting errors from clients.

    This will be my last step before going live this week.

    Any thoughts on what I may have missed or should look or?
    I did notice my shipping on my 1.3.7 site shows PerItem National and PerItem International, so I will need to go through that on the new site.

    Bill Scheltema

 

 

Similar Threads

  1. Error when upgrading to 1.3.8.
    By elnaraniall in forum Upgrading from 1.2 to 1.3.x
    Replies: 4
    Last Post: 12 Feb 2008, 12:11 AM
  2. Linkpoint_api Error msg When Upgrading to v1.3.8a
    By bsteinagel in forum Upgrading from 1.3.x to 1.3.9
    Replies: 4
    Last Post: 31 Dec 2007, 07:42 AM
  3. Error after upgrading
    By seattleannie in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 22 Feb 2007, 06:05 PM
  4. Email Error: after upgrading to 1.3.6
    By lennypeng in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 16 Nov 2006, 09:42 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •