Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1
    Join Date
    Nov 2008
    Location
    Canterbury
    Posts
    46
    Plugin Contributions
    0

    Default Site doesn't load anymore???!!! WHY?

    Hi all,

    My site was working fine. Then I changed a line on the index.php file -some text on the site.

    /rcmonster.co.uk/includes/languages/english/index.php

    And it stopped loading, just a white screen now

    www.rcmonster.co.uk

    I changed the index.php file back to the original, but still not working!!???

    The admin page works so server must be OK.

    ANy ideas?

    Thanks

    Paul

  2. #2
    Join Date
    Jul 2006
    Location
    Montreal, Canada
    Posts
    2,285
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?


  3. #3
    Join Date
    Nov 2008
    Location
    Canterbury
    Posts
    46
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?

    Thanks for the info. Well the debug file says line 54, but I cant see a problem there. I have pasted the file contents below with the error line in red:

    <?php
    /**
    * @package languageDefines
    * @copyright Copyright 2003-2006 Zen Cart Development Team
    * @copyright Portions Copyright 2003 osCommerce
    * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
    * @version $Id: index.php 6550 2007-07-05 03:54:54Z drbyte $
    */

    define('TEXT_MAIN','This is the main define statement for the page for english when no template defined file exists. It is located in: <strong>/includes/languages/english/index.php</strong>');

    // Showcase vs Store
    if (STORE_STATUS == '0') {
    define('TEXT_GREETING_GUEST', 'Hi, <span class="greetUser">Guest!</span> Would you like to <a href="%s">log yourself in</a>?');
    } else {
    define('TEXT_GREETING_GUEST', 'Welcome, please enjoy our online showcase.');
    }

    define('TEXT_GREETING_PERSONAL', 'Hello <span class="greetUser">%s</span>! Would you like to see our <a href="%s">newest additions</a>?');

    define('TEXT_INFORMATION', 'RC Monster');

    //moved to english
    //define('TABLE_HEADING_FEATURED_PRODUCTS','Featured Products');

    //define('TABLE_HEADING_NEW_PRODUCTS', 'New Products For %s');
    //define('TABLE_HEADING_UPCOMING_PRODUCTS', 'Upcoming Products');
    //define('TABLE_HEADING_DATE_EXPECTED', 'Date Expected');

    if ( ($category_depth == 'products') || (zen_check_url_get_terms()) ) {
    // This section deals with product-listing page contents
    define('HEADING_TITLE', 'Available Products');
    define('TABLE_HEADING_IMAGE', 'Product Image');
    define('TABLE_HEADING_MODEL', 'Model');
    define('TABLE_HEADING_PRODUCTS', 'Product Name');
    define('TABLE_HEADING_MANUFACTURER', 'Manufacturer');
    define('TABLE_HEADING_QUANTITY', 'Quantity');
    define('TABLE_HEADING_PRICE', 'Price');
    define('TABLE_HEADING_WEIGHT', 'Weight');
    define('TABLE_HEADING_BUY_NOW', 'Buy Now');
    define('TEXT_NO_PRODUCTS', 'There are no products to list in this category.');
    define('TEXT_NO_PRODUCTS2', 'There is no product available from this manufacturer.');
    define('TEXT_NUMBER_OF_PRODUCTS', 'Number of Products: ');
    define('TEXT_SHOW', 'Filter Results by:');
    define('TEXT_BUY', 'Buy 1 \'');
    define('TEXT_NOW', '\' now');
    define('TEXT_ALL_CATEGORIES', 'All Categories');
    define('TEXT_ALL_MANUFACTURERS', 'All Manufacturers');
    } elseif ($category_depth == 'top') {
    // This section deals with the "home" page at the top level with no options/products selected
    /*Replace this text with the headline you would like for your shop. For example: 'Welcome to My SHOP!'*/
    define('HEADING_TITLE', 'Welcome to RC Monster!');
    } elseif ($category_depth == 'nested') {
    // This section deals with displaying a subcategory
    /*Replace this line with the headline you would like for your shop. For example: 'Welcome to My SHOP!'*/
    define('HEADING_TITLE', 'Welcome to RC Monster');
    }
    ?>


    Can anyone tell me if this is OK? or is there a program I can paste it into to tell me??

    Thanks

    Paul

  4. #4
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    159
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?

    Do you have your backup files to revert to a working state?

  5. #5
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,591
    Plugin Contributions
    3

    Default Re: Site doesn't load anymore???!!! WHY?

    define('TEXT_NUMBER_OF_PRODUCTS', 'Number of Products: ');
    define('TEXT_SHOW', 'Filter Results by:');
    define('TEXT_BUY', 'Buy 1 \'');
    define('TEXT_NOW', '\' now');
    define('TEXT_ALL_CATEGORIES', 'All Categories');
    define('TEXT_ALL_MANUFACTURERS', 'All Manufacturers');


    That character in red should be a single quote.

  6. #6
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    159
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?

    Nice catch stevesh! Very nice. That is some serious micro vision.
    Last edited by saitomedia; 22 Dec 2008 at 12:45 PM.

  7. #7
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,591
    Plugin Contributions
    3

    Default Re: Site doesn't load anymore???!!! WHY?

    Thanks, but the interesting thing is that it's a double single quote (as opposed to a quotation mark) in a fresh copy of that file, so I don't know if that's right or not.

  8. #8
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    159
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?

    Quote Originally Posted by stevesh View Post
    Thanks, but the interesting thing is that it's a double single quote (as opposed to a quotation mark) in a fresh copy of that file, so I don't know if that's right or not.
    my default zen files reads:
    Code:
     define('TEXT_BUY', 'Buy 1 \' ');
    with no space in beween. It looked like there is a space but i checked with my keyboard and no problem with the fresh copy. Funky stuff.
    Last edited by saitomedia; 22 Dec 2008 at 12:58 PM.

  9. #9
    Join Date
    Oct 2006
    Location
    Alberta, Canada
    Posts
    4,151
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?

    Methinks that "includes/languages/english/index.php" is the wrong file to be dealing with.

    Did a copy & paste of the above code into my Editor and nothing wrong with the syntax. Problem must be somewhere else / some other file.
    The learning is in the doing.

    Potent Products

  10. #10
    Join Date
    Feb 2008
    Location
    Southern California
    Posts
    159
    Plugin Contributions
    0

    Default Re: Site doesn't load anymore???!!! WHY?

    Quote Originally Posted by Website Rob View Post
    Methinks that "includes/languages/english/index.php" is the wrong file to be dealing with.
    Did a copy & paste of the above code into my Editor and nothing wrong with the syntax. Problem must be somewhere else / some other file.

    Thank you for your comment WB,

    Was he adding some sort of mod into zen cart? Hey rcmonster, let us know what you *were* doing right before you got your white-screen-of-death.
    Last edited by saitomedia; 22 Dec 2008 at 01:08 PM.

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Help! Cannot reach my site anymore
    By pettiger15 in forum General Questions
    Replies: 4
    Last Post: 20 Sep 2008, 09:10 PM
  2. Help please, site won't work anymore!
    By noahsarcade in forum Templates, Stylesheets, Page Layout
    Replies: 0
    Last Post: 11 May 2008, 10:16 PM
  3. Need www. to get site to load
    By spigot in forum General Questions
    Replies: 2
    Last Post: 17 Jan 2007, 03:22 PM
  4. logo.jpg won't load up anymore
    By zc-newbie in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 13 Sep 2006, 01:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •