Results 1 to 6 of 6
  1. #1
    Join Date
    Sep 2006
    Posts
    30
    Plugin Contributions
    0

    Default missing HTML pages after upgrade (ie: /shop/shippinginfo.html gives 404 error)

    hi, i've just started upgrading a heavily-modded 1.3.5 to 1.3.8. it's been nearly 2 years since i looked at this, and i could really use some help. i did use template overrides, but i'm still finding major discrepancies after the upgrade.

    so far i've upgraded the database, uploaded my template override files, and installed updated versions of a couple of mods.

    first question, the site has/had a series of EZ pages links in the footer: shipping info, privacy notice, terms and conditions, etc. you can see the links (for the time being) in the google cache (the site is down for maintenance/rescuing). here's one of those pages, cached: shipping and returns.

    since the upgrade, none of these links are working. clicking any of them triggers a 404 error. this is a bit tricky: there's a wordpress blog installed in the root directory and zen cart is installed in /shop/. anything 404-ing from within /shop/ triggers the wordpress (root) 404 page. so that's what i see when i click the footer links for "conditions" or "shipping" etc.

    now, in the admin EZ pages editor, the page titles all show up and are correctly activated in the footer and listed in the proper order. they're all set up to link to an internal link URL, e.g. to /shop/shippinginfo.html. none of the EZ pages have any content in the editor field. since all the EZ pages activate internal link URLs i'd been putting the content for those target pages in via the define pages editor tool, which adds content to the shippinginfo.html page by editing /languages/english/html_includes/define_shipping_info.php.

    i opened the define pages editor in the upgraded admin and found only the sample/default zen cart text where the original content used to be before the upgrade. so i double-checked the english/html_includes folder and sure enough, i'd forgotten to copy my new files there. i copied them over, and the content showed up in the define pages editor as it should. but the links still don't work, all of them just 404.

    can someone point me in the direction of where to look next? has something changed in the formatting of the permalinks used by the EZ pages? any idea why i don't have a /shop/shippinginfo.html page all of a sudden?

    your help would be much appreciated, cheers.
    -p.

  2. #2
    Join Date
    Jun 2005
    Location
    Hertfordshire, UK
    Posts
    9,958
    Plugin Contributions
    3

    Default Re: missing HTML pages after upgrade (ie: /shop/shippinginfo.html gives 404 error)

    Did you have a SEO module on the old version?

    The path:/shop/shippinginfo.html

    suggests you did.

    If you put:

    Code:
    http://www.plastiquemonkey.com/shop/index.php?main_page=shippinginfo
    into your browser, the page shows up.

    Your EZpages internal link needs to therefore be:

    index.php?main_page=shippinginfo

    ...until you get your SEO modules sorted out!
    Our latest project is Pet Tags.

  3. #3
    Join Date
    Jun 2005
    Location
    Hertfordshire, UK
    Posts
    9,958
    Plugin Contributions
    3

    Default Re: missing HTML pages after upgrade (ie: /shop/shippinginfo.html gives 404 error)

    In order to cater for these stored GOOGLE references, you may consider doing HTTP REFRESH pages.

    Create a HTML file for each "html" page that Google may have stored... for example, for shipping.html


    HTML Code:
    <html> <head> <title>Webmaster redirect</title> <META http-equiv="refresh" content="0;URL=http://www.plastiquemonkey.com/shop/index.php?main_page=shippinginfo"> </head> <body bgcolor="#ffffff"> <center>The contents you are looking for have moved. You will be redirected to the new location automatically. Please bookmark the correct page at <a href="http://www.plastiquemonkey.com/shop/index.php?main_page=shippinginfo"> http://www.plastiquemonkey.com/shop/index.php?main_page=shippinginfo</a> </center> </body> </html>
    SAVE this html file as shippinginfo.html and FTP it to your shop folder.

    Do the same for all other such pages google has, remembering of course to change the PATHS as is done in the above example, to the php equivalent.

    This will prevent the 404 you are experiencing.
    Our latest project is Pet Tags.

  4. #4
    Join Date
    Sep 2006
    Posts
    30
    Plugin Contributions
    0

    Default Re: missing HTML pages after upgrade (ie: /shop/shippinginfo.html gives 404 error)

    thanks, that's very helpful.

    stupidly i'd been thinking it would simpler to set up the updated version of zen cart first and then add back in the mods. but that's not working out so far.

    i reinstalled ultimate SEO URLs and that fixed the 404 problem.

    except that the "about us" html file was still 404-ing from within the shop (triggering the page not found file created in the define pages editor). of course that's itself a mod, so i installed the updated version of "about us" and it worked fine.

    then i noticed the privacy page was loading normally but the privacy notice wasn't displaying, just the title and the "back" button that's usually at the bottom of the page. searched the forum for an answer and found that "privacy notice" is turned off by default in admin-configuration-define pages status. switched that from 3 to 1 (link on, define text on) and there it was.

    so the lesson today is that i'm going to reinstall updated versions of all the mods i was using in 1.3.5 before starting any more forum threads.
    -p.

  5. #5
    Join Date
    Jan 2004
    Posts
    60,695
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: missing HTML pages after upgrade (ie: /shop/shippinginfo.html gives 404 error)

    Just a reminder ... upgrades should *always* be done in a *copy* of your site, and not directly on the live site until you've tested all your changes, customizations, addons, etc. And of course having solid backups before and after is prudent as well.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6
    Join Date
    Sep 2006
    Posts
    30
    Plugin Contributions
    0

    Default Re: missing HTML pages after upgrade (ie: /shop/shippinginfo.html gives 404 error)

    yeah, point well taken.

    the previous version of the shop broke earlier this month when our server upgraded to PHP 5.2 -- sessions weren't working for some reason and i couldn't even login to the admin. trying to fix the login problem seemed like a waste of time given the need to upgrade the site anyway, so i just put it down for maintenance with a note about reopening in a week. the shop sells original work unavailable elsewhere so we don't worry too much about losing business during a fairly brief shutdown. i did copy the old site to a hidden directory for comparison's sake.

    we'll see how it goes, so far so good overall.

 

 

Similar Threads

  1. creating anchor links in defined pages like shippinginfo.html
    By shocker in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 7 Dec 2008, 11:35 AM
  2. Replies: 3
    Last Post: 29 Aug 2008, 08:11 PM
  3. Replies: 2
    Last Post: 11 Jan 2008, 10:53 AM
  4. checkout_shipping.html is missing
    By shqipo in forum Built-in Shipping and Payment Modules
    Replies: 5
    Last Post: 20 Dec 2006, 07:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg