Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2004
    Posts
    76
    Plugin Contributions
    0

    Default upgrade from 1.2.7 -> 1.3.8a problem

    I have read the forum and tried to follow the directions in the "3 Easy Steps" document but I'm still having some problems.

    I created a copy of my db from 1.2.7 and used it to create a db in 1.3.8 and I edited the configure.php in includes and admin/includes to provide the appropriate db and site information.

    When I go to the site root, I get the following error message:

    -------Begin Message
    1054 Unknown column 'startdate' in 'field list'
    in:
    [select startdate, counter, session_counter from zen_counter_history where startdate='20090201']
    -------End Message

    1. Is that an indication that the connection to the db is being made?

    I then executed zc_install/index.php but I did not get the Upgrade option.

    2. Would I be okay to execute the sql upgrade scripts directly on the db without using zc_install?

    Any help would be appreciated.

    Carter

  2. #2
    Join Date
    Aug 2005
    Posts
    26,512
    Plugin Contributions
    9

    Default Re: upgrade from 1.2.7 -> 1.3.8a problem

    I created a copy of my db from 1.2.7 and used it to create a db in 1.3.8 and I edited the configure.php in includes and admin/includes to provide the appropriate db and site information.
    This does not look right??? Install 1.3.8a with a NEW DB. The configs will be created and correct. Import a "Good" 1.2.7 backup to this installs DB - and re-run zc_install


    2. Would I be okay to execute the sql upgrade scripts directly on the db without using zc_install?
    Not adviseable as you will have hundreds to do between those versions
    Zen-Venom Get Bitten
    Get Your Business Found

  3. #3
    Join Date
    Jul 2004
    Posts
    76
    Plugin Contributions
    0

    Default Re: upgrade from 1.2.7 -> 1.3.8a problem

    I had a problem understanding the upgrade instructions so let me repeat back.

    I'm going to do a complete install of 1.3.8a and get it up and running.
    Then I'm going to create another database from the 1.2.7 install.
    Then change the configure.php to point to the 1.2.7 db.
    Then rerun the install and I should get the upgrade option.
    I rerun the install to upgrade the database one version at a time. (don't check them all at once)

    If I counted right, there are 8 sql scripts to execute.

    I tried the first one. I got an error because my tables are prefixed with "zen_" so I had to modify the sql script by adding "zen_" to each table name. After that, the script ran the script and it ran the first time.

    Am I getting closer?

  4. #4
    Join Date
    Aug 2005
    Posts
    26,512
    Plugin Contributions
    9

    Default Re: upgrade from 1.2.7 -> 1.3.8a problem

    I tried the first one. I got an error because my tables are prefixed with "zen_" so I had to modify the sql script by adding "zen_" to each table name.
    You did not need to create a NEW DB for the 127 and could have just restored your backup to the one you installed 1.3.8 to but what you did will also work.

    In the upgrade screens there should be a field to define the prefix so you do not have to edit each sql file
    Zen-Venom Get Bitten
    Get Your Business Found

  5. #5
    Join Date
    Jul 2004
    Posts
    76
    Plugin Contributions
    0

    Default Re: upgrade from 1.2.7 -> 1.3.8a problem

    Thanks for the reply kobra!

    Learning the process is important to me. I want to know what is going on in the application. I may well try this several different ways and see what I like best.

    You are correct, I could have restored the "backup" and tried the install. Now that I have started the migration I may switch to the install method and see if it works that way too. I'll let you know.

    Carter

 

 

Similar Threads

  1. HELP! upgrade problem
    By keylesslocks in forum Upgrading from 1.3.x to 1.3.9
    Replies: 9
    Last Post: 22 Jan 2008, 08:26 AM
  2. Upgrade Problem ~ please help!
    By Mrsb in forum Upgrading from 1.2 to 1.3.x
    Replies: 8
    Last Post: 18 Jun 2006, 05:18 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •