Page 4 of 208 FirstFirst ... 234561454104 ... LastLast
Results 31 to 40 of 2076
  1. #31
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,895
    Plugin Contributions
    3

    Default Re: ozpost shipping module

    Quote Originally Posted by LowlyWorm View Post
    Let me know if I can do anything to help,
    Thanks!
    David
    Hi David, I'd appreciate your help :-)

    Attached to this message (hopefully) is a .zip file called ozpost_test.zip

    Within it you will find two files, an update of the ozpost.php file, and a small jpeg for the overseas registered parcels.

    Place the jpeg file in with the other ozpost jpegs.

    Replace the modules/includes/shipping/ozpost.php with this one.
    Log into admin, hit the 'remove' button to remove the existing ozpost module, then immediately hit the 'install' button to reinstall. This action is required to enable the overseas registered function. It appear that I did code for it on the server side, but it fell through the cracks on the client side.

    I've updated the icon path stuff so you shouldn't need to hack anything to get it to install (in fact this is what I really need you to test for me).

    As long as I get positive feedback from you I'll create another full package and upload it to the zencart downloads area for others.

    For anyone else reading this, please be advised that the attachment is NOT a full distribution, so don't expect to download it it and have it just 'work'. You are however free to download the original archive from the downloads area and follow the instructions above.

    Attachment 5516

    Cheers
    Rod
    Last edited by RodG; 8 Dec 2009 at 01:47 PM.

  2. #32
    Join Date
    Mar 2009
    Posts
    19
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    Hi Rod,
    No problem, thanks for the update. I was just heading out for a little but will check it out as soon as I get back. Will let you know how I go :)

    David

  3. #33
    Join Date
    Mar 2009
    Posts
    19
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    I've installed the two new files, uninstalled and reinstalled the module (also double checked previous default parameter was removed) and all is looking good on initial inspection i.e. I didn't see any errors etc. I haven't given it a real good bash yet but registered international parcels are certainly there now, great!

    Interestingly though, I did notice that it was listing "Express Parcel International" even when it wasn't enabled in the admin section. I tried enabling it and disabling it but shows up either way. Insured Express Parcel International only shows when enabled though. Again, I haven't given it a very thorough work out though, I can have a better look tomorrow.

    David

  4. #34
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,895
    Plugin Contributions
    3

    Default Re: ozpost shipping module

    Quote Originally Posted by LowlyWorm View Post
    I've installed the two new files, uninstalled and reinstalled the module (also double checked previous default parameter was removed) and all is looking good on initial inspection i.e. I didn't see any errors etc. I haven't given it a real good bash yet but registered international parcels are certainly there now, great!
    Excellent news. :-)


    Quote Originally Posted by LowlyWorm View Post
    Interestingly though, I did notice that it was listing "Express Parcel International" even when it wasn't enabled in the admin section. I tried enabling it and disabling it but shows up either way. Insured Express Parcel International only shows when enabled though. Again, I haven't given it a very thorough work out though, I can have a better look tomorrow.

    David
    Thanks. I've just had a look at the EPI showing all the time, and can confirm that it's a bug. I've already taken care of it.

    I'll await for any further feedback before I zip the whole thing up again.

    Cheers
    Rod.

  5. #35
    Join Date
    Mar 2009
    Posts
    10
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    Hi,

    I just downloaded the new version of OzPost...

    There are no files (or directory) for includes/languages/english etc in the zip file I downloaded, so when I installed it I got errors complaining that the files don't exist....

    Is there something missing in the download area, or did mine just not download properly?

    Thanks for your great work to provide this module, it has saved me many days of work....

    Nerida.

  6. #36
    Join Date
    Mar 2009
    Posts
    19
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    Quote Originally Posted by neridal View Post
    Hi,

    Is there something missing in the download area, or did mine just not download properly?

    Nerida.
    Hi Nerida,
    There is a new version being tested with some fixes Rod has added in, which will no doubt be available soon.

    David

  7. #37
    Join Date
    Mar 2009
    Posts
    10
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    Thanks David,
    I guess I will wait and see...


  8. #38
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,895
    Plugin Contributions
    3

    Default Re: ozpost shipping module

    Quote Originally Posted by neridal View Post
    Hi,

    I just downloaded the new version of OzPost...

    There are no files (or directory) for includes/languages/english etc in the zip file I downloaded, so when I installed it I got errors complaining that the files don't exist....

    Is there something missing in the download area, or did mine just not download properly?

    Thanks for your great work to provide this module, it has saved me many days of work....

    Nerida.
    As David has said, a new update is currently being tested that takes care of this (and a couple of other problems). It should be available in a few days.

    Meanwhile, if you you can't wait that long, AND you are running your server on a LINUX based system you should be able to get things working by creating an empty file in the languages directory called 'ozpost.php'.

    Please be advised though that there are a couple of other bugs that may or may not affect you, eg, the 'kg/gms' setting doesn't work (it is 'stuck' on gms), and one of the overseas shipping methods is stuck in the 'on' position.

    Cheers
    Rod

  9. #39
    Join Date
    Mar 2009
    Posts
    10
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    Thanks Rod,

    I will wait for now, as we are only in the setup phase for our shopping cart with products.

    Great to know you are making progress...

    cheers,
    Nerida.

  10. #40
    Join Date
    Mar 2009
    Posts
    20
    Plugin Contributions
    0

    Default Re: ozpost shipping module

    Hi There,

    Great work on the shipping module !!

    I have it installed & operational.

    The items in my shop are quite large & I am having problems if shipping more than 1 item as the combined total of all items exceeds the OzPost maximium. It seems it doesn't see the items as being seperate boxes and adds ALL together for 1 global package.
    I can not seem to find any facility in your Module or Zencart to split the shipping of the items to be indiviually boxed, packaged.

    Using latest Zen & also your module.

    Is there a script hack to enable this or is it a core rewrite for the next version ?

    Regards
    Matt

 

 
Page 4 of 208 FirstFirst ... 234561454104 ... LastLast

Similar Threads

  1. USPS Shipping Module to Print Shipping Labels
    By HelenSama in forum Built-in Shipping and Payment Modules
    Replies: 7
    Last Post: 8 Sep 2011, 03:17 PM
  2. Canadapost Shipping module and Dual Pricing module
    By oxxyfx in forum Addon Shipping Modules
    Replies: 1
    Last Post: 12 Feb 2009, 02:06 AM
  3. store pick-ip in ozpost shipping module
    By lazerweb in forum Addon Shipping Modules
    Replies: 2
    Last Post: 29 Jul 2008, 05:04 AM
  4. Clone a shipping module or define a new shipping attribute under table rate module?
    By meeven in forum Built-in Shipping and Payment Modules
    Replies: 0
    Last Post: 4 Sep 2007, 04:56 PM
  5. MZMT shipping module - Display Shipping Options based on Weight
    By DogTags in forum Addon Shipping Modules
    Replies: 2
    Last Post: 27 Feb 2007, 04:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •