Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Hybrid View

  1. #1
    Join Date
    May 2008
    Posts
    354
    Plugin Contributions
    0

    Default How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Patch

    Hi, when i log in to my admin area it is still showing the message "New PATCH Available: v1.3.8a - patch: [1] :: Important Security Patch "

    I've installed the patch but it still showing the message. Do i need to change the "Admin" folder and log in url?

    Because iam a newbie iam really nervous & scared of start messing around with folders

  2. #2
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,537
    Plugin Contributions
    3

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    I believe you do need to change the name of the admin folder to prevent that message from appearing, but you want to do that anyway, for security reasons. It's really pretty simple:

    Change the name of the 'admin' folder.

    Open admin/includes/configure.php and change the three (3) places where it says 'admin' to the new name of your folder.

    Save the configure.php back to admin/includes, overwriting the existing file.

  3. #3
    Join Date
    Jan 2004
    Posts
    60,305
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    The security patch ZIP file was updated a couple times. Perhaps you got an earlier edition of the file that didn't contain the updates.
    It's easy to fix that:
    a) clear the browser's "temporary files"
    b) re-download the patch zip file
    c) unzip
    d) apply the patch as if it was the first time you were doing it.
    There's only a few files in it to deal with, so will only take a couple minutes.


    Renaming your Admin is still very important, but is unrelated to the version number message.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  4. #4
    Join Date
    May 2008
    Posts
    354
    Plugin Contributions
    0

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    Could i just install the security patch & leave the Admin Folder, or do i have to rename admin to get rid of the message "New PATCH Available: v1.3.8a - patch: [1] :: Important Security Patch "

  5. #5
    Join Date
    Jul 2006
    Location
    Montreal, Canada
    Posts
    2,285
    Plugin Contributions
    0

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    as DrByte mentioned. renaming your admin folder is unrelated to version / update message you get in your admin. download the patch again as this one has been updated to also deal with version message and reapply the patch .

  6. #6
    Join Date
    May 2008
    Posts
    354
    Plugin Contributions
    0

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    Thanks for everyone who got back to me. Thanks

  7. #7
    Join Date
    Feb 2008
    Posts
    175
    Plugin Contributions
    0

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    I installed the patch on June 22nd, renamed admin directory today (july 1) and am still getting the new patch message. Patch is current version per security thread. Do I still need to reinstall?

  8. #8
    Join Date
    Aug 2009
    Location
    NYC
    Posts
    5
    Plugin Contributions
    0

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    I have downloaded and installed the patch, there only seems to be one version available, but after unzipping it looks like it includes at least one file that was updated July 25. I have tried reinstalling a couple of times, I have changed my admin folder, etc. I still get the message "New Version Available v1.3.8a :: Important Security Patch" and the "Download Here" link leads me to the exact same file I already patched. So I try again... Still see that message! How do I make it go away? Again, I have installed and reinstalled the patch files multiple times.

  9. #9
    Join Date
    Jan 2004
    Posts
    60,305
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    What version of Zen Cart are you using? The message will not go away if you're not using v1.3.8a and the security patch. If you have an older version installed then ... well ... the message is correct.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #10
    Join Date
    Aug 2009
    Posts
    1
    Plugin Contributions
    0

    Default Re: How to get of New PATCH Available: v1.3.8a - patch: [1] :: Important Security Pat

    One of the problems I ran into which made the red error message stay on top and which made my online catalog page become blank is that I installed the patch files into INCLUDES, not ADMIN>INCLUDES.

    The file names are all the same, so it's an easy mistake to make. It was when I moved the output.php that the catalog page went blank.

    So make sure you're copying the files into the include directory in your ADMIN directory (or whatever directory you changed admin to).

    Now I get my catalog page and the red error message goes away.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. security patch - what to do?
    By rich00693 in forum General Questions
    Replies: 2
    Last Post: 29 Jun 2009, 12:22 AM
  2. June 2009 Admin Security Patch vs some Addons/Contributions
    By wilt in forum Zen Cart Release Announcements
    Replies: 0
    Last Post: 24 Jun 2009, 02:28 PM
  3. Security Patch
    By Snotori in forum General Questions
    Replies: 1
    Last Post: 2 Sep 2006, 06:34 PM
  4. 1064 Error after Update Patch and Db patch to latest...
    By colin99 in forum Upgrading from 1.2 to 1.3.x
    Replies: 2
    Last Post: 31 Aug 2006, 04:43 PM
  5. security patch 1.3.0.x what to do?
    By zenartman in forum General Questions
    Replies: 4
    Last Post: 19 Aug 2006, 07:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •