Results 1 to 7 of 7

Hybrid View

  1. #1
    Join Date
    Sep 2009
    Posts
    5
    Plugin Contributions
    0

    Default which version should i choose?

    Hi,

    I am a newbie for Zencart. I have used oscommerce for a while.

    I wanted to write a module for my site. i would like to know which version of zencart should i write?

    i see there are lots of versions like 1.3.0, 1.3.2, 1.3.7, 1.3.8a etc

    the module which i am going to write should work in all these plug-ins.

    can anyone give me an approach for this?

    if module developed for one version works for another?

    please advice...

  2. #2
    Join Date
    Jan 2008
    Posts
    1,711
    Plugin Contributions
    7

    Default Re: which version should i choose?

    Well 1.3.8a is the current version so that's the version to write for. Some people still use 1.3.7 so they will probably want the mod to work for them, even though 1.3.7 is no longer officially supported by the Zen Cart team. Fortunately 1.3.7 and 1.3.8 are quite similar so sometimes a mod will work fine with both versions, but not always. Personally I wouldn't worry about anyone using anything lower than 1.3.7. That's assuming you'll be sharing the mod anyway.

  3. #3
    Join Date
    Sep 2009
    Posts
    5
    Plugin Contributions
    0

    Default Re: which version should i choose?

    Quote Originally Posted by Steven300 View Post
    Well 1.3.8a is the current version so that's the version to write for. Some people still use 1.3.7 so they will probably want the mod to work for them, even though 1.3.7 is no longer officially supported by the Zen Cart team. Fortunately 1.3.7 and 1.3.8 are quite similar so sometimes a mod will work fine with both versions, but not always. Personally I wouldn't worry about anyone using anything lower than 1.3.7. That's assuming you'll be sharing the mod anyway.
    Steven300,

    thank you for the reply.

    i agree with you. but i wanted to make module be compatible with the version which is quite popular with merchants. we are not sure that all merchants might have upgraded from 1.3.0 to 1.3.8a...

    any pointers to get that data?

  4. #4
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: which version should i choose?

    That depends on what sort of module you're writing. What is it?
    It also depends on whether you're going to make the module available for free download via the Free Addons area. Are you?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  5. #5
    Join Date
    Sep 2009
    Posts
    5
    Plugin Contributions
    0

    Default Re: which version should i choose?

    Quote Originally Posted by DrByte View Post
    That depends on what sort of module you're writing. What is it?
    It also depends on whether you're going to make the module available for free download via the Free Addons area. Are you?
    its a Payment Module.

    ofcourse. Module will be available for free download via the free add-ons.

  6. #6
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: which version should i choose?

    Best to write for v1.3.8a.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  7. #7
    Join Date
    Sep 2009
    Posts
    5
    Plugin Contributions
    0

    Default Re: which version should i choose?

    Quote Originally Posted by DrByte View Post
    Best to write for v1.3.8a.
    Thank you DrByte.

    I will start on it. by the way, is there any unit test cases for testing zencart functionality?

 

 

Similar Threads

  1. Can I download and use templates for older version on current version?
    By ronron in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 13 Mar 2009, 12:29 PM
  2. anyway to choose what is new ?
    By netuser in forum Templates, Stylesheets, Page Layout
    Replies: 3
    Last Post: 26 Jun 2008, 05:29 PM
  3. Choose only 5 of 30 checkboxes..possible?
    By Banhi in forum Setting Up Categories, Products, Attributes
    Replies: 2
    Last Post: 18 Jan 2008, 07:19 AM
  4. Get rid of 'Please choose:'
    By busymum in forum Setting Up Categories, Products, Attributes
    Replies: 2
    Last Post: 11 Sep 2007, 03:55 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •