Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2008
    Posts
    7
    Plugin Contributions
    0

    Default What versions of xampp to use?

    So i purchased the manual. Didn't know that i would have to download something like xampp. thought i would just download zencart and it would have everything there for me.

    Manual says on page 33 to download xampp version 1.4.16 from october 2005. is that the version i should download or should i download the newest version? also if i do download the new version, will the manual i purchased still be relevant? and if i download the newest version, will i have to go back and install the patch to fix the apparent PHP compatibility problem mentioned in many posts?

    i read all the posts, but none of the posts conclusively say what version of xampp to use. just want to make sure i do it correctly from the start.

    last, is there anyone in the Dallas/fort worth area that has done a setup on local host before? maybe would want to make some extra coin.

  2. #2
    Join Date
    Dec 2006
    Location
    Seligman, MO U.S.A.
    Posts
    2,124
    Plugin Contributions
    6

    Default Re: What versions of xampp to use?

    Always get the latest (stable) version.
    Teach them to shop and they will shop today;
    Teach them to Zen and they will OWN a shop tomorrow!

  3. #3
    Join Date
    Dec 2008
    Posts
    7
    Plugin Contributions
    0

    Default Re: What versions of xampp to use?

    will the manual still be correct?

    will i need to install the PHP patch as mentioned in other threads?

    Surprised the author has not made a 2nd edition.

  4. #4
    Join Date
    Dec 2006
    Location
    Seligman, MO U.S.A.
    Posts
    2,124
    Plugin Contributions
    6

    Default Re: What versions of xampp to use?

    Don't know about zampp, as I use wamp, but it's version 2.0 and works perfectly right after install, and I've never had to install anything else.

    I would think, though that with the new version you should be good to go.

    Hope this helps.
    Teach them to shop and they will shop today;
    Teach them to Zen and they will OWN a shop tomorrow!

  5. #5
    Join Date
    Oct 2006
    Posts
    625
    Plugin Contributions
    0

    Default Re: What versions of xampp to use?

    The XAMPP version recommended in the book gives the least headaches and gets you started faster. Versions later than that may require manual adjustments (port conflicts, PHP bugs, etc) and patches (e.g. PHP 5.3 patch for Zen Cart).

    Thus you can try installing the latest XAMPP version and then patch your Zen Cart installation manually and make any required adjustments by doing a search in the forums. Be prepared to spend some time on the whole process as it is difficult to troubleshoot something without access to your local PC.

    Note that the book's contents will still be relevant to a Zen Cart store regardless of your XAMPP version. Similarly, you can try out other AMP packages like WAMP or MAMP and get them to work with Zen Cart.
    Goh Koon Hoek, author of "e-Start Your Web Store with Zen Cart".
    Printed book: www.lulu.com/content/10576284
    Electronic book and Errata: www.cucumbermedia.com/store

  6. #6
    Join Date
    Jan 2004
    Posts
    60,178
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: What versions of xampp to use?

    Quote Originally Posted by jshurbet View Post
    So i purchased the manual. Didn't know that i would have to download something like xampp. thought i would just download zencart and it would have everything there for me.
    Or, you could skip the localhost install altogether, and just put it directly on a real webserver.
    There's nothing saying "you must" install on a local PC first. You'll want all the *files* on your PC, but you don't *need* to set your PC up as a webserver at all. That's what real webservers are for, not PCs.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Which versions work with ZC?
    By ckosloff in forum Installing on a Windows Server
    Replies: 2
    Last Post: 6 May 2007, 04:56 AM
  2. Which PHP/MySQL versions?
    By dugawug in forum Installing on a Linux/Unix Server
    Replies: 5
    Last Post: 10 Mar 2007, 02:32 AM
  3. planed changes for new versions ?
    By snarkys in forum General Questions
    Replies: 2
    Last Post: 5 Sep 2006, 04:49 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •