Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2010
    Posts
    6
    Plugin Contributions
    0

    Default blank page after editing the 2 configure.php files

    I have searched the forums and tutorials and can't seem to find a solution. After getting a private SSL and making sure it worked I edited the 2 configure.php files in includes and admin/includes. Immediately afterwards I received a blank page and i KNOW I have edited the files correctly, making sure I left the ' where they belong. I then went back and changed it bacl to "false" on both configure.php files. My website is www.maxpsi.com

    below is the configure.php
    Code:
    // Define the webserver and path parameters
      // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com
      // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com
      define('HTTP_SERVER', 'http://www.maxpsi.com');
      define('HTTPS_SERVER', 'https://www.maxpsi.com');
    
      // Use secure webserver for checkout procedure?
      define('ENABLE_SSL', 'false');
    below is the admin/includes/configure.php
    Code:
       * URLs for your site will be built via:  
       *     HTTP_SERVER plus DIR_WS_ADMIN or
       *     HTTPS_SERVER plus DIR_WS_HTTPS_ADMIN or 
       *     HTTP_SERVER plus DIR_WS_CATALOG or 
       *     HTTPS_SERVER plus DIR_WS_HTTPS_CATALOG
       * ...depending on your system configuration settings
       *
       * If you desire your *entire* admin to be SSL-protected, make sure you use a "https:" URL for all 4 of the following:
       */
      define('HTTP_SERVER', 'http://www.maxpsi.com');
      define('HTTPS_SERVER', 'https://www.maxpsi.com');
      define('HTTP_CATALOG_SERVER', 'http://www.maxpsi.com');
      define('HTTPS_CATALOG_SERVER', 'https://www.maxpsi.com');
    
      // Use secure webserver for catalog module and/or admin areas?
      define('ENABLE_SSL_CATALOG', 'false');
      define('ENABLE_SSL_ADMIN', 'false');

    help

  2. #2
    Join Date
    Mar 2004
    Posts
    684
    Plugin Contributions
    0

    Default Re: blank page after editing the 2 configure.php files

    http://www.zen-cart.com/index.php?ma...roducts_id=860

    Install the above debugging tool from DrByte - the log file will be written to your cache folder and you can see what line the error is on - hopefully that helps.

  3. #3
    Join Date
    Apr 2010
    Posts
    6
    Plugin Contributions
    0

    Default Re: blank page after editing the 2 configure.php files

    yea what ever this means

    Code:
    12-Apr-2010 16:09:11] PHP Warning:  require(includes/functions/compatibility.php) [<a href='function.require'>function.require</a>]: failed to open stream: No such file or directory in /home6/maxpsico/public_html/includes/init_includes/init_file_db_names.php on line 34
    [12-Apr-2010 16:09:11] PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required 'includes/functions/compatibility.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home6/maxpsico/public_html/includes/init_includes/init_file_db_names.php on line 34

  4. #4
    Join Date
    Mar 2004
    Posts
    684
    Plugin Contributions
    0

    Default Re: blank page after editing the 2 configure.php files

    It means the file: compatibility.php

    isn't located in the includes/functions/ folder

    Is this a new setup? If so - files are missing especially the one I mentioned above.

  5. #5
    Join Date
    Apr 2010
    Posts
    6
    Plugin Contributions
    0

    Default Re: blank page after editing the 2 configure.php files

    upon closer examination, this is what I have found...

    many of my folders do not show up as a folder in cpanel's file manager AS folders. but when you click on them you see the file names but 0 bytes and they have permissions set to 444.
    When I try to reupload them via filezilla it says Critical file transfer error.

    its been running for several months

 

 

Similar Threads

  1. Blank Screen on Step 2 of the Checkout Process after editing files in dreamweaver
    By cyberfrog in forum Built-in Shipping and Payment Modules
    Replies: 9
    Last Post: 18 Apr 2012, 11:46 PM
  2. Replies: 2
    Last Post: 27 Mar 2011, 03:01 PM
  3. Urgent help required.. Website all blank after editing configure.php to add SSL
    By hamid84 in forum Templates, Stylesheets, Page Layout
    Replies: 15
    Last Post: 24 Mar 2010, 12:02 AM
  4. blank page after editing english.php?
    By ctag in forum General Questions
    Replies: 3
    Last Post: 2 Mar 2010, 04:25 AM
  5. Getting Blank Page On Checkout after editing files with RTF editor
    By breck in forum Upgrading from 1.3.x to 1.3.9
    Replies: 36
    Last Post: 25 May 2008, 06:32 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg
Zen-Cart, Internet Selling Services, Klamath Falls, OR