Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Apr 2007
    Posts
    37
    Plugin Contributions
    0

    Default Categories - What am I missing?

    I'm using 1.3.8a

    I havent done any upgrading recently.

    I know there is a setting somewhere in Admin, but I am totally missing it.

    How do you set the categories so that if you click on a main category and you have sub-categories, the subs show up on the main category's page.

    IE I have yarn as a main category, under that I have by Brand, and By Yarn Weight.

    Under By Brand I have 2 different brands so far.

    So, for example, when I select By Brand, I should see both brands on the page as well as in the navigation on the left side. If you want to see what I mean

    http://www.greatyarns.com/shop

    If you click on Yarn and then by brand, you will notice that nothing shows up on the page. But the navigation shows the 2 brands.

    What am I missing?

  2. #2
    Join Date
    Aug 2005
    Posts
    26,425
    Plugin Contributions
    9

    Default Re: Categories - What am I missing?

    Might you have produvts under yarn and then additional subcats also?

    Yarn->
    By Brand->
    Prism
    Trendsetter Yarns
    Zen-Venom Get Bitten
    Get Your Business Found

  3. #3
    Join Date
    Apr 2007
    Posts
    37
    Plugin Contributions
    0

    Default Re: Categories - What am I missing?

    Yes I would have those sub categories too!

  4. #4
    Join Date
    Aug 2005
    Posts
    26,425
    Plugin Contributions
    9

    Default Re: Categories - What am I missing?

    Yes I would have those sub categories too!
    So if you got what I asked correctly that might be the issue

    Quote Originally Posted by Tutorial
    Note: Subcategories can hold sub-subcategories or products, but not both at the same level.
    Check again that whare you have products, that you have NO subcats under it
    Zen-Venom Get Bitten
    Get Your Business Found

  5. #5
    Join Date
    Aug 2005
    Posts
    26,425
    Plugin Contributions
    9

    Default Re: Categories - What am I missing?

    ???Doubled up same post somehow???
    Zen-Venom Get Bitten
    Get Your Business Found

  6. #6
    Join Date
    Apr 2007
    Posts
    37
    Plugin Contributions
    0

    Default Re: Categories - What am I missing?

    Quote Originally Posted by kobra View Post
    So if you got what I asked correctly that might be the issue


    Check again that whare you have products, that you have NO subcats under it

    There are not categories with products and Sub cats. All Categories either have a sub category or products.. never mixed. I know that much. I have been using Zen Cart on my own site for more than 5 years. This is a clients cart.

    Is there some one out there that can give me a straight answer? PLEASE?
    Last edited by KRW Knitwear; 12 May 2010 at 01:58 PM.

  7. #7
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    66,837
    Plugin Contributions
    6

    Default Re: Categories - What am I missing?

    In the view source I am seeing:
    <!-- BOF: Display grid of available sub-categories, if any -->
    <!-- hsyong remove categories thumbnails -->

    <!-- EOF: Display grid of available sub-categories -->
    This makes me think that the display of the categories has been removed or commented out in your template ...

    If you were to switch to Classic Template ... do they reappear?

    If so, do a search in the Tools ... Developers Tool Kit ... in the bottom input box for:
    category_row

    select Catalog ... and click SEARCH ...

    Do you see a reference to calls to the category_row that have been commented out ... the lines would be commented with two forward slashes // at the beginning of the line ...

    These should be in your template and override files and you should be able to remove the commented out lines to get them back ...

    Also check the setting Configuration ... Product Listing ...
    Show SubCategories on Main Page while navigating
    Show Sub-Categories on Main Page while navigating through Categories

    0= off
    1= on
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.1]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...

  8. #8
    Join Date
    Apr 2007
    Posts
    37
    Plugin Contributions
    0

    Default Re: Categories - What am I missing?

    Hi Linda!

    The categories did come back when I went back to the classic template.

    I did the search like you mentioned and this is what I got. Do you see anything? The only thing I see are "*" in the code. Could that be it?



    Also, in the Configuration>Product Listing, Those settings are missing.

  9. #9
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    66,837
    Plugin Contributions
    6

    Default Re: Categories - What am I missing?

    Look at the two tpl_index_categories.php files ... the one for template_default has the code for the rows and the one for your template does not ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.1]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...

  10. #10
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    21,831
    Plugin Contributions
    25

    Default Re: Categories - What am I missing?

    Search on
    hsyong remove categories thumbnails
    for many threads about this problem, and the exact solution (code to copy).

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Missing Some Sub-categories .... Help
    By Horrific_ending in forum General Questions
    Replies: 14
    Last Post: 6 Dec 2009, 01:54 AM
  2. New Categories Button Missing
    By DUB305 in forum General Questions
    Replies: 1
    Last Post: 29 Jun 2009, 07:01 AM
  3. Missing Categories Button
    By Kylo in forum Basic Configuration
    Replies: 2
    Last Post: 25 Sep 2008, 04:57 PM
  4. data goes missing from the categories
    By raunharman in forum General Questions
    Replies: 1
    Last Post: 26 Jul 2008, 05:28 PM
  5. Missing categories
    By wizzie in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 30 Dec 2006, 04:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •