Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2008
    Posts
    3
    Plugin Contributions
    0

    Default [Not a bug] Admin orders product name search is missing wildcard

    OK, maybe not a bug as such, but probably not the intent ?

    Seen in 1.3.8 and still in 1.3.9d.

    ./admin/orders.php

    line 716 (in 1.3.9d):

    $search = " and (op.products_model like '%" . $keywords . "%' or op.products_name like '" . $keywords . "%')";
    does not allow a search match in all parts of product name as leading wildcard is missing on keyword. Can be solved by adding in % as:

    $search = " and (op.products_model like '%" . $keywords . "%' or op.products_name like '%" . $keywords . "%')";
    Note: For 1.3.8, then you need to of applied bugfix http://www.zen-cart.com/forum/showpo...7&postcount=18 for the 'Search by Product Name' field to work.


  2. #2
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    67,639
    Plugin Contributions
    6

    Default Re: Admin orders product name search is missing wildcard

    That was by design not a bug so that Product Name searches had to begin with the search word ...

    Many sites will find the first word more useful on a search of a Product than searching within a Product Name ...

    If you need for your specific site this change would do as you have stated ...

    As to making it part of the default setting in Zen Cart, at this time it would really need to be considered as previous checks on large database tables have found that to be more of a bother than a help ...

    Thanks for the suggesting!
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.3]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...

 

 

Similar Threads

  1. Replies: 3
    Last Post: 21 Jun 2010, 05:08 PM
  2. Replies: 11
    Last Post: 9 Sep 2008, 03:21 AM
  3. Orders Missing In Admin!
    By Billyboy in forum Managing Customers and Orders
    Replies: 2
    Last Post: 21 Jul 2007, 08:09 PM
  4. Missing orders & customer record in Admin
    By marvin in forum Managing Customers and Orders
    Replies: 16
    Last Post: 1 Jul 2006, 05:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •