Results 1 to 7 of 7
  1. #1
    Join Date
    Feb 2006
    Location
    Chicago
    Posts
    1,167
    Plugin Contributions
    0

    Default Upgrading from 1.3.8 to 1.3.9d

    Is it recommended to use tortoise svn or any other sub version system to upgrade the existing 1.3.8 (but modified) version to 1.3.9d?

    Also, is winmerge enough/sufficient for this?
    Are there any good 3 way merging tool people use or recommend?

    Free or paid ones......please put your experiences
    Thanks
    Tutorials on Zen Cart
    http://tutorials.zen-cart.com/index.php
    ---------------
    advanced.programmer at gmail dot com
    In love with Zen Cart!!

  2. #2
    Join Date
    Jan 2004
    Posts
    60,406
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Upgrading from 1.3.8 to 1.3.9d

    http://www.zen-cart.com/wiki/index.p...arison_Utility

    Also, I suggest that you upgrade to 1.3.9e, not just "d".
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Feb 2006
    Location
    Chicago
    Posts
    1,167
    Plugin Contributions
    0

    Default Re: Upgrading from 1.3.8 to 1.3.9d

    No subversion system is recommended?
    Tutorials on Zen Cart
    http://tutorials.zen-cart.com/index.php
    ---------------
    advanced.programmer at gmail dot com
    In love with Zen Cart!!

  4. #4
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: Upgrading from 1.3.8 to 1.3.9d

    Subversion doesn't play any part in a Zen Cart upgrade, unless that's how you keep track of your own changes.
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  5. #5
    Join Date
    Feb 2006
    Location
    Chicago
    Posts
    1,167
    Plugin Contributions
    0

    Default Re: Upgrading from 1.3.8 to 1.3.9d

    Oh so if you have a modification done on version 1.3.8a say for instance and you want to upgrade to 1.3.9e without loosing those changes, whats the best way to do it? Manually using a 3 way editor?
    Tutorials on Zen Cart
    http://tutorials.zen-cart.com/index.php
    ---------------
    advanced.programmer at gmail dot com
    In love with Zen Cart!!

  6. #6
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: Upgrading from 1.3.8 to 1.3.9d

    Yes. Personally I like Beyond Compare which incorporates comparison (including with remote sites via FTP) and basic editing.
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  7. #7
    Join Date
    Jan 2004
    Posts
    60,406
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Upgrading from 1.3.8 to 1.3.9d

    Quote Originally Posted by superprg View Post
    Oh so if you have a modification done on version 1.3.8a say for instance and you want to upgrade to 1.3.9e without loosing those changes, whats the best way to do it? Manually using a 3 way editor?
    Yes. That's why all the documented upgrade instructions tell you to do it by hand, comparing file to identify your customizations, and then copy those customizations into the new files.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Replies: 3
    Last Post: 19 Jun 2008, 12:44 AM
  2. Upgrading from 1.2.4 to 1.3.8
    By micatex in forum Upgrading from 1.2 to 1.3.x
    Replies: 2
    Last Post: 14 May 2008, 03:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •