Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2005
    Posts
    178
    Plugin Contributions
    0

    Default Some attribute types don't show on multi-language site

    Is there a bug with certain attribute types when using multiple languages?

    We're working on the site, and my client has added a File option and a Textarea option. These show fine in Spanish (the default language), but when you switch to English, those two option names remain, but the form fields themselves disappear (they aren't even in the code). We haven't made any customizations to the attributes module.

    The pulldown menu is working fine.

    You can see this in action here:

    n a r a n j a s.dreamhosters.com/index.php?main_page=product_info&products_id=18&language=en

    n a r a n j a s.dreamhosters.com/index.php?main_page=product_info&products_id=18&language=es

    Version 1.3.9d

    Using these add-ons:

    image_handler__for_vx_Ver2-0Rev8b
    column/grid layout,
    languagecurrency_links_in_header_1-0
    multilanguage ezpages
    multi cross sell

    Thanks in advance!

  2. #2
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    67,556
    Plugin Contributions
    6

    Default Re: Some attribute types don't show on multi-language site

    Go to phpMyAdmin and do a search of the table:
    products_options_values

    for the:
    products_options_values_name

    that reads:
    TEXT

    and see how many records you have and their language_id value ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.3]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...

  3. #3
    Join Date
    Mar 2005
    Posts
    178
    Plugin Contributions
    0

    Default Re: Some attribute types don't show on multi-language site

    Yippee! I only had one TEXT entry, for the Spanish language, so I made one for English and it's fine now. Is this something we messed up in the admin?

  4. #4
    Join Date
    Sep 2003
    Location
    Ohio
    Posts
    67,556
    Plugin Contributions
    6

    Default Re: Some attribute types don't show on multi-language site

    Somewhere along the way it was lost ... unfortunately that is hard to pinpoint ...

    Thanks for the update that you were able to fix it ...

    NOTE: since you had a language problem you should check your other database tables and ensure that you have the same number of records for each language to make sure that nothing else is out of wack ...
    Linda McGrath
    If you have to think ... you haven't been zenned ...

    Did YOU buy the Zen Cart Team a cup of coffee and a donut today? Just click here to support the Zen Cart Team!!

    Are you using the latest? Perhaps you've a problem that's fixed in the latest version: [Upgrade today: v1.5.3]
    Officially PayPal-Certified! Just click here

    Try our Zen Cart Recommended Services - Hosting, Payment and more ...

 

 

Similar Threads

  1. 139c multi language dont show
    By stefanl in forum Upgrading from 1.3.x to 1.3.9
    Replies: 0
    Last Post: 4 Jun 2010, 09:31 AM
  2. multi language button image in header, links to multi language pages
    By bluesky2008 in forum Templates, Stylesheets, Page Layout
    Replies: 0
    Last Post: 31 Jul 2008, 04:14 PM
  3. How to set a default country per language for multi language sites
    By lacabessa in forum Addon Language Packs
    Replies: 2
    Last Post: 18 Nov 2006, 11:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •