Page 3 of 23 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 225
  1. #21
    Join Date
    Jan 2008
    Location
    Chevreuse, France
    Posts
    273
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    I reinstalled the language paypal.php file from 1.3.9f and all is back in order.
    Pete
    zc 1.3.9h
    www.gardenserre.fr

  2. #22
    Join Date
    Jan 2008
    Posts
    90
    Plugin Contributions
    0

    Default Re: 139g weird problem define pages editor

    Quote Originally Posted by wilt View Post
    Are you talking about the define pages, or some other preview ???
    I haven't used the Define Pages since the update yet. Honestly, I'm a little hesitant to do so. I'm referring to the Product Preview page that you get after you add a new product.

    Will your whitelist fix that or should I just wait for something more permanent?

  3. #23
    Join Date
    May 2010
    Location
    London
    Posts
    250
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Hello

    I just downloaded and installed a clean copy of 1.3.9g.
    Same problem of HTML tags showing on the product preview pages (admin side) and define_main_pages (store side)

    I installed CKEditor by: Kuroi
    same problmes outlined above

    I then applied Wilts patch.
    This fixed the problems of HTML tags appearing on define_main_pages (store side) when using both HTMLarea and CKEditor.

    One thing that worried me is delia's comment of "Creating a whole 'nother file that will be obsolete soon is not a great option for me". Is the Wilt patch just a quick fix?
    If so, i think i will wait for 1.3.9g1 or 1.3.9h before upgrading my live shop.

    Because "Some contributions may be affected, and if so the entry boxes affected in those contributions may need whitelisting in a similar manner to the above, but array('file_contents'); will need to be changed to add the name attribute of the form entry box - wilt" goes over my head, and i have about 30+ add-ons installed.

  4. #24
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: HTML tags show after upgrade to 1.3.9g

    Folks, the PRODUCT PREVIEW page display issue is NOT a bug.
    While you may dislike the way the preview shows, it is unfortunately necessary in order to protect YOU against XSS attacks on your admin area.
    Clicking Save on the product-preview screen SAVES IT PROPERLY.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  5. #25
    Join Date
    May 2010
    Location
    London
    Posts
    250
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Mr Byte, is the Wilt fix a permanent fix for the define_main_pages bug and going to be added to 1.3.9g or 1.3.9h fileset, therefore upgrading to 1.3.9g now is OK.

    Or should I wait a while for further news on this?

    Thanks
    Michael

  6. #26
    Join Date
    May 2006
    Location
    Charlottesville VA
    Posts
    1,431
    Plugin Contributions
    20

    Default Re: HTML tags show after upgrade to 1.3.9g

    Dr. Byte, please speak to the problem of the define pages not showing correctly on the client side. What I'm hearing so far is that the extra file has to be added for the define pages. Is this a permanent solution? A bug? Please clarify because this has made using the define pages impossible for the average cart owner.

  7. #27
    Join Date
    Aug 2005
    Posts
    26,507
    Plugin Contributions
    9

    Default Re: HTML tags show after upgrade to 1.3.9g

    Quote Originally Posted by dutchy
    Mr Byte, is the Wilt fix a permanent fix for the define_main_pages bug
    Quote Originally Posted by delia
    Dr. Byte, please speak to the problem of the define pages not showing correctly on the client side.
    I think this is clear...
    Quote Originally Posted by DrByte
    While you may dislike the way the preview shows, it is unfortunately necessary in order to protect YOU against XSS attacks on your admin area.
    Clicking Save on the product-preview screen SAVES IT PROPERLY.
    Zen-Venom Get Bitten
    Get Your Business Found

  8. #28
    Join Date
    May 2010
    Location
    London
    Posts
    250
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    Sorry Kobra. I don't mean to be rude, but if it were clear, two of use would not have felt the need to ask if this fix is permanent and we are good to go.

    "yes/no this is/isn't a permanent fix for the define_main_pages " is clear

  9. #29
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: HTML tags show after upgrade to 1.3.9g

    Yes. Treat it as a "permanent" fix.

    For now.


    There are numerous other far more important fixes in 1.3.9g that warrant the upgrade. Don't hold it off just for this trivial issue. Use the fix supplied.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #30
    Join Date
    May 2010
    Location
    London
    Posts
    250
    Plugin Contributions
    0

    Default Re: HTML tags show after upgrade to 1.3.9g

    brilliant, thanks for the top work!
    I shall not delay in 1.3.9g upgrade.

 

 
Page 3 of 23 FirstFirst 1234513 ... LastLast

Similar Threads

  1. Plain text is adding HTML tags
    By eVelt in forum General Questions
    Replies: 13
    Last Post: 8 Jul 2010, 10:15 PM
  2. HTML tags not working in main product page?
    By scottmcclean in forum Setting Up Categories, Products, Attributes
    Replies: 5
    Last Post: 14 Sep 2009, 03:34 PM
  3. Replies: 5
    Last Post: 22 Jan 2009, 10:23 AM
  4. html tags i product listing
    By procella in forum Templates, Stylesheets, Page Layout
    Replies: 5
    Last Post: 21 Oct 2008, 02:21 PM
  5. Replies: 4
    Last Post: 7 Jul 2008, 12:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •