Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Admin page weird

    Hello,

    Just installed zencart for the first time and all went well (after changing host). However, when I make the customised changes to the admin files - as requested just after installing - I can only get access to a page which says "index of/name" (where name is the new name of the admin file) and gives me a link to the parent directory - the main domain index page.

    I've never yet seen teh admin page so I don't even know what to expect here.

    Any help appreciated

  2. #2
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,658
    Plugin Contributions
    3

    Default Re: Admin page weird

    You should see the admin login boxes.

    Any time you see the index of ... page, it means you don't have an index file in the directory you pointed your browser to.

    I would guess you don't have the right directory name specified in the configure file. Did you change the 'admin' to your new admin folder name in all three places in admin/includes/configure.php ?

  3. #3
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    I followed the instructions exactly - only changing the three names requested. I've looked over and over in case there is a silly error - but I seem to have done exactly as requested.

  4. #4
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    I also cahnged the admin directory name to correspond - again as requested.

  5. #5
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    I found another directory created on the server with the same name but empty - so deleted it.

    Now when I direct to the newly named "admin" file I just get "page not found".

    Going around in circles here. Wouldn't mind but it's been going on for several hours now.

  6. #6
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    If I write the complete address (which includes the "/zencart/name/" then I get the following...


    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@valproshop.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

  7. #7
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,658
    Plugin Contributions
    3

    Default Re: Admin page weird

    Just so I understand:

    Your Zencart installation is http: //www.yoursite.com/zencart

    You changed your admin folder name to, say, newadmin.

    You edited admin/includes/configure.php to change the 'admin' to 'newadmin' in three places and uploaded it back to the server. Be sure you're editing the right configure.php file. There are two, one in admin/includes, and one in /includes.

    You directed your browser to http: //www.yoursite.com/zencart/newadmin

    and you get a 404 Page Not Found ?

    Try http: //www.yoursite.com/zencart/newadmin/index.php.

    If that doesn't work, your files must not be in that folder.

  8. #8
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    same error comes up - but that does seem to be the folder!

    I remaned it back to admin for now so the full address is
    http://www.valproshop.com/zencart/admin/index.php

  9. #9
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    it's that admin/includes configure file that I edited.

    I'm thinking tah perhaps I should just rip it all out and start again - but I can't see anythign that I'd do differently - I just followed the instructions and don't think I did anything different.

  10. #10
    Join Date
    Nov 2010
    Posts
    83
    Plugin Contributions
    0

    Default Re: Admin page weird

    I'm goin to give myself a time limit for this - if I still can't get anywhere by next monday morning than I'll give up. I've already spent a week just getting the servers organised to get this far - VERY frustrating.

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Weird characters on admin screen
    By infocom in forum General Questions
    Replies: 5
    Last Post: 15 Oct 2010, 07:59 PM
  2. Weird Problem/Malfunction in my Admin
    By liharts in forum General Questions
    Replies: 4
    Last Post: 27 Jan 2010, 01:11 AM
  3. Help Zen admin gone weird
    By Shiftypow in forum Basic Configuration
    Replies: 4
    Last Post: 31 Jan 2007, 02:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •