Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Nov 2010
    Posts
    9
    Plugin Contributions
    0

    Default Upgrade from 1.3.7 to 1.3.9 ?

    Hello,

    I'm new to this forum, I have version zencart 1.3.7 ... I have never upgraded, and I really need/want to.

    Is there a link or readme file that explains in detail, how to upgrade from 1.3.7 to 1.3.9 ? I have found some upgrade steps, but i'm not sure it this is for my OLD version to upgrade to the NEW version. I can follow the steps, I just want to make sure these are the RIGHT steps for my Version.

    Any help would be greatly appreciated :) THANK YOU

  2. #2
    Join Date
    Aug 2005
    Posts
    26,512
    Plugin Contributions
    9

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    how to upgrade from 1.3.7 to 1.3.9
    Steps are the same only compiling a list of all the files that have changed is a bit harder

    Then only if you have used the tempate override system for all of your customized files will it be simpler...
    If you have not, first thing to do is get a fresh version of what you are using now and a set of the files your shop is using all on your local.

    Run a file compare on these 2 sets to locate what core files you might have edited and to preserve these changes

    Then a fresh install of 1.3.9h with a new database and follow the tutorial from there

    http://tutorials.zen-cart.com/index.php?article=108
    Zen-Venom Get Bitten
    Get Your Business Found

  3. #3
    Join Date
    Nov 2010
    Posts
    9
    Plugin Contributions
    0

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    Thank you!

    Also, when someone uses PayPal IPN, I receive an email saying the money has been sent, but It does not update in my orders log. Would you know how to fix this?

    Thanks in advance.

  4. #4
    Join Date
    Aug 2005
    Posts
    26,512
    Plugin Contributions
    9

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    but It does not update in my orders log. Would you know how to fix this?
    Not if 1.3.7 as I have not had a copy of that loaded since 2007
    Zen-Venom Get Bitten
    Get Your Business Found

  5. #5
    Join Date
    Jan 2004
    Posts
    60,565
    Blog Entries
    4
    Plugin Contributions
    145

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    Quote Originally Posted by video2402 View Post
    Thank you!

    Also, when someone uses PayPal IPN, I receive an email saying the money has been sent, but It does not update in my orders log. Would you know how to fix this?

    Thanks in advance.
    Upgrade, and switch to Express Checkout instead of IPN. It's much more reliable.

    In the meantime you can try many things to sort out your IPN problems: http://www.zen-cart.com/wiki/index.php/PayPal
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6
    Join Date
    Nov 2010
    Posts
    9
    Plugin Contributions
    0

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    I'll be honest... I'm completely lost when it comes to upgrading (I don't want to mess anything up) Is there anyone I could pay to convert everything?

  7. #7
    Join Date
    Nov 2010
    Posts
    9
    Plugin Contributions
    0

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    Quote Originally Posted by DrByte View Post
    Upgrade, and switch to Express Checkout instead of IPN. It's much more reliable.

    In the meantime you can try many things to sort out your IPN problems: http://www.zen-cart.com/wiki/index.php/PayPal

    I receive some payments correctly, but some go unnoticed, and then I have to ask the customers what they ordered. So, some of them are working properly.... This started just yesterday by the way.

  8. #8
    Join Date
    Nov 2010
    Posts
    9
    Plugin Contributions
    0

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    Quote Originally Posted by DrByte View Post
    Upgrade, and switch to Express Checkout instead of IPN. It's much more reliable.

    In the meantime you can try many things to sort out your IPN problems: http://www.zen-cart.com/wiki/index.php/PayPal
    I have switched to Express Checkout, I did everything right, but now I get a few errors

    "Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /home/designsn/public_html/includes/modules/payment/paypalwpp.php on line 1467

    Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /home/designsn/public_html/includes/modules/payment/paypalwpp.php on line 1467

    Fatal error: Call to undefined function curl_init() in /home/designsn/public_html/includes/modules/payment/paypal/paypal_curl.php on line 333"


    Did I do something wrong?

  9. #9
    Join Date
    Jan 2004
    Posts
    60,565
    Blog Entries
    4
    Plugin Contributions
    145

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    Expres Checkout requires CURL to be available on your server. Most reputable hosting companies have this available, already compiled into PHP with OpenSSL. If yours doesn't, you're stuck.

    As for the array_merge error messages, those were fixed in newer versions of Zen Cart ... so upgrading will fix those for you.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #10
    Join Date
    Nov 2010
    Posts
    9
    Plugin Contributions
    0

    Default Re: Upgrade from 1.3.7 to 1.3.9 ?

    Quote Originally Posted by DrByte View Post
    Expres Checkout requires CURL to be available on your server. Most reputable hosting companies have this available, already compiled into PHP with OpenSSL. If yours doesn't, you're stuck.

    As for the array_merge error messages, those were fixed in newer versions of Zen Cart ... so upgrading will fix those for you.
    That's what I figured, I will attempt this

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. upgrade 1.3.9d to e my admin area still says i need to upgrade
    By cjbwebs in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 5 Aug 2010, 10:31 AM
  2. 1.3.7 upgrade to 1.3.8 - database upgrade failing
    By hollygds in forum Upgrading from 1.3.x to 1.3.9
    Replies: 5
    Last Post: 29 Sep 2009, 02:53 PM
  3. upgrade cfg files or database upgrade???
    By waghelak in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 11 Sep 2006, 02:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •