Results 1 to 5 of 5
  1. #1
    Join Date
    Dec 2008
    Posts
    16
    Plugin Contributions
    0

    Default System setup required after upgrade 1.2.7 to 1.3.9h

    Hi Zenners,

    Im just starting to lose it..
    Just spend about 6 hours to upgrade a very old V1.2.7 zen cart to the latest 1.3.9H.

    I followed all stepd in the 123 easy upgrade tutorial.
    I can start the upgrade and beside a few minor statements the upgrade has performed succesfully.

    But when I click on goto your store I get:

    Hello. Thank you for loading Zen Cart™.
    You are seeing this page for one or more reasons:
    1.This is your first time using Zen Cart™ and you haven't yet completed the normal Installation procedure.
    If this is the case for you, Click here to begin installation.


    2.Your /includes/configure.php and/or /admin/includes/configure.php file contains invalid path information and/or invalid database-connection information.
    If you recently edited your configure.php files for any reason, or maybe moved your site to a different folder or different server, then you'll need to review and update all your settings to the correct values for your server.
    See the Online FAQ and Tutorials area on the Zen Cart™ website for assistance.
    3.Additional Details: includes/configure.php file contents invalid. ie: DIR_FS_CATALOG not valid or not set

    I have tried everything:

    restored the DB backup several times.
    installes with and without DB prefix
    checked the config files a million times
    I even tried to upgrade from 1.2.7 to 1.30 first (still the same)
    What an I doing wrong??

    Please help....

  2. #2
    Join Date
    Aug 2005
    Posts
    26,507
    Plugin Contributions
    9

    Default Re: System setup required after upgrade 1.2.7 to 1.3.9h

    Step #1
    Unzip a copy of the new version of Zen Cart™, upload it to your webserver into a "demo" folder, and install the new version into a separate database
    You end up with a new version - -seems that you have not done this
    Zen-Venom Get Bitten
    Get Your Business Found

  3. #3
    Join Date
    Sep 2008
    Location
    Toronto, Ontario, Canada
    Posts
    482
    Plugin Contributions
    0

    Default Re: System setup required after upgrade 1.2.7 to 1.3.9h

    Why not just do a complete rebuild from the ground up with the new version?

    This is what I did and I just installed the easy populate mod - WHAT A TOOL!

    I'll be able to build my catelogue in no time with this - not to mention keep it maintained.

    Make up a back up of some of the stuff you have so you can transfer it over as needed - ie you .css styles
    [FONT="Comic Sans MS"]After looking at computer code for a while - I think I'm going crazy but the voice in my head assures me that I'm not! [/FONT]http://www.jecphotography.com/mystore

  4. #4
    Join Date
    Mar 2006
    Location
    New Zealand
    Posts
    89
    Plugin Contributions
    0

    Default Re: System setup required after upgrade 1.2.7 to 1.3.9h

    Janissaire...

    How long did it take you? I have to do mine as well and have been putting it off and putting it off...
    Elemi

    The Art of Bespoke Aromatherapy
    www.AmorAromatherapy.co.nz

  5. #5
    Join Date
    Jan 2004
    Location
    N of San Antonio TX
    Posts
    5,473
    Plugin Contributions
    6

    Default Re: System setup required after upgrade 1.2.7 to 1.3.9h

    Elemi,

    The degree of difficulty in upgrading a cart really has little to do with the number of products, customers, etc.

    If the cart was built with a proper foundation (custom template), one can upgrade a cart to a new version in a few hours. That's because most PROPER customization is not touched during upgrade.

    A few mods touch what we call "Core Files" and will have their changes overwritten on upgrade. Personally, I think there should be a new item in the Free Software Add Ons that identifies if a mod changes core files just as it tells you if the mod is PHP 5.3 compatible.

    All that said, upgrading from 1.2 to 1.3 is really a major jump and should probably be done with a complete new installation. Starting fresh with proper customization with make later upgrades enormously easier.

    Upgrading to 1.3.9 from 1.3.8 is really no big deal IF the foundation of 1.3.8 was done correctly on install. That's one of the reasons the team advises against automated installs like Fantastico.

    Bottom line is... Follow the 3 easy steps at http://tutorials.zen-cart.com/index.php?article=108 and you will have an upgraded cart in little time. DO NOT SKIP ANY PART OF STEP 1.

    Most of the upgrade nightmares are caused from not following the steps line by line. Shortcuts to save minutes cost hours on upgrade.
    Did you read the posting tips?!?

 

 

Similar Threads

  1. 'System Setup Required' after install error
    By EggDesign in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 7 Sep 2010, 11:07 AM
  2. System Setup Required after attempting to enable SSL
    By joshuacripps in forum Basic Configuration
    Replies: 11
    Last Post: 7 Jan 2010, 03:44 AM
  3. Help - Admin page is showing System Setup Required
    By joannem in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 8 Oct 2009, 10:24 PM
  4. System Setup Required
    By bubblegumgoods in forum Installing on a Windows Server
    Replies: 7
    Last Post: 1 Sep 2008, 09:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •