Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 31 to 40 of 74
  1. #31
    Join Date
    Sep 2011
    Posts
    2
    Plugin Contributions
    0

    Default Re: Time Zone Fix Support Thread

    Quote Originally Posted by PleXy View Post
    I just can't get this mod to work. Tried different timezones just to test if the other timezones works. But nothing, the TZ remains the same.

    Anyone else who had this problem and solved it?

    I spoke with my host and they said it's either something wrong with the script or I did something wrong adding it.
    I defenately added the files correctly.
    I'm having issues too.

    I'm on 1.3.9h and followed the installation instructions exactly.

    Out of interest, what host do you use?

    Can this issues with certain hosts? I'm with One.com.

  2. #32
    Join Date
    Aug 2005
    Location
    Vic, Oz
    Posts
    1,650
    Plugin Contributions
    5

    Default Re: Time Zone Fix Support Thread

    Quote Originally Posted by johndavison View Post
    I'm having issues too.

    I'm on 1.3.9h and followed the installation instructions exactly.

    Out of interest, what host do you use?

    Can this issues with certain hosts? I'm with One.com.
    Works with most tested linux hosts
    I can't tell from their website if they are linux or MS

    By the way
    I'm having issues too.
    really give us NO info to work with.

    What type of server are you on?
    What have you done?
    How have you installed it?
    Which version of zen-cart?
    Which version of this mod did you install?
    What happens?

    In the "readme" there are 3 steps and checks that you should do before proceeding to the next step.
    What step does it beak on and how does it break?

  3. #33
    Join Date
    Nov 2011
    Posts
    5
    Plugin Contributions
    0

    help question Re: Time Zone Fix Support Thread

    Hi,

    I have ZC 1.3.9h installed and working.

    I downloaded the zip file, extracted and edited the 2 files time_zone_fix.php, even thought the doc refers to time_offset.php, uploaded each respective files (3 of them) to the correct folders on the server.

    I see no change in the date/time on my admin home page (section just under the top header.

    What am I doing wrong?

    Thanks.

  4. #34
    Join Date
    Aug 2005
    Location
    Vic, Oz
    Posts
    1,650
    Plugin Contributions
    5

    Default Re: Time Zone Fix Support Thread

    Quote Originally Posted by Vatche View Post
    Hi,

    I have ZC 1.3.9h installed and working.

    I downloaded the zip file, extracted and edited the 2 files time_zone_fix.php, even thought the doc refers to time_offset.php, uploaded each respective files (3 of them) to the correct folders on the server.

    I see no change in the date/time on my admin home page (section just under the top header.

    What am I doing wrong?

    Thanks.
    Before uploading did you rename the YOUR_RENAMED_ADMIN directory so that its the same as whatever your actual admin name is?
    Are you running this local or is it live on a linux server?
    Post the contents of one of your time_zone_fix.php files?

  5. #35
    Join Date
    Nov 2011
    Posts
    5
    Plugin Contributions
    0

    Default Re: Time Zone Fix Support Thread

    Quote Originally Posted by gilby View Post
    Before uploading did you rename the YOUR_RENAMED_ADMIN directory so that its the same as whatever your actual admin name is?
    Are you running this local or is it live on a linux server?
    Post the contents of one of your time_zone_fix.php files?
    I basically edited the files, then ftp each php file to the server at the correct server folders. (linux)

    File located locally:
    tzf_v1.00\139gh\YOUR_RENAMES_ADMIN\includes\extra_configures\time_zone_fix.php

    <?php
    // Full list of timezones here: http://php.net/manual/en/timezones.php
    //
    // You can modify the TZ (Time Zone) by using a named Country/City
    // eg:
    // TZ=America/Los_Angeles
    // TZ=America/Denver;
    // TZ=America/Chicago
    // TZ=America/Costa_Rica;

    putenv ('TZ=Australia/Sydney');

    ?>

    Uploaded to server at:
    secret_admin\includes\extra_configures\time_zone_fix.php

    Done the same with the other 2 files.

    Thanks for the help.

  6. #36
    Join Date
    Aug 2005
    Location
    Vic, Oz
    Posts
    1,650
    Plugin Contributions
    5

    Default Re: Time Zone Fix Support Thread

    goto admin -> version
    Search near the bottom in the "Environment" section
    Confirm that there is a TZ variable there
    and its value is Australia/Sydney

  7. #37
    Join Date
    Nov 2011
    Posts
    5
    Plugin Contributions
    0

    Default Re: Time Zone Fix Support Thread

    Quote Originally Posted by gilby View Post
    goto admin -> version
    Search near the bottom in the "Environment" section
    Confirm that there is a TZ variable there
    and its value is Australia/Sydney
    Just checked, but no, there is no Environment variable TZ.

    Does this mean the file time_zome_fix.php is not being called?

    Thanks.

  8. #38
    Join Date
    Nov 2011
    Posts
    5
    Plugin Contributions
    0

    Default Re: Time Zone Fix Support Thread

    Hi,

    Here is a message when I put the code in index.php

    Warning: putenv() [function.putenv]: Safe Mode warning: Cannot set environment variable 'TZ' - it's not in the allowed list.

    Damn!

  9. #39
    Join Date
    Nov 2011
    Posts
    5
    Plugin Contributions
    0

    Default Re: Time Zone Fix Support Thread

    All good now, got the hosting provider to allow it and now it is working.

    Thanks for your top support!

  10. #40
    Join Date
    Aug 2005
    Location
    Vic, Oz
    Posts
    1,650
    Plugin Contributions
    5

    Default Re: Time Zone Fix Support Thread

    Quote Originally Posted by Vatche View Post
    Hi,

    Here is a message when I put the code in index.php

    Warning: putenv() [function.putenv]: Safe Mode warning: Cannot set environment variable 'TZ' - it's not in the allowed list.

    Damn!
    Glad you got it sorted

    You may have other problems in the future
    Quoting from What are the Server requirements to run Zen Cart?

    "safe_mode off recommended, also for security reasons "

 

 
Page 4 of 8 FirstFirst ... 23456 ... LastLast

Similar Threads

  1. BackUp ZC [Support Thread]
    By skipwater in forum All Other Contributions/Addons
    Replies: 261
    Last Post: 12 Aug 2014, 07:49 PM
  2. Save For Later Support Thread
    By swguy in forum All Other Contributions/Addons
    Replies: 134
    Last Post: 13 Jan 2014, 05:04 PM
  3. Multiple Zone Rates Support Thread
    By totalsam in forum Addon Shipping Modules
    Replies: 42
    Last Post: 23 Nov 2012, 05:04 PM
  4. PO Box Ban [support thread]
    By Steven300 in forum Addon Shipping Modules
    Replies: 23
    Last Post: 28 Oct 2009, 11:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •