Results 1 to 10 of 10
  1. #1
    Join Date
    Mar 2010
    Posts
    15
    Plugin Contributions
    0

    help question Categories missing from admin console - ?

    Hi,

    My site is bombshellshirts.com. I recently moved all the site files out of the default Zencart folder and into public_html on the host server. I initially had some problems getting the admin login page to come up, but was able to resolve with Fix_Cache_Key.php. I also had to manually move the zc_admin folder over to public_html.

    I am able to log into my admin page, however, none of the categories, which still show up on my site are in the admin section under public_html.

    The categories that are on the site are:

    Mens-
    Tribute Series
    Womens-
    Bombshells

    It seems to me that the admin control is no longer communicating with the site. Any help would be greatly appreciated

  2. #2
    Join Date
    Jan 2004
    Posts
    60,714
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: Categories missing from admin console - ?

    Sounds like you've got the wrong database settings in the admin version of your configure.php file
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Mar 2010
    Posts
    15
    Plugin Contributions
    0

    Default Re: Categories missing from admin console - ?

    Quote Originally Posted by DrByte View Post
    Sounds like you've got the wrong database settings in the admin version of your configure.php file
    Do you know how to correct that?

  4. #4
    Join Date
    Jan 2004
    Posts
    60,714
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: Categories missing from admin console - ?

    Sure: put the right settings in it.

    Not sure why you would have changed them in the first place.

    Is your storefront working properly? If so, you could use the DB_XXXXXXX settings from your /includes/configure.php file as a reference for the right similar settings to put in your admin version of the file.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  5. #5
    Join Date
    Mar 2010
    Posts
    15
    Plugin Contributions
    0

    Default Re: Categories missing from admin console - ?

    Quote Originally Posted by DrByte View Post
    Sure: put the right settings in it.

    Not sure why you would have changed them in the first place.

    Is your storefront working properly? If so, you could use the DB_XXXXXXX settings from your /includes/configure.php file as a reference for the right similar settings to put in your admin version of the file.
    I did not intentionally change it. I simply moved the the files in the default Zencart folder to public_html so that my webaddress points to the front page of the site instead of the index page.

    I must not have moved all the files/folders over since I was also missing the zc_admin folder (it was in public_htmlold and had to be moved to public_html).

    Storefront seems to be working so I'll try what you suggested.

  6. #6
    Join Date
    Mar 2010
    Posts
    15
    Plugin Contributions
    0

    Default Re: Categories missing from admin console - ?

    Quote Originally Posted by DrByte View Post
    Sure: put the right settings in it.

    Not sure why you would have changed them in the first place.

    Is your storefront working properly? If so, you could use the DB_XXXXXXX settings from your /includes/configure.php file as a reference for the right similar settings to put in your admin version of the file.
    I checked both configure php files and they have the same settings. I did make changes to them in order to remove any references to the removed 'Zencart' folder. This was problematic as it did not allow me to bring up the admin login screen until I used Fix_Cache_Key and moved the missing zc_admin folder over from public_htmlold to public_html.

    Still no categories in control panel. Please help as I am at a loss.

    Thanks

  7. #7
    Join Date
    Jan 2004
    Posts
    60,714
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: Categories missing from admin console - ?

    Is it "just" your categories that are missing? Or are all your other admin settings looking rather generic?
    Are your payment/shipping settings looking normal?
    Are your settings under Admin->Configuration->My Store looking normal?

    What *else* was going on around the same time as the "move"?

    Are you sure that no files were damaged in the move? Maybe you need to replace the files under your new admin folder?

    Did you *really* RENAME "public_html" to "public_htmlold"? Are you sure you didn't lose any permissions when you did that?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  8. #8
    Join Date
    Mar 2010
    Posts
    15
    Plugin Contributions
    0

    Default Re: Categories missing from admin console - ?

    Quote Originally Posted by DrByte View Post
    Is it "just" your categories that are missing? Or are all your other admin settings looking rather generic?
    Are your payment/shipping settings looking normal?
    Are your settings under Admin->Configuration->My Store looking normal?

    What *else* was going on around the same time as the "move"?

    Are you sure that no files were damaged in the move? Maybe you need to replace the files under your new admin folder?

    Did you *really* RENAME "public_html" to "public_htmlold"? Are you sure you didn't lose any permissions when you did that?
    It does appear that all of my admin setting went to default, or "generic".

    I had not worked on the site in some months and was working with the host helpdesk recently. I was initially trying to just get my url to point to my front page, but in doing so all of these other issues have come up! I moved the files over as instructed by the helpdesk and have been troubleshooting my way back to normal admin control since.

    Not sure what the best move from here is?? Is this repairable? Or should I start from scratch and do a complete reinstall from the base Zencart template and try to get back to where I was??

    I am shooting for a deadline of March 1 to get my site up and running and products added.

    "Maybe you need to replace the files under your new admin folder?" - Can I simply replace these with the original files and go from there??

    Thanks again!!

  9. #9
    Join Date
    Jan 2004
    Posts
    60,714
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: Categories missing from admin console - ?

    If your admin is showing data that's different from what your storefront is showing, then the database settings in the configure.php file in your admin are different from the settings in the configure.php file for your storefront.
    If they don't match, then they're pointing to different sets of data in the database, or different databases altogether.

    If the database settings in your two configure.php files, as they exist on the server, are in fact identical but you're seeing different data then ... well ... something magical is happening ... because that's impossible.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #10
    Join Date
    Mar 2010
    Posts
    15
    Plugin Contributions
    0

    Default Re: Categories missing from admin console - ?

    Quote Originally Posted by DrByte View Post
    If your admin is showing data that's different from what your storefront is showing, then the database settings in the configure.php file in your admin are different from the settings in the configure.php file for your storefront.
    If they don't match, then they're pointing to different sets of data in the database, or different databases altogether.

    If the database settings in your two configure.php files, as they exist on the server, are in fact identical but you're seeing different data then ... well ... something magical is happening ... because that's impossible.
    Gotcha. I'll have to look closer.

    thanks anyway

    Reno

 

 

Similar Threads

  1. Admin Console Not Displaying Correctly
    By collguy82 in forum Installing on a Windows Server
    Replies: 5
    Last Post: 16 Sep 2009, 10:51 PM
  2. Own URL for admin console?
    By MrParanoid in forum General Questions
    Replies: 3
    Last Post: 24 Dec 2008, 08:55 PM
  3. Session Issue on UI & Admin Console :: Win XP :: php 4.4.8
    By programguru in forum Installing on a Windows Server
    Replies: 2
    Last Post: 9 Aug 2008, 01:17 AM
  4. Admin Console has changed
    By tracib in forum Basic Configuration
    Replies: 3
    Last Post: 30 Jan 2008, 02:42 PM
  5. Meta tags buttons disappeared from the admin Categories console
    By dreamdaily in forum Setting Up Categories, Products, Attributes
    Replies: 4
    Last Post: 10 Jul 2006, 05:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •