Page 1 of 3 123 LastLast
Results 1 to 10 of 29
  1. #1
    Join Date
    Sep 2006
    Posts
    20
    Plugin Contributions
    0

    Default Moved to new server (GoDaddy), now I'm lost

    I've been using Zen Cart for over 5 years now and I consider myself zc savvy up until now. I need help, here's my issue.

    My host went oob. I am moving my websites to GoDaddy.
    I decided to freshly install the newest version of ZC and to my dismay, my db wasn't compatible, DUH!
    So, I came hear to grab an older version of ZC, I believe I had 1.3.6, installed that and now I can't complete the install because I get an error:
    "Error encountered while writing /includes/configure.php"

    Also, (this sounds terrible) I made backups before my previoud host went belly up, but I don't know what to do with .tar files.

    any help is appreciated

  2. #2
    Join Date
    Jan 2008
    Location
    Portland, Oregon USA
    Posts
    353
    Plugin Contributions
    0

    Default Re: Moved to new server (GoDaddy), now I'm lost

    Old files can be found here: http://sourceforge.net/projects/zenc....3.x%20Series/

    I would recommend two things:

    • Upgrade to the lastest version 1.3.9H
    • and find another host other than GoDaddy


    http://www.zen-cart.com/index.php?ma...es&pages_id=10

    Search the forum for both recommendations and you'll find a multitude of reasons to hopefully make some changes sooner than later.

    Cheers,
    Doug

  3. #3
    Join Date
    Nov 2004
    Location
    Norfolk, United Kingdom
    Posts
    3,102
    Plugin Contributions
    2

    Default Re: Moved to new server (GoDaddy), now I'm lost

    As the "Upgrade Database Only" option doesn't need to write anything to the configure.php files I have never been able to fathom why it wants those two files to be writeable - but it does.

    After you have installed your new Zen Cart site with its new 1.3.9h database you need to "Drop" all those shiny new tables using phpMyAdmin, and then import your old db backup into that new db.

    Then you upload the new 1.3.9h zc_install folder to the root of your website and go to it in your browser and choose the "Upgrade Database Only" option. This will upgrade your old database to 1.3.9+ level, which along with your new 1.3.9h fileset gives you a new website with all your old customer and product data.

    Vger

  4. #4
    Join Date
    Jan 2004
    Posts
    60,217
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: Moved to new server (GoDaddy), now I'm lost

    Vger, they're not talking about upgrading specifically. They're trying to install and getting that "cannot write" message when the installer is trying to create the config files for their new server.

    And, the "Upgrade Database Only" option does not need to write to configure.php files, and does not require them to be writeable. Maybe it did a long time ago, but it doesn't now, unless going from 1.2 to 1.3 where it needs to add new content to the files.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  5. #5
    Join Date
    Sep 2006
    Posts
    20
    Plugin Contributions
    0

    Default Re: Moved to new server (GoDaddy), now I'm lost

    So if I do a fresh install of the newest version, I should be able to upgrade my database during install?

  6. #6
    Join Date
    Sep 2006
    Posts
    20
    Plugin Contributions
    0

    Default Re: Moved to new server (GoDaddy), now I'm lost

    Is there a file that states what version zc is in use?

  7. #7
    Join Date
    Nov 2004
    Location
    Norfolk, United Kingdom
    Posts
    3,102
    Plugin Contributions
    2

    Default Re: Moved to new server (GoDaddy), now I'm lost

    I decided to freshly install the newest version of ZC and to my dismay, my db wasn't compatible
    1. Install 1.3.9h as normal, but leave the zc_install folder in place for now, and then

    2. Access the new 1.3.9h database via phpMyAdmin and "Drop" all of the tables in it, then

    3. Using phpMyAdmin again, use the Import tab to import a backup of your old database into the new (and now empty) database.

    4. Assuming you installed Zen Cart 1.3.9h at an address called http://www.yourdomain.com then go back to http://www.yourdomain.com/zc_install and when you get to the first proper page of the install you'll see (at the bottom of the page) an option to "Upgrade database only". Click on this button.

    5. It doesn't much matter which version you are upgrading from because the Database Upgrade will amend your old database in increments through the various versions up to the current version.

    6. You then delete the zc_install folder.

    7. You then rename the 'admin' folder using FTP or your web hosting control panel to something unique and you edit the website's admin/includes/configure.php file and change /admin/ in 3 places to read /new-admin-name/ - you will have to reset permissions on this file to 644 (to be able to edit it) and then reset them later back to 444 or 400.

    You now have a 1.3.9h website with the data from your old website.

    Vger

  8. #8
    Join Date
    Sep 2006
    Posts
    20
    Plugin Contributions
    0

    Default Re: Moved to new server (GoDaddy), now I'm lost

    Thank you! I followed these instructions, but encountered a new problem.
    After dropping the database and uploading my old database, not all of the tables are uploading. Every table after "orders" won't upload in addition to that, the "orders" table is 0 and it should be 2,000+

  9. #9
    Join Date
    Nov 2004
    Location
    Norfolk, United Kingdom
    Posts
    3,102
    Plugin Contributions
    2

    Default Re: Moved to new server (GoDaddy), now I'm lost

    This probably means that the database backup file is too large (in file size) for phpMyAdmin to handle.

    You can either create two new .txt documents and copy/paste the first half of the db into one and the second half into the other, and then import them one at a time using phpMyAdmin or else you'll need to get someone experienced with using SSH (Secure Shell Access) to import the whole db for you. SSH is not restricted by file size the way that phpMyAdmin is.

    If you split the db into separate files you will need to drop the tables that did Import the first time around before you try again with the separate files.

    Vger

  10. #10
    Join Date
    Sep 2006
    Posts
    20
    Plugin Contributions
    0

    Default Re: Moved to new server (GoDaddy), now I'm lost

    Ok, I will try the split method you explained.

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Moving from Windows Server to Linux Server - GoDaddy
    By spetznaz2588 in forum Installing on a Linux/Unix Server
    Replies: 1
    Last Post: 19 Feb 2011, 07:20 AM
  2. Moved to new server, ran fix cache, lost admin log-in
    By Lyon in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 26 Sep 2009, 05:26 AM
  3. Moved web server
    By SimonB in forum General Questions
    Replies: 3
    Last Post: 12 Apr 2009, 01:49 AM
  4. Moved Zen Cart from one computer to another and lost data
    By acanthuscarver in forum General Questions
    Replies: 2
    Last Post: 4 Oct 2007, 12:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •