Results 1 to 8 of 8

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Posts
    7
    Plugin Contributions
    0

    Default slow preformace after upgrade to 1.39

    Hi,
    I in the process of upgrading a customers site from 1.36 to 1.39h and we seem to have a 5 fold decrease in performance. I have run the same upgraded site both locally on my laptop and on my own development site with no impairment of performance.

    The database query times are acceptable but the parse times are not.

    Is the performance issue due to mismatch between the new zencart 1.3.9h and PHP 4.4.9 or are there other issues I need to look at?

    Thanks for reading
    Mackenzie

    The basic server information:
    Server OS: Windows NT WEBC16 5.2 build 3790
    Database: MySQL 5.0.54-log
    HTTP Server: Microsoft-IIS/6.0
    PHP Version: 4.4.9 (Zend: 1.3.0)
    PHP Safe Mode: Off
    Data Size: 109,287 kB
    Database Index Size: 5,539 kB

    SAMPLE Load times on the same page
    Current site: (zencart 1.36)
    Parse Time: 2.298 - Number of Queries: 323 - Query Time: 0.543119
    Parse Time: 2.449 - Number of Queries: 323 - Query Time: 0.606774
    Parse Time: 2.239 - Number of Queries: 322 - Query Time: 0.511505

    Upgrade site: (zencart 1.39h)
    Parse Time: 12.501 - Number of Queries: 334 - Query Time: 0.686452
    Parse Time: 12.505 - Number of Queries: 324 - Query Time: 0.532058
    Parse Time: 12.505 - Number of Queries: 324 - Query Time: 0.532058

    Sorry no URL: the upgraded site is not public yet.

  2. #2
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: slow preformace after upgrade to 1.39

    Is this a dedicated or shared server? And, Gotta wonder why you're planning to run Zen Cart on a Windows server with PHP4?
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  3. #3
    Join Date
    Jan 2004
    Posts
    60,393
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: slow preformace after upgrade to 1.39

    Quote Originally Posted by mcosens View Post
    I have run the same upgraded site both locally on my laptop and on my own development site with no impairment of performance.
    Do I understand this correctly? You're saying that running the upgraded site on various servers *other than* the live server, works just fine with no performance problems?
    By process of elimination, that suggests the bottleneck is the live server.


    And, I echo kuroi's comments: why use obsolete PHP4? why windows?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  4. #4
    Join Date
    Mar 2008
    Posts
    7
    Plugin Contributions
    0

    Default Re: slow preformace after upgrade to 1.39

    The main reason for using "obsolete" PHP is compatibility with 1.3.6. He has a website that runs 1.3.6 and generates a revenue stream. If PHP had not broken backward compatibility then this would be an non-issue. Besides PHP 4.4.9 fits with in the requirements to run 1.39 http://tutorials.zen-cart.com/index.php?article=6

    If no one can think of any other likely cause for poor performance I will give my client the easy answer: Which is when he is happy with the test site, we will get the ISP to upgrade PHP .

    Thanks for you time.
    mackenzie

  5. #5
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: slow preformace after upgrade to 1.39

    ... and is a dedicated or a shared server?

    What are the server loads?
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

  6. #6
    Join Date
    Mar 2008
    Posts
    7
    Plugin Contributions
    0

    Default Re: slow preformace after upgrade to 1.39

    Quote Originally Posted by kuroi View Post
    ... and is a dedicated or a shared server?

    What are the server loads?
    Hi
    I don't think that dedicated vs shared server is the issue. Both sets of code exist on the same server in different directories. I would expect any impairment in performance to be the same on both sets of code since they share the same environment. I don't think load is the issue either for the same reason, I would expect both sets of code to impaired the same and poor performance to be shared between them and that doe not seem to be the case.

    I just finished reading http://www.zen-cart.com/forum/showthread.php?t=153143 DrByte post has been very helpful. He indicates that "If you're using such an old version of PHP, then your site is certainly not PCI-Compliant" and indicates some unhelpful behaviors within the new code when used with older PHP version. I think these are reasons enough to recommend upgrading to newer version. I expect the server environment upgrade will fix the performance issue.

    Thank you for your posts and inquiries, they have been very helpful in dealing with this issue.

    mackenzie

  7. #7
    Join Date
    Mar 2008
    Posts
    7
    Plugin Contributions
    0

    Default Re: slow preformace after upgrade to 1.39

    I have just resolved the slow performance issue with my upgrade. Its an interesting lesson in things that you would not think would be so deadly to performance but are.

    In Configuration::My Store there is a setting Enable phpBB linkage? this was set to true. There is no phpBB installed on the new server so I set it to false and my Parse Time: went from 10+sec to under 1 sec

    mackenzie

  8. #8
    Join Date
    Apr 2006
    Location
    London, UK
    Posts
    10,655
    Plugin Contributions
    25

    Default Re: slow preformace after upgrade to 1.39

    That's one I've not heard of before and very useful to know. Thanks for sharing it with the community.
    See and test drive Zen Cart's free templates at zencarttemplates.info

    Kuroi Web Design and Development | Twitter

    (Questions answered in the forum only - so that any forum member can benefit - not by personal message)

 

 

Similar Threads

  1. Cart running very slow after 1.3.8a upgrade
    By four-point in forum General Questions
    Replies: 19
    Last Post: 19 Apr 2009, 05:57 PM
  2. Slow site before & after 1.3.7 upgrade
    By inovermyhead in forum General Questions
    Replies: 13
    Last Post: 3 Apr 2007, 03:23 AM
  3. really slow...
    By willjoe86 in forum General Questions
    Replies: 2
    Last Post: 7 Jun 2006, 10:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •