Results 1 to 10 of 10
  1. #1
    Join Date
    Nov 2011
    Posts
    3
    Plugin Contributions
    0

    Default Installed, finally, store ok, ADMIN not!

    One heck of a day installing my site (a server problem with ftp, not zen)... after 12 hours, I can see the demo store.
    BUT,
    after installation, on the "Finish" page zc_install/index.php?main_page=finished there are two buttons at the bottom, something like "see the store" and " open admin area"
    the store I can get to, but if I click to the admin area, I get this error in the browser:
    The page isn't redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    If I try going to the admin/index.php page with IE, it just spins in its tracks forever and never leaves google (my home page)...

    I never get to a page to log into the database.

    I am using the most current cart - new installation no customizations (I downloaded it today from the zen cart site)

  2. #2
    Join Date
    Oct 2011
    Location
    AZ
    Posts
    392
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    When you get to that page, before you can proceed you need to change a couple of things. There should be an error if you don't.

    There should be a tutorial somewhere around here, I'm off to dinner and can't find it - but you need to rename your admin folder to something besides "admin" and then you need to download your configures files and where the paths says .../admin/... you change them to the new path. This hides your admin folder from prying eyes (I think.) And you also have to remove the zc_install folder. and I think there's something else. You're close - very close. If you can find that tutorial (Srry I'm rushing and can't find it) you'll see the light at the end of the tunnel.


    OH I had to come back because it was bugging me and I couldn't enjoy chili-dogs knowing you were stuck.
    I found the tutorial - you are somewhere down near the bottom "After Installation."
    http://tutorials.zen-cart.com/index.php?article=107

    Good Luck.
    Last edited by joejoejoe; 13 Nov 2011 at 01:43 AM. Reason: had to find the tutorial or I'd get indigestion.

  3. #3
    Join Date
    Nov 2011
    Posts
    3
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    Thanks for the quick reply, hope you enjoyed dinner!

    I do have and am following the tutorial you spoke of.
    Renaming the admin folder comes later, you can access the admin folder (or should be able to, but I cant, as I am in a php loop) without changing the folder name.... the name change is so that it is harder to find for hackers.
    The error messages you speak of in the tutorial refer to the actual storefront... and those messages will be gone once I set permissions back to read only on the config files... this also is not why I am in a php loop.

    I am at a loss as to why I'm "loopy"

  4. #4
    Join Date
    Oct 2011
    Location
    AZ
    Posts
    392
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    What version are you installing? I've installed 1.3.9h twice this month and both times when I got to that page you are talking about with the two tabs at the bottom, if I clicked on "my store It would take me to my store but there would be a big error message across the top - "You need to delete or rename zc_install" And if I clicked on the tab to go to my admin I'd get a page that said I couldn't do it until I'd changed the name of the admin folder and rewritten the paths. (And once you do that, the tab won't work because you have to change the "admin" in the url to whatever your new name is.)
    I know the tutorial makes it sound like you can go to the admin page first and get around to changing it whenever you feel like it. Maybe the tutorial was written before they made it a mandatory thing? I dunno. Maybe a zen-master will step in here and set me straight.....

    Good Luck
    Last edited by joejoejoe; 13 Nov 2011 at 02:38 AM. Reason: I h8 typos

  5. #5
    Join Date
    Nov 2011
    Posts
    3
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    Thanks Joe!

    weird... they talk about changing the folder after accessing the admin area, but you were right! Changed the folder name, and the 3 instances of the folder name in configure.php, and I'm able to access the admin area now.

    That's what I get for first trying to wing it, then after hours of trying, deleting the whole works off my server and computer and starting from scratch and following the directions word for word. I think I'll suggest they change the wording in the tutorial.

    thanks again!
    lv

  6. #6
    Join Date
    Oct 2011
    Location
    AZ
    Posts
    392
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    Glad to hear you finally got in. I agree the tutorial could use a bit of freshening, but wouldn't know where to go to get it done. I'd write one myself and submit it but I'd probably leave some other bit of info out and end up causing more problems.

  7. #7
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: Installed, finally, store ok, ADMIN not!

    Quote Originally Posted by lverkeyn View Post
    I think I'll suggest they change the wording in the tutorial.
    No need to change the wording.
    If you read the existing tutorial you'll see that all those edits won't be necessary starting with v1.5.0.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  8. #8
    Join Date
    Oct 2011
    Location
    AZ
    Posts
    392
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    That's nice it's fixed in the newer version. But 1.5.0 isn't ready for live stores yet. So anyone installing for a live store (like I was) will see that line about 1.5.0 and ignore it because it doesn't apply.

  9. #9
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: Installed, finally, store ok, ADMIN not!

    Quote Originally Posted by joejoejoe View Post
    That's nice it's fixed in the newer version. But 1.5.0 isn't ready for live stores yet. So anyone installing for a live store (like I was) will see that line about 1.5.0 and ignore it because it doesn't apply.
    How would you suggest re-wording "that line" to be more clear for people NOT running v1.5.0?
    Quote Originally Posted by FAQ
    IMPORTANT NOTE: If you're using Zen Cart v1.5.0 or newer, you can skip this step...
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #10
    Join Date
    Oct 2011
    Location
    AZ
    Posts
    392
    Plugin Contributions
    0

    Default Re: Installed, finally, store ok, ADMIN not!

    Quote Originally Posted by DrByte View Post
    How would you suggest re-wording "that line" to be more clear for people NOT running v1.5.0?
    That line is fine but since I wasn't on 1.5.0 I just ignored it - I was referring to the steps down below.
    On both my last 2 installs, and apparently on the other poster's install above, once we get to the end of "Starting the Installation" and before "After the installation" we're presented with a congratulations page with two tabs at the bottom - one goes to the store and one goes to the store admin. Reading the tutorial as written it looks like everything should work fine at that point, but that we need to go in later and change the admin folder name and directory settings in the config files. But clicking on the "go to admin" tab doesn't work - because (at least for my installs on 1.3.9h) the new admin is locked out until he goes in and makes the changes.

    It made me feel as though there was a previous version that let you do the install and get around to changing the admin folder name and deleting zc_install when you wanted to, but at some point it was changed to mandatory and this particular tutorial didn't get upgraded. (I think the one included in the install package does mention it - in which case it's a matter of different instructions in different places and it's just good/bad luck as to which one you work from.

    I hope I worded that right - I'm trying to remember the process from a week ago. Maybe the OP has some input?
    Thanks.

 

 

Similar Threads

  1. I finally got Image Handler 2 installed, but something is definitely wrong...
    By strugglingnovice in forum All Other Contributions/Addons
    Replies: 3
    Last Post: 26 Jun 2010, 08:14 PM
  2. SSL Installed and now can't login to store or Admin
    By GGVL in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 11 Aug 2009, 02:49 AM
  3. Just installed & no buttons, images, icons in admin or store
    By marvin in forum Basic Configuration
    Replies: 6
    Last Post: 21 Sep 2007, 03:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •