Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2011
    Posts
    22
    Plugin Contributions
    0

    Default XAMPP Testing Question

    I have loaded v1.3.9h on to the XAMPP test server. Things are going pretty good except that when I test the checkout process I can get all the way to confirming the order, but instead of getting an order confirmation page, I just get a blank page. Is this because I'm on a test server? I would like to test the full functionality of my website before I put it out on the web. Should I be able to complete an order and even get the order pending e-mail sent to me?

    Thanks for any help.

  2. #2
    Join Date
    Jan 2004
    Posts
    60,305
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: XAMPP Testing Question

    It could be failing for any number of reasons, all of which are a result of a failure to access a required resource. That could be sending an email, it could be talking to an external server for another reason, it could be a lot of things. Especially problematic on non-live "test" servers since they're often not adequately equipped to do full website operations. It could also be a PHP error caused by a syntax error in one of your customizations or a badly installed addon or a poorly-written addon.

    Related FAQ article: http://tutorials.zen-cart.com/index.php?article=82
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Nov 2011
    Posts
    22
    Plugin Contributions
    0

    Default Re: XAMPP Testing Question

    I found the debug file that was talked about in the link you posted. Looks like it was a time out error. Here it is:

    error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\zen\includes\classes\http_client.php on line 338

    This is what line 338 looks like:

    $this->replyString = trim(fgets($this->socket, 1024));

    I haven't touched this file. Do you think I should just upload my site to my hosting server and see if I have the same problem?

  4. #4
    Join Date
    Jan 2004
    Posts
    60,305
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: XAMPP Testing Question

    That suggests that it's having trouble making an external communications attempt, and your local XAMPP server or your ISP are blocking the port/communications from taking place adequately.
    So, yes, a proper test would be performed by loading the site to a properly hosted website.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Testing the upgrade under xampp first. (No Products Showing)
    By gobrinton in forum Installing on a Windows Server
    Replies: 5
    Last Post: 6 Oct 2011, 11:08 PM
  2. can't change Testing:successful to testing declined in Linkpoint Pymnt Module
    By WhiteWolf in forum Built-in Shipping and Payment Modules
    Replies: 8
    Last Post: 3 Jul 2009, 04:27 PM
  3. Xampp 1.4.16
    By Edm in forum General Questions
    Replies: 3
    Last Post: 5 May 2008, 04:27 PM
  4. Simple XAMPP Backup Question
    By wwwursa in forum Installing on a Windows Server
    Replies: 3
    Last Post: 22 Jan 2008, 11:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •