Results 1 to 6 of 6
  1. #1
    Join Date
    Nov 2011
    Location
    Atlanta, GA
    Posts
    43
    Plugin Contributions
    1

    application error [fixed] gzpost errors with 1.5.0 RC2 on Windows/IIS

    I have installed the new 1.5.0 RC2 on a Windows 2003 server and can't seem to get the Admin module working. Just gives internal server 500 error. I'm sure LINUX / Apache is better but I have what I have.... PHP 5.3.8. MySQL 5.1. I'm running 1.3.9h on the same box without any problems. Any advice is much appreciated.

    --Ron

  2. #2
    Join Date
    Nov 2011
    Location
    Atlanta, GA
    Posts
    43
    Plugin Contributions
    1

    Default Re: Anyone running 1.5.0 on Windows/IIS

    OK, I got it working. Found this:

    [30-Nov-2011 09:51:32] PHP Fatal error: 1364:Field 'gzpost' doesn't have a default value :: insert into admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '0', 'Log found to be empty. Logging started.', '', '10.25.1.210') in C:\www\b2c.bauerfeinusa.com\webstore\includes\classes\db\mysql\query_factory.php on line 101

    Changed gzpost to allow NULL, please let me know if this should be fixed a different way...

    Thanks,

    --Ron
    Ron Huseby
    ron@huseby.us

  3. #3
    Join Date
    Apr 2008
    Location
    Qld, Aust
    Posts
    16
    Plugin Contributions
    0

    Default Re: Anyone running 1.5.0 on Windows/IIS

    I have installed ZC v1.5.0RC2 on Windows 7 with Apache v2.2.21, MySQL 5.1.50, PHPv5.2.14
    and received an error when trying to access the admin pages.

    The debug log file contained the following:
    "PHP Fatal error: 1364:Field 'gzpost' doesn't have a default value :: insert into admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '0', 'Log found to be empty. Logging started.', '', '192.168.1.148') in E:\web\ZenCart-150\includes\classes\db\mysql\query_factory.php on line 101.

    I resolved it by making teh gzpost field in the admin_activity_log default to a NULL value.

  4. #4
    Join Date
    Apr 2008
    Location
    Qld, Aust
    Posts
    16
    Plugin Contributions
    0

    Default Re: Anyone running 1.5.0 on Windows/IIS

    I can put this one down to user error.
    I have since installed an upgrade from v1.3.9h on Linux and Windows 7 several times perfectly.

  5. #5
    Join Date
    Apr 2008
    Location
    Qld, Aust
    Posts
    16
    Plugin Contributions
    0

    Default Re: Anyone running 1.5.0 on Windows/IIS

    I will correct my own statement. This error is reproducible on a Windows server. Steps taken are:
    Copy entire new v 1.5.0 files to zc150 folder
    create blank db zc150test
    run installer
    page 1 ok
    page 2 db username +pwd; database name ok
    page 3 ok
    page 4 fill in store settings; no demo data ok
    page 5 fill in admin user +temp password ok
    select 'go to store' ok
    select 'go to admin' - fails

    Error is : PHP Fatal error: 1364:Field 'gzpost' doesn't have a default value :: insert into admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '0', 'Log found to be empty. Logging started.', '', '192.168.1.148') in E:\web\zc150\includes\classes\db\mysql\query_factory.php on line 101
    environment is:
    Windows 7 latest patches; Apache 2.2.21; MySQL 5.1.50; PHP 5.3.8

  6. #6
    Join Date
    Jan 2004
    Posts
    60,413
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Anyone running 1.5.0 on Windows/IIS

    Quote Originally Posted by rhuseby View Post
    I have installed the new 1.5.0 RC2 on a Windows 2003 server and can't seem to get the Admin module working. Just gives internal server 500 error. I'm sure LINUX / Apache is better but I have what I have.... PHP 5.3.8. MySQL 5.1.
    Quote Originally Posted by rhuseby View Post
    [30-Nov-2011 09:51:32] PHP Fatal error: 1364:Field 'gzpost' doesn't have a default value :: insert into admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '0', 'Log found to be empty. Logging started.', '', '10.25.1.210') in C:\www\b2c.bauerfeinusa.com\webstore\includes\classes\db\mysql\query_factory.php on line 101

    Changed gzpost to allow NULL
    Quote Originally Posted by OldNGrey View Post
    I have installed ZC v1.5.0RC2 on Windows 7 with Apache v2.2.21, MySQL 5.1.50, PHPv5.2.14
    and received an error when trying to access the admin pages.

    The debug log file contained the following:
    "PHP Fatal error: 1364:Field 'gzpost' doesn't have a default value :: insert into admin_activity_log (access_date, admin_id, page_accessed, page_parameters, ip_address) values (now(), '0', 'Log found to be empty. Logging started.', '', '192.168.1.148') in E:\web\ZenCart-150\includes\classes\db\mysql\query_factory.php on line 101.

    I resolved it by making teh gzpost field in the admin_activity_log default to a NULL value.
    Yes, setting it to a default of NULL or just blank will suffice. Fix will be included in final official v1.5.0 release.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Fixed size pop-up windows?
    By absoluteblock in forum General Questions
    Replies: 6
    Last Post: 2 Jan 2012, 11:25 PM
  2. Replies: 2
    Last Post: 2 Aug 2011, 03:57 PM
  3. Errors after move my zencart system from OS Windows to LInux
    By bianbian in forum Installing on a Linux/Unix Server
    Replies: 8
    Last Post: 8 Jun 2006, 02:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •