Results 1 to 5 of 5
  1. #1
    Join Date
    May 2009
    Posts
    68
    Plugin Contributions
    0

    Default Upgrade to 1.5 necessary?

    Hello,

    I have a shop running Zen Cart 1.3.9h, which underwent a lot of customizations, meaning upgrading to 1.5 won't be easy. I am perfectly happy with version 1.3.9's feature-set. Of course, I am also interested in keeping as secure as possible, so at some point an upgrade might be inevitable in order to prevent loss or modification of my customer-data (or even worse).

    As far as I am concerned, I would really like to run my shop for 2-3 years with the current Zen Cart version.

    Will there be a Service Pack for 1.3.9h so users who can't upgrade at least get the latest security features?

    Thanks in advance,
    p1lot

  2. #2
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,653
    Plugin Contributions
    3

    Default Re: Upgrade to 1.5 necessary?

    I can't speak for the developers, but since 1.5 is in Release Candidate 2, I'd doubt if there will be a security patch for 1.3.9.

    Upgrading from 1.3.9h to 1.5.0RC2 is really simple, but as you mentioned, you'll need to account for any mods you've installed. If your customizations are mostly template-related, you'll have little problem.

    To anyone reading this thread, difficulty in upgrading is an excellent argument for limiting mod installation to those which you are sure will help you sell more products. Too many Zenners, I think, install multiple mods because they seem cool, or are currently fashionable. I would include sliders and lightbox-style image hover mods in the latter.

    p.s. There are no users 'who can't upgrade'.

  3. #3
    Join Date
    Jan 2004
    Posts
    60,406
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Upgrade to 1.5 necessary?

    Quote Originally Posted by p1lot View Post
    Will there be a Service Pack for 1.3.9h so users who can't upgrade at least get the latest security features?
    Yes. It'll be called v1.5.0
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  4. #4
    Join Date
    Feb 2010
    Posts
    12
    Plugin Contributions
    0

    Default Re: Upgrade to 1.5 necessary?

    Is version 1.5 able to be downloaded and installed now?

  5. #5
    Join Date
    May 2011
    Location
    Sunny Rossendale (not)
    Posts
    569
    Plugin Contributions
    2

    Default Re: Upgrade to 1.5 necessary?

    Quote Originally Posted by bromerrill View Post
    Is version 1.5 able to be downloaded and installed now?
    You'll find it here
    http://www.zen-cart.com/forum/showth...54#post1078354
    It's rc2 so there will be updates/upgrades when the final version is released
    as stevesh says if you keep to this KISS principle (Keep It Simple Stupid) it saves a lot of grief
    What ever your doing remember to KISS ( Keep It Simple Stupid )

 

 

Similar Threads

  1. Replies: 5
    Last Post: 13 Sep 2011, 11:35 PM
  2. upgrade 1.3.9d to e my admin area still says i need to upgrade
    By cjbwebs in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 5 Aug 2010, 10:31 AM
  3. upgrade cfg files or database upgrade???
    By waghelak in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 11 Sep 2006, 02:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •