Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2007
    Posts
    50
    Plugin Contributions
    0

    Default Upgrade Question


    Hopefully someone will have time to answer my stupid questions. I am having troubles wrapping my mind around the upgrading from 3.7 to 3.9h.
    So far I understood that:
    After uploading the new version to a separate database and separate folder under my actual store, I have to compare the original 3.7 to my modified one with Winmerge for example.

    After I put the files I modified in the override system of my 3.7 version (didn't use it and how do I regret!), I compare my modified files to 3.9.h in winmerge. For every different files I either paste/copy the different language files and modify the code I did modified in the my 3.7.

    I upload the 3.9 modified in my demo folder with the zen install folder.

    I copy the 2 configure files from my old store in 3.9.

    And then I install through my browser, clicking upgrade instead of install.

    My problem: I have an issue with bluehost. When I try to install to try out the new version the server tells me it cannot access the new database (and I can remote access it, but not the zencart installer). It get stuck with an error too many connections. I contacted bluehost and they reset the server (can't do it myself with this host and the command flush host or reset in the sql query). But on my end it still doesn't work! So the guy at bluehost installed the new version, it was working but not anymore.

    I can't understand what the problem is with my new database. I probably made a big mistake somewhere as I am not familiar with sql and phpmyadmin etc.

    So my main question would be: once I have changed everything for 3.9 can I upload it in the new folder and connect to my first database (not the new one)? When I change the configure files for the new database it doesn't connect and nothing works.

    I am pretty stuck right now. I would really appreciate someone's help. Sorry for the long post and in advance thank you!!

  2. #2
    Join Date
    Jun 2003
    Posts
    33,823
    Plugin Contributions
    0

    Default Re: Upgrade Question

    Moderator's note - Post moved to its own thread in the correct forum.
    Please do not PM for support issues: a private solution doesn't benefit the community.

    Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

  3. #3
    Join Date
    May 2010
    Location
    WA State
    Posts
    1,666
    Plugin Contributions
    1

    Default Re: Upgrade Question

    This part isn't making any sense to me:

    It get stuck with an error too many connections.
    I have mutliple installs of Zen Cart, as well as several other open source packages, on my sandbox site using multiple databases. I've never seen an issue with too many connections, either during installs or while in operation. This sounds like some kind of problem with the way your host has the server configured.
    Bumble Bee Template - my first contribution!

    The best way to learn is to try stuff. But, back it up first.

  4. #4
    Join Date
    Aug 2007
    Posts
    50
    Plugin Contributions
    0

    Default Re: Upgrade Question

    RescoCCC, yes it is an error with the host server. They have the number of wrong connection (if you make a misspelling or any mistake) to the database set to 10. With some host you can enter a sql query or tweak it so it is set up to thousand. But I do not have access to it, just the host. Sorry english is not my native language so sometimes it gets in the way.

    And even when they reset the server, I also have problem connecting to the new database, with all the correct informations entered and that only with the zencart install. If not I connect ok to the new database.

  5. #5
    Join Date
    Aug 2007
    Posts
    50
    Plugin Contributions
    0

    Default Re: Upgrade Question

    Oh and admins, sorry for the forum mistake!

 

 

Similar Threads

  1. upgrade question
    By buildingblocks in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 4 Oct 2010, 09:34 PM
  2. Upgrade question
    By mediathing in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 1 Sep 2008, 04:08 AM
  3. question about upgrade
    By topaz44 in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 31 Dec 2007, 07:09 PM
  4. Upgrade question
    By Linux in forum Upgrading from 1.3.x to 1.3.9
    Replies: 4
    Last Post: 8 May 2007, 12:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •