I'm using Zen Cart 1.5 upgraded from 1.3.9h (official upgrade procedure) with a few add-ons, which can not be held responsible for the issue below. However, I will provide a list of them if necessary.

I go to Configuration > Layout Settings > Bread Crumbs Navigator Separator and click "edit". The box to enter a new value replacing the default value of  ::  with a small arrow image. I enter
&nbsp;&nbsp;<img src="images/design/arrow_right_yellow.gif" height="9" width="9" alt="right" title="" />&nbsp;
and click "update". The new entry is shown correctly as in the following image:

The new breadcrumb is pictured below (tailored with CSS) and everything is fine:

The problems start if I try to edit the value later (for example, to change image dimensions or something else). If I click edit, the value in the box shows as:
&amp;nbsp;&amp;nbsp;&lt;img src=&quot;images/design/arrow_right_yellow.gif&quot; height=&quot;9&quot; width=&quot;9&quot; alt=&quot;right&quot; title=&quot;&quot; /&gt;&amp;nbsp;
and it shows like this when "update" is clicked:

The breadcrumb now in the product page becomes as pictured below:

Just to clarify that the first right pointing arrow still shows in the error breadcrumb because it comes from the includes/languages/english/my_template/header.php file, where I have changed the following line:

define('HEADER_TITLE_BREADCRUMB', '<font color="#0000ff"><a href="index.php">Home</a></font>&nbsp;&nbsp;<img src="images/design/arrow_right_yellow.gif" height="9" width="9" alt="right" title="" />&nbsp;');
It is not impossible to handle this issue but it's certainly annoying. Is this a bug?

Thanks in advance for any consideration.