Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2007
    Location
    Leicestershire, UK
    Posts
    10
    Plugin Contributions
    0

    Default Blank descriptions on EZpages, products, categories, define pages

    I have installed zencart 1.5 in a temporary directory. When you look at the site you can see all the pages, products, ezpages etc, but when I try to edit them from admin there is nothing in the description box. I thought it was the character set problem, but I have fixed that.

  2. #2
    Join Date
    Mar 2007
    Location
    Leicestershire, UK
    Posts
    10
    Plugin Contributions
    0

    Default Re: Blank descriptions on EZpages, products, categories, define pages

    Problem sorted. It was a charset problem. I had changed the Charset from UTF8 to iso-8859-1 in the includes/languages/english.php file but not in the admin/includes/languages/english.php file. Now I have done that it is working fine.

  3. #3
    Join Date
    Jan 2004
    Posts
    59,806
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Blank descriptions on EZpages, products, categories, define pages

    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  4. #4
    Join Date
    Nov 2007
    Location
    Oregon
    Posts
    14
    Plugin Contributions
    0

    Default Re: Blank descriptions on EZpages, products, categories, define pages

    In case someone else is interested and wants to stay with UTF-8 and has also upgraded from an older version of Zen-Cart.

    I upgraded from ZC1.3.9h to ZC1.5. Admit I did not pay attention to what the character set was prior. I think I went UTF-8 before 1.3.9h, but can't say for sure. I've been using ZenCart since 2007

    I also had the issue that my EZ pages were showing correctly for the front-end of the site, but when I went to edit the content, the content did not show in the EZ pages editor.

    I checked the character set as mentioned in post#2 and both were UTF-8. I checked my database and it was also UTF-8. I surmised that the issue likely was that my database was not UTF-8 when I originally edited these pages (stored in the database) as they are fairly static.

    So, I went to my phpadmin interface to the database, located the ezpages table (mine is zen_ezpages) and went in as if to edit an entry, highlighted the pages_html_text (ctl-a), copied it (ctl-c), then in another tab in my browser, pasted (ctl-v) the html into the ezpages editor for that same entry.

    This worked for me. The update from the html editor re-saves the html content, now in the correct character set.

    I had only about 15 pages, so it was not a big deal.
    I also tested this with the default text editor and CKeditor. For CKEditor, just be sure to select "Source" before you paste your html in.

    Hope this helps someone else

 

 

Similar Threads

  1. meta tags and title descriptions for EZpages and other pages
    By bangsters in forum General Questions
    Replies: 38
    Last Post: 28 Oct 2013, 05:17 PM
  2. PHP scripts in ezpages or define pages possible?
    By bangsters in forum General Questions
    Replies: 13
    Last Post: 5 Jan 2011, 04:15 PM
  3. Entering images to EZpages and Define Pages
    By dogjumps in forum Customization from the Admin
    Replies: 2
    Last Post: 8 Oct 2010, 09:30 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •