Results 1 to 5 of 5

Hybrid View

  1. #1
    Join Date
    Nov 2008
    Posts
    40
    Plugin Contributions
    0

    Default Testing on PHP 5.2

    Zen 1.5 Requires PHP version 5.3 to run. My hosting provider is in the process of upgrading from 5.2 to 5.3, but is still 30-60 days out. In the mean time I'd like to begin transferring my site over and do testing so that when my host flips the switch, I can do so as well. Zen 1.5 does not let you install if you are running php 5.2

    I have installed zen 1.5 in a test environment (different server) and is up and running. I've copied that site back to my production server (not live) and done testing it under php 5.2 as and far as I can tell, all works fine. I don't plan on making this live until my host makes the official switch, but I would prefer to do all my testing on the same server that it will live on as this is on a cloud hosting provider and hosting is handled a bit differently than standard shared hosting.

    So to the point, what errors or missing functionality will i experience running on 5.2 versus 5.3. Once again, this is for testing only, not production.

  2. #2
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    8,761
    Plugin Contributions
    31

    Default Re: Testing on PHP 5.2

    Quote Originally Posted by nightdesigns View Post
    Zen 1.5 Requires PHP version 5.3 to run.
    Duuno where you got your info from, but you are mistaken..

    See: http://www.zen-cart.com/forum/showthread.php?t=190424
    Minimum Requirements
    Zen CartŪ v1.5.0 requires a minimum of the following:
    • PHP 5.2.14 or higher
    • MySQL 4.1.3 or higher
    • Apache 2.0 or higher.
    • Apache configured with AllowOverride set to either 'All' or at least both 'Limit' and 'Indexes' parameters, and preferably the 'Options' parameter as well.
    • PHP configured to support CURL with OpenSSL

    While Zen CartŪ can run on Windows/IIS servers, Linux/Apache servers are recommended for best results, superior performance, and easier use by shopowners.
    My Site
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  3. #3
    Join Date
    May 2010
    Location
    WA State
    Posts
    1,666
    Plugin Contributions
    1

    Default Re: Testing on PHP 5.2

    I have 1.50 installed at my sandbox running 5.2.17. Works like a champ.
    Bumble Bee Template - my first contribution!

    The best way to learn is to try stuff. But, back it up first.

  4. #4
    Join Date
    Nov 2008
    Posts
    40
    Plugin Contributions
    0

    Default Re: Testing on PHP 5.2

    Sorry, I misspoke. I'm running 5.2.13, but 5.2.14 is required. My host is upgrading to 5.3 in the near future.

  5. #5
    Join Date
    Feb 2008
    Posts
    1,356
    Plugin Contributions
    1

    Default Re: Testing on PHP 5.2

    If you are on a shared server they should have their server up to date, at least all the good host already provide newest version of software.

    If you are on a dedicated server and they are giving you hard time to update your server which is usually the case because it is not that easy to update the software on a server, you should keep trying because they have to provide you with the software version you need especially a stable version of php such as the 5.3, which will also require upgrading the myphpadmin.

    You can tell them, they can update the server and still allow their customer who wish to continue using lower version of php to do so using Apache handler in htaccess.

 

 

Similar Threads

  1. can't change Testing:successful to testing declined in Linkpoint Pymnt Module
    By WhiteWolf in forum Built-in Shipping and Payment Modules
    Replies: 8
    Last Post: 3 Jul 2009, 04:27 PM
  2. Help with testing
    By SmartSeller in forum Templates, Stylesheets, Page Layout
    Replies: 5
    Last Post: 3 Dec 2007, 08:38 PM
  3. testing
    By mex in forum Templates, Stylesheets, Page Layout
    Replies: 0
    Last Post: 3 Mar 2007, 03:46 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •