Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2006
    Posts
    168
    Plugin Contributions
    0

    Default updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edit

    Hi guys!! 1.5 rocks!!

    however, encountered some minor hiccup probably when upgrading from 1.3.9 to 1.5. Normally, when I edit the main page, instead of editing the files directly, I go to the admin portal -> tools -> define pages editor. It was working fine in 1.3.9, but now in 1.5, it's not showing the pages. I instead just see a white text box with no HTML code.... and above it, it shows the correct path and filename of the page I want to edit:

    /home/domain/domain.com/html/online/includes/languages/english/html_includes/mytemplate/define_main_page.php

    I checked permissions and they are correct. Any suggestions? For now I'm editing directly the files, but I prefer using the admin portal.

    Thanks guys!!

  2. #2
    Join Date
    Jun 2006
    Posts
    168
    Plugin Contributions
    0

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    Actually, it's not only the define pages editor that's messed up.... Everythign with a large text box shows empty data. Like in the Product description, the contents of the product do not show up. Just shows a big white text box.....

    Any idea what could be causing this?

  3. #3
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,623
    Plugin Contributions
    3

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    Do you mean that the HTML editor is missing ? If so, you'll need to install this:

    http://www.zen-cart.com/index.php?ma...oducts_id=1626

  4. #4
    Join Date
    Jun 2006
    Posts
    168
    Plugin Contributions
    0

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    even in text editor mode, the contents are not showing up....

    the same goes when i try to edit a product, the product description disappears as well.....

    I checked for errors, and found this in the debug file:

    [15-Mar-2012 11:39:26] PHP Warning: htmlspecialchars() [<a href='function.htmlspecialchars'>function.htmlspecialchars</a>]: Invalid multibyte sequence in argument in /home/domain/domain.com/html/folder/admin/includes/modules/product/collect_info.php on line 410

  5. #5
    Join Date
    Jun 2006
    Posts
    168
    Plugin Contributions
    0

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    and it only happens on sites updated from 1.3.9 to 1.5. any other site on the same server that's a fresh install of 1.5 shows up correctly....

  6. #6
    Join Date
    Jun 2006
    Posts
    168
    Plugin Contributions
    0

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    ok fixed it by changing utf-8 to iso-8859-1 in the admin configure.php file.

    one thing that puzzles me though... new installs use utf-8 and they work fine. also if I go to phpmyadmin for the upgraded installs (1.3.9 to 1.5) they show MySQL charset: UTF-8 Unicode (utf8).

    So how come when the charset is utf-8 in zen admin it wouldn't show some of the html codes???

  7. #7
    Join Date
    Jan 2004
    Posts
    60,330
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    If your database content isn't UTF-8, then you will want to NOT use UTF-8:
    http://tutorials.zen-cart.com/index.php?article=414

    And "iso-8859-1" is incorrect for DB_CHARSET configure.php file defines. In those files it would be "latin1" instead. I think there's a comment to that effect directly within the file itself.

    And you need to use the same DB_CHARSET in both of your configure.php files. They need to be set to the same.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  8. #8
    Join Date
    Mar 2007
    Posts
    53
    Plugin Contributions
    0

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    I have this issue as well - upgraded from 1.3.7 to 1.5 and now the pages show as blank in the define pages editor, with the ' Invalid multibyte sequence in argument error' shown in the cache debug directory.

    I can't see anywhere to change this in the configure.php file, and in my english.php file, there is already a line saying

    define('CHARSET', 'utf-8');

    Where should I be looking?

  9. #9
    Join Date
    Jan 2004
    Posts
    60,330
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    Quote Originally Posted by jmouse View Post
    I have this issue as well - upgraded from 1.3.7 to 1.5 and now the pages show as blank in the define pages editor, with the ' Invalid multibyte sequence in argument error' shown in the cache debug directory.

    I can't see anywhere to change this in the configure.php file, and in my english.php file, there is already a line saying

    define('CHARSET', 'utf-8');

    Where should I be looking?
    http://tutorials.zen-cart.com/index.php?article=414
    If you upgraded from 1.3.7 then your database content is based on latin1 / iso-8859-1 and NOT based on utf8.
    So, your upgraded site should NOT be using utf8. So, change your english.php files' CHARSET from 'utf-8' to 'iso-8859-1'
    See: http://tutorials.zen-cart.com/index.php?article=414
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #10
    Join Date
    Mar 2007
    Posts
    53
    Plugin Contributions
    0

    Default Re: updated to 1.5 (from 1.3.9), now define pages editor not loading the pages to edi

    Ah-HA! Thanks for that.

 

 

Similar Threads

  1. Can't edit pages in define editor pages
    By Rich219 in forum Customization from the Admin
    Replies: 6
    Last Post: 28 Jul 2010, 11:24 AM
  2. why can I not edit any of the pages in Define Pages editor?
    By touchclothing in forum General Questions
    Replies: 5
    Last Post: 20 Aug 2009, 04:21 PM
  3. I lost my HTMLarea editor in Define pages edit
    By jojovale in forum General Questions
    Replies: 0
    Last Post: 21 May 2008, 04:56 AM
  4. Can't edit in Define Pages Editor
    By leeshalynn in forum Customization from the Admin
    Replies: 3
    Last Post: 9 Mar 2007, 05:13 AM
  5. Cannot edit via Define Pages Editor
    By Nellie in forum Basic Configuration
    Replies: 1
    Last Post: 15 May 2006, 07:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •