Page 1 of 2 12 LastLast
Results 1 to 10 of 19
  1. #1
    Join Date
    Jul 2011
    Posts
    114
    Plugin Contributions
    0

    Default Site moving issues - Please help!

    Moving the shopping cart from one server to another (URL is also changing) I've been following the step by step instructions at:

    http://tutorials.zen-cart.com/index.php?article=100

    The last step is:
    6. Grab the "Fix_Cache_Key" utility to reset your Admin->Sessions->Session Directory key so that it uses the proper folder path for your new server:
    http://www.zen-cart.com/index.php?ma...products_id=82

    Simply upload the file to your NEW Zen Cart folder and open fix_cache_key.php in your browser. It will give you status messages. Delete fix_cache_key.php when you're finished.


    When I do this I get a screen that says nothing but the following:

    1146 Table 'MYDATABASE.configuration' doesn't exist
    in:
    [select configuration_key as cfgkey, configuration_value as cfgvalue from configuration]

    (I've replaced my actual database name in the above with MYDATABASE)


    I'm lost here, can you help?

  2. #2
    Join Date
    Mar 2008
    Location
    Cape Town & London (depends on the season)
    Posts
    2,984
    Plugin Contributions
    0

    Default Re: Site moving issues - Please help!

    If you now log into your admin panel, go to Configuration >>> Sessions, and tell me what you see there... in "Session Directory"

  3. #3
    Join Date
    Jul 2011
    Posts
    114
    Plugin Contributions
    0

    Default Re: Site moving issues - Please help!

    It is giving me the same message when trying to log into the admin panel:

    1146 Table 'MYDATABASE.project_version' doesn't exist
    in:
    [select * from project_version WHERE project_version_key = 'Zen-Cart Database' ]
    If you were entering information, press the BACK button in your browser and re-check the information you had entered to be sure you left no blank fields.

  4. #4
    Join Date
    Mar 2008
    Location
    Cape Town & London (depends on the season)
    Posts
    2,984
    Plugin Contributions
    0

    Default Re: Site moving issues - Please help!

    You say that the URL is also changing. Did you put the new URL into the HTTP configures?

    Additionally, your database may either be corrupt or malconfigured. Your system seems to be finding a database. If it didn't it would come up with quite a neat page telling you that it could not find a database.

    Try creating a NEW database (if your host allows more than one database) and bring your database backup (from the old installation) into that new database. Remember to change the CONFIGURE php files as well, to show the new database's name (and if you created a new user for that new DB, then change that info too.)

  5. #5
    Join Date
    Jan 2004
    Posts
    59,816
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Site moving issues - Please help!

    Quote Originally Posted by In2Deep View Post
    Moving the shopping cart from one server to another (URL is also changing) I've been following the step by step instructions at:

    http://tutorials.zen-cart.com/index.php?article=100
    Take a look back at that article, in step 2(a).
    Did you use the same DB_PREFIX in the new store as you had been using in the old store?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  6. #6
    Join Date
    Jul 2011
    Posts
    114
    Plugin Contributions
    0

    Default Re: Site moving issues - Please help!

    Quote Originally Posted by fairestcape View Post
    You say that the URL is also changing. Did you put the new URL into the HTTP configures?
    Yes I did this, the two configure files have been edited.

    Quote Originally Posted by DrByte View Post
    Take a look back at that article, in step 2(a).
    Did you use the same DB_PREFIX in the new store as you had been using in the old store?
    Yes, 2a was done and good to go when I did it. The fresh install was good to go. Hit the snag on step 6.

  7. #7
    Join Date
    Mar 2008
    Location
    Cape Town & London (depends on the season)
    Posts
    2,984
    Plugin Contributions
    0

    Default Re: Site moving issues - Please help!

    Did you try to access the site BEFORE running step 6? If so, did you see anything "meaningful" or did you get Dbase errors?

    There is no reason why running fix_cache_key (step 6) would corrupt the database... all it does is write correct information to the relevant table. In your case, it's not even finding that table, and appears to be struggling to find tables when you attempt to get into admin.

    So the problem lies in the way you have configured your database, or your configure.php files.

    What do you see when you call up the database in phpMyAdmin? Are there table prefixes (eg: zen_ )? Are all tables there? See if the table that fix_cache_key is reporting as "not found" is actually in the database.

  8. #8
    Join Date
    Jan 2004
    Posts
    59,816
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Site moving issues - Please help!

    It's telling you that it's trying to access a table that it can't find. Probably because the prefix doesn't match.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  9. #9
    Join Date
    Jun 2005
    Location
    Hertfordshire, UK
    Posts
    9,954
    Plugin Contributions
    3

    Default Re: Site moving issues - Please help!

    In your configure.php files, (assuming that there IS a prefix on your tables) does it say:

    zen

    or

    zen_
    Our latest project is Pet Tags.

  10. #10
    Join Date
    Jul 2011
    Posts
    114
    Plugin Contributions
    0

    Default Re: Site moving issues - Please help!

    Quote Originally Posted by schoolboy View Post
    In your configure.php files, (assuming that there IS a prefix on your tables) does it say:

    zen

    or

    zen_
    OMFG, doh. I guess I was being sloppy. Too many hours in front of the computer. Woke up this morning and looked at this with a fresh head and fixed it. Thanks guys! It was the prefix being entered wrong.


 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. v139h Some issues with moving site up one level
    By mudpit in forum General Questions
    Replies: 1
    Last Post: 14 Mar 2012, 02:48 AM
  2. Moving oscommerce to zen and possible issues
    By webbydeb in forum General Questions
    Replies: 19
    Last Post: 10 Jun 2011, 02:39 AM
  3. Issues after moving to a new server
    By geeker in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 17 Mar 2011, 04:58 PM
  4. Checkout issues (prepayment, moving .important a.o.)
    By scrap in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 29 Mar 2009, 10:04 PM
  5. moving site problem (site template doesnot show up now)
    By mrcoolboy15 in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 18 Jul 2008, 09:48 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •