Results 1 to 5 of 5
  1. #1
    Join Date
    Mar 2007
    Posts
    28
    Plugin Contributions
    0

    Default Site down after upgrade attemp, can't access admin section

    Hi,

    my site is currently down as the upgrade has not gone as planned. I'm moving from 1.3.7 to 1.5.

    The issue is that when I try to access the admin section I get the; "You are seeing this page for one or more reasons".

    It suggests there is an issue with the paths in the includes/config.php file or there are issues with the database connection. The paths are correct and the database settings are correct. What is going on?

    I ran the zc_install, updated the database settings and ran the upgrade. I got some skipped items:

    SKIPPED: Cannot ALTER or INSERT/REPLACE into table linkpoint_api because it does not exist. CHECK PREFIXES!
    SKIPPED: Cannot drop index page_accessed on table admin_activity_log because it does not exist.
    SKIPPED: Cannot drop index access_date on table admin_activity_log because it does not exist.
    SKIPPED: Cannot add index idx_page_accessed_zen to table admin_activity_log because it already exists.
    SKIPPED: Cannot add index idx_access_date_zen to table admin_activity_log because it already exists.

    but no errors. The upgrade is installed at root folder and the database settings are correct (the upgrade couldn't have worked it they were not).

    I installed zc 1.5 under a new folder to test and it worked fine. I then merged the old and new versions and uploaded to root. Backed up the db and restoed to new db. Then ran the upgrade. I've tried this twice now with the same results.

    Please help, as site is down and I'm stuck.

    thanks T

  2. #2
    Join Date
    Feb 2005
    Location
    Lansing, Michigan USA
    Posts
    19,270
    Plugin Contributions
    3

    Default Re: Site down after upgrade attemp, can't access admin section

    In almost every case I've seen, you only get that 'You are seeing ...' page if the paths in the configure.php file aren't correct, so triple-check them.

  3. #3
    Join Date
    Mar 2007
    Posts
    28
    Plugin Contributions
    0

    Default Re: Site down after upgrade attemp, can't access admin section

    Hi,

    Thanks for the response. Below is my admin/includes/configure.php, the paths look ok to me. ZC is installed under the root folder. Maybe I'm missing something, a critical / somewhere perhaps. A diff with the original sites configure.php doesn't show anything different, well except the ZC creates the admin path, i.e. no long hard coded in the file.

    <?php
    define('HTTP_SERVER', 'http://www.domain.com');
    define('HTTPS_SERVER', 'https://domain.com');
    define('HTTP_CATALOG_SERVER', 'http://www.domain.com');
    define('HTTPS_CATALOG_SERVER', 'https://www.domain.com');

    define('ENABLE_SSL_ADMIN', 'false');

    define('ENABLE_SSL_CATALOG', 'false');

    $t1 = parse_url(HTTP_SERVER);$p1 = $t1['path'];$t2 = parse_url(HTTPS_SERVER);$p2 = $t2['path'];

    define('DIR_WS_ADMIN', preg_replace('#^' . str_replace('-', '\-', $p1) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/');
    define('DIR_WS_CATALOG', '/');
    define('DIR_WS_HTTPS_ADMIN', preg_replace('#^' . str_replace('-', '\-', $p2) . '#', '', dirname($_SERVER['SCRIPT_NAME'])) . '/');
    define('DIR_WS_HTTPS_CATALOG', '/');

    define('DIR_WS_IMAGES', 'images/');
    define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');
    define('DIR_WS_CATALOG_IMAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'images/');
    define('DIR_WS_CATALOG_TEMPLATE', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/templates/');
    define('DIR_WS_INCLUDES', 'includes/');
    define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
    define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
    define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
    define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
    define('DIR_WS_CATALOG_LANGUAGES', HTTP_CATALOG_SERVER . DIR_WS_CATALOG . 'includes/languages/');

    define('DIR_FS_ADMIN', realpath(dirname(__FILE__) . '/../') . '/');
    define('DIR_FS_CATALOG', '/');

    define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');
    define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');
    define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');
    define('DIR_FS_CATALOG_TEMPLATES', DIR_FS_CATALOG . 'includes/templates/');
    define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');
    define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');
    define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

    define('SQL_CACHE_METHOD', 'none');
    define('DIR_FS_SQL_CACHE', '/home/user/public_html/cache');

  4. #4
    Join Date
    Mar 2007
    Posts
    28
    Plugin Contributions
    0

    Default Re: Site down after upgrade attemp, can't access admin section



    define('DIR_FS_CATALOG', '/');

    was the culprit, should have a path.

    define('DIR_FS_CATALOG', '/path/to/public_html/');

    Thanks

  5. #5
    Join Date
    Apr 2006
    Location
    Ohio
    Posts
    6,097
    Plugin Contributions
    0

    Default Re: Site down after upgrade attemp, can't access admin section

    Thank you for posting the fix ..
    Mark
    Hare Do - Does the rabbit beat Zen "never".
    Zen Cart 1.5.1 Update Release Need help Purchase the Book

 

 

Similar Threads

  1. Can't access my site's admin section
    By Tamuren in forum General Questions
    Replies: 2
    Last Post: 22 Aug 2011, 11:34 PM
  2. Replies: 3
    Last Post: 25 Jul 2007, 07:13 AM
  3. Cannot access Admin section???
    By SFAShop in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 18 Dec 2006, 03:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •