Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2012
    Posts
    8
    Plugin Contributions
    0

    Default Suddenly getting Apache test page

    Having a huge problem. Store and all customisation was working fine for months. no changes made but suddenly started getting apache test page for linux error. Wanted to follow instructions as suggested in the welcome.conf file but using Plesk control panel so have no access to linux files. I contacted service provider for access so i could edit using ssh client but was informed by SP that they do not provide this access. They simply stated that the reason i am getting the error is because i do not have an index.html, index.htm or index.php file in the root of my /httpdocs folder. My problem is that i never had one in there when the site worked properly so why now. Secondly if i do require one what should the content of it be. I created one as a test and added some generic html content from my define_main_page.php file and all it does is display the raw html content. its not linked to a stylesheet so obviously no formatting but the actual store does not load at all. i dont care about formatting but how do i get my template to load.
    I reverted back to the classic template, created a new template, searched the forums, renamed .htaccess files etc to no avail.
    Is there a way to create an index file in /httpdocs root and link it to the rest of my template files? Is that the actual solution. Forgive my ignorance but i am very new to this and know very little about web dev.
    My site address is www.poor-boys.co.za.
    I have gone around in circles here and am fresh outta ideas so any suggestions would be greatly appreciated.

    Naz

  2. #2
    Join Date
    Jan 2004
    Posts
    60,253
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: Suddenly getting Apache test page

    Quote Originally Posted by Naz_newbie View Post
    They simply stated that the reason i am getting the error is because i do not have an index.html, index.htm or index.php file in the root of my /httpdocs folder. My problem is that i never had one in there when the site worked properly so why now.
    Zen Cart requires an index.php to run. And even comes with the required files.
    So, with respect, your statement is inaccurate.
    You will need to restore the file that's been deleted.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Jan 2004
    Posts
    60,253
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: Suddenly getting Apache test page

    I see you went and started a second duplicate thread on the same topic, and found a resolution there, but didn't come back here and say that the problem was resolved.
    That's why starting multiple identical discussions is frowned upon. Please don't do that in the future.

    http://www.zen-cart.com/forum/showthread.php?t=195057
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Replies: 7
    Last Post: 28 Feb 2012, 10:26 PM
  2. Upgrade Apache from 1.x to 2.2 now https cannot display page
    By sngskunk in forum Installing on a Linux/Unix Server
    Replies: 3
    Last Post: 28 Aug 2008, 02:04 AM
  3. Test Server wtih Apache and IIS
    By Lfong6266 in forum Installing on a Windows Server
    Replies: 3
    Last Post: 16 Sep 2007, 12:56 AM
  4. All graphics on my test site suddenly disappear
    By LuKhach in forum General Questions
    Replies: 5
    Last Post: 4 Jul 2007, 02:56 AM
  5. apache test error wen installed
    By bidsea in forum Installing on a Linux/Unix Server
    Replies: 2
    Last Post: 16 Jan 2007, 09:35 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •