Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Join Date
    Nov 2006
    Posts
    9
    Plugin Contributions
    0

    Default Admin Password required to proceed with upgrade Nightmare

    I've been struggling with this for hours and it's incredibly frustrating.
    I've viewed every post I can find that mentions this problem but I still
    can't find a solution.

    I'm trying to upgrade from 1.38a to 1.5, the DB Upgrade page
    has 2 boxes ticked for upgrading from 1.38 to 1.39 and 1.39 to 1.5.

    I'm starting to think I should do these separately, but this doesn't seem
    possible via the upgrade page, because I've exhausted every other avenue.

    I get the following message on trying to upgrade -

    Admin Password required to proceed with upgrade

    I'm using the correct Admin details, not the configure/DB access details.
    I have a duplicate copy of the live site DB that I'm attempting to upgrade.
    The duplicate was only made yesterday and the admin details are exactly the same.
    I've logged in to the Admin on the live site a number of times whilst trying
    to resolve this to check. All the paths in the configure file are correct.

    I've even compared the hash password in both DB's via phpMyAdmin
    and tried changing the configure file to upgrade the live DB rather than the new
    DB. I figured since they match I could just switch the new DB to be live
    instead until I was ready. No joy! Still the same error even though I
    logged in to the Admin a few minutes before switching the DB
    connections around.

    I've noticed it's recommended that on accessing the 1.5 Admin you
    should not do it with other browser tabs open, I tried that, just the
    upgrade page open, nope no joy there either.

    I usually cut & paste a password to avoid typos but I tried typing this
    in case there was some paste blocking code. Nope.

    Nothing has worked I still get the same fecking error!

    So what else could possibly be going on? And what's left to try?!

    tia,

  2. #2
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,794
    Plugin Contributions
    3

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Quote Originally Posted by dustmagic View Post
    I'm trying to upgrade from 1.38a to 1.5, the DB Upgrade page
    has 2 boxes ticked for upgrading from 1.38 to 1.39 and 1.39 to 1.5.

    I'm starting to think I should do these separately,
    Your thinking is good, V1.38 to V1.50 is a *huge* jump, and the general recommendation is to do them separately.

    Quote Originally Posted by dustmagic View Post
    but this doesn't seem
    possible via the upgrade page, because I've exhausted every other avenue.
    Although it is quite possible to do the entire upgrade using the V1.50 files (I think), you will probably find it a lot less troublesome to literally do it as two separate upgrades.. First using the V1.3.9 distribution files, and after you have a working V1.3.9 install you can consider using the V1.5 files to 'complete' the task.

    I appreciate that this may seem a long winded way of doing it (especially as V1.5.0 does appear to allow the intermediate V1.3.9 update), but I suspect that this particular upgrade path hasn't been as extensively tested as the two stage process.

    I think a lot of it has to do with luck, and the rest has to do with whatever add-ons you are using.

    V1.3.9 is considered stable and secure so there is no urgency to move on to V1.5... it is imperative that you decommission V1.3.8 ASAP though.

    Cheers
    Rod

  3. #3
    Join Date
    Nov 2006
    Posts
    9
    Plugin Contributions
    0

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Hi Rod,

    Thanks for the reply. The two stage upgrade looks like the
    path to folllow then.

    I haven't installed any Mods at this stage I was upgrading
    and then moving on to adding those back in. Maybe that's
    an issue as there's likely Mod data in the DB that could be
    throwing things off.

    I'll hang back for now on moving to 1.39 instead and see
    if there are any other suggestions. Going the 1.39 route
    shouldnt be too much of an issue as I only have a few files
    to edit but it's still a hassle considering how much time I've
    already wasted on the admin password issue. :\

    Thanks again. ;)

  4. #4
    Join Date
    Jan 2007
    Location
    Los Angeles, California, United States
    Posts
    8,866
    Plugin Contributions
    31

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Quote Originally Posted by RodG View Post
    Your thinking is good, V1.38 to V1.50 is a *huge* jump, and the general recommendation is to do them separately.
    Not according to posts by DrByte unless I misunderstood him.. His posts seemed to indicated that there isn't any reason to NOT make the jump form v1.3.8 to v1.5..

    Personally I just did a couple of 1.3.8 to 1.5 upgrades, and in my experience as long as both the 1.3.8 to 1.3.9 and 1.3.9 to 1.5 checkboxes are checked it all goes just fine..

    I opted to do my upgrade by doing a clean vanilla install of 1.5 (no test products). After a quick looksee to make sure that v1.5 is installed and working, I replace my v1.5 DB with my 1.3.8 DB by doing a DB restore. Then I navigated to the zc_install directory and walked through the upgrade steps.

    After that I start with restoring my template and then re-install my add-ons one by one.. Since Zen Cart has no add-on "repository", all add-ons have to be manually re-installed anyway, and this gives me an opportunity to do some "housekeeping".

    I chose approaching things this way because I found out after doing a few upgrades that the configure.php files created in a vanilla v1.5 install different than the ones from my older v1.3.8 and v1.3.9 installs.
    My Site
    I don't answer support questions via PM. Post add-on support questions in the support thread. The question & the answer will benefit others with similar issues.

  5. #5
    Join Date
    Jan 2004
    Posts
    60,330
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Admin Password required to proceed with upgrade Nightmare

    The only time I've seen anyone have a problem with the password for upgrading is when they were indeed using the wrong password. You must use the same password that you would use to login as your admin user. Not the hash value you see in the db table. Not the password you used when you did your fresh install before importing old data. Not the password to MySQL database.

    And yes, going from 1.3.8 to 1.5.0 by using the v1.5.0 zc_install is fine. If you wish to do it with one checkbox at a time, that's fine too. There's definitely no reason to use the complete 1.3.9 codebase as an interim step, as that's wasted time unless you are actually planning to run the entire site in 1.3.9 for awhile ... which would be a pointless exercise. It can be done, but is pointless. Using the 1.5.0 upgrade code is actually better because the upgrade to 1.3.9 in 1.3.9 actually contains a few inefficiencies in the upgrade code. In summary: use the latest code. Period.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6
    Join Date
    Jan 2007
    Location
    Australia
    Posts
    4,794
    Plugin Contributions
    3

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Quote Originally Posted by dustmagic View Post
    Hi Rod,

    Thanks for the reply. The two stage upgrade looks like the
    path to folllow then.
    I've been outvoted 2/1 with DrByte holding the trump card.

    Please disregard my previous response (other than the fact that you need to decommission V1.38 ASAP).

    Cheers
    Rod

  7. #7
    Join Date
    Nov 2006
    Posts
    9
    Plugin Contributions
    0

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Thanks for the replies. I've since unploaded the 1.39 files and tried the upgrade again...
    exactly the same issue.

    I'm definately using the right Admin and password, I just logged in to the 1.39 install
    Admin with it. It's not the configure/SQL user and pass or the hash neither is it the ftp
    or my internet banking details.

    In attempting this upgrade I get a box tiicked for upgrading from 1.11 to 1.12 as well as
    the 1.38 to 1.39. I've tried upgrading these together and alone and there's no change -

    'Admin Password required to proceed with upgrade'

    And 'Diva Vocals' I'm taking the exact same upgrade route, test install, link to old DB,
    Upgrade DB, template and finally Mods but I just cannot get the DB upgraded.

    I've checked the DB tables against another ZC install elsewhere and they're all present.

    I really don't know what else to try.

  8. #8
    Join Date
    Jan 2004
    Posts
    60,330
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Can I suggest that you double-check that the files in /zc_install/includes/classes/*.php and /zc_install/includes/functions/*.php are present and complete, and unaltered.

    And that the DB_PREFIX in the new site configure.php is the same as the DB_PREFIX in the old one.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  9. #9
    Join Date
    Nov 2006
    Posts
    9
    Plugin Contributions
    0

    Default Re: Admin Password required to proceed with upgrade Nightmare

    I've double checked the files n the zc_install and uploaded them all again
    for both versions and attempted the DB upgrade on both, no change.

    The DB doesn't have a prefix.

    Maybe it's time to start digging about in the code and set the
    'admin login checked' to true.

  10. #10
    Join Date
    Jan 2004
    Posts
    60,330
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Admin Password required to proceed with upgrade Nightmare

    Of the thousands of times I've run zc_install to do upgrades the only times I ever get that message is when the database table does NOT include an entry matching the encrypted version of the password I'm typing in.

    ie: you're using the wrong password against the wrong database

    ie: the password you're entering cannot be used to authenticate the login

    That's the only reason why it wouldn't work.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. can't proceed to Admin or Store
    By elninomago in forum Installing on a Windows Server
    Replies: 3
    Last Post: 5 May 2010, 06:46 PM
  2. Admin Password required to proceed with upgrade
    By keneso in forum Upgrading from 1.3.x to 1.3.9
    Replies: 4
    Last Post: 4 May 2010, 06:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •