Results 1 to 9 of 9
  1. #1

    Default Some pages are blank

    Hi great community,

    I want to share an issue that we are trying to troubleshoot during the last week without success. Hopefully someone can help us out.

    Domain name is okidoqui.com. We have many modules installed including multisite, permission manager, Simple SEO, and many more.

    We have the SSL certificate installed with works fine if you check by going on https://www.okidoqui.com, but many pages that require the SSL connection are not working. For instance, if you click on a product such as this: http://okidoqui.com/accessories-cabl...-ties-p-676536.

    If you click on add product, you will get a blank page. The same if you try to login. Well, the admin uses SSL connection and it works fine without any problems.

    Please let us know which files or part of files you may need us to post for understanding what the problem is.

    All best,

  2. #2
    Join Date
    Nov 2007
    Location
    Sunny Coast, Australia
    Posts
    2,507
    Plugin Contributions
    7

    Default Re: Some SSL pages are not working

    Your login page works fine for me.

    Take a look at this thread for the "add to cart" issue: http://www.zen-cart.com/showthread.p...ght=blank+page
    Zen Cart with a Passion (Fair Dinkum Australian): iSO Network | frNT Online Dispensary
    Contribs: CSAR | German Language Pack | Local Delivery Only

  3. #3

    Default Re: Some SSL pages are not working

    Quote Originally Posted by frank18 View Post
    Your login page works fine for me.

    Take a look at this thread for the "add to cart" issue: http://www.zen-cart.com/showthread.p...ght=blank+page
    I ran the debugging tool and I get these PHP warninngs:

    [25-Apr-2012 13:59:21] PHP Warning: session_save_path() [<a href='function.session-save-path'>function.session-save-path</a>]: Unable to access /okidoqui/public_html/cache in /home2/okidoqui/public_html/includes/functions/sessions.php on line 156
    [25-Apr-2012 13:59:21] PHP Warning: Cannot modify header information - headers already sent by (output started at /home2/okidoqui/public_html/includes/languages/english/header.php:33) in /home2/okidoqui/public_html/includes/init_includes/overrides/init_templates.php on line 79
    [25-Apr-2012 13:59:21] PHP Warning: Cannot modify header information - headers already sent by (output started at /home2/okidoqui/public_html/includes/languages/english/header.php:33) in /home2/okidoqui/public_html/includes/modules/pages/product_info/header_php.php on line 29
    [25-Apr-2012 14:13:22] PHP Warning: Cannot modify header information - headers already sent by (output started at /home2/okidoqui/public_html/includes/languages/english/header.php:33) in /home2/okidoqui/public_html/includes/functions/functions_general.php on line 44

    Any suggestions?

  4. #4

    Default Re: Some SSL pages are not working

    wrong post
    Last edited by riky; 26 Apr 2012 at 03:23 AM. Reason: wrong thread

  5. #5

    Default Re: Some SSL pages are not working

    Also the some searches do not work. For instance, if you search for SAMSUNG ME 55A, a blank page will open. Hopefully someone can help me.

    Thanks in advance.

  6. #6

    Default Re: Some SSL pages are not working

    Quote Originally Posted by frank18 View Post
    Your login page works fine for me.

    Take a look at this thread for the "add to cart" issue: http://www.zen-cart.com/showthread.p...ght=blank+page
    The login page opens but if you actually insert real credentials you will see a blank page. You can try the following credentials.

    Username: test2@okidoqui.com
    Password: zencart

  7. #7

    Default Re: Some SSL pages are not working

    With Samsung ME 55A is working now but it is not working for some words. For instance try to search for hello.
    You will get a blank page.

  8. #8
    Join Date
    Jan 2004
    Posts
    60,443
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: Some SSL pages are not working

    Quote Originally Posted by riky View Post
    [25-Apr-2012 13:59:21] PHP Warning: Cannot modify header information - headers already sent by (output started at /home2/okidoqui/public_html/includes/languages/english/header.php:33) in /home2/okidoqui/public_html/includes/init_includes/overrides/init_templates.php on line 79
    [25-Apr-2012 13:59:21] PHP Warning: Cannot modify header information - headers already sent by (output started at /home2/okidoqui/public_html/includes/languages/english/header.php:33) in /home2/okidoqui/public_html/includes/modules/pages/product_info/header_php.php on line 29
    [25-Apr-2012 14:13:22] PHP Warning: Cannot modify header information - headers already sent by (output started at /home2/okidoqui/public_html/includes/languages/english/header.php:33) in /home2/okidoqui/public_html/includes/functions/functions_general.php on line 44

    Any suggestions?
    Suggestions? Yes. Fix those errors.
    There are Tutorial/FAQ articles talking about them, easily found by using the Search. Example: http://www.zen-cart.com/content.php?...s-already-sent
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  9. #9

    Default Re: Some SSL pages are not working

    Thanks for the link.

    I fixed the problem. I removed a blank line at the end of the header.php file. I can't believe that a blank line created all these problems.

 

 

Similar Threads

  1. Blank Web Pages after changing Page_2_3_4 URLs in Define Pages
    By chevvychase81 in forum General Questions
    Replies: 14
    Last Post: 31 Mar 2011, 10:15 AM
  2. Blank Pages
    By extremeguncare in forum Templates, Stylesheets, Page Layout
    Replies: 5
    Last Post: 25 Apr 2010, 03:10 PM
  3. Blank Pages That Should Not Be Blank
    By bumba000 in forum General Questions
    Replies: 6
    Last Post: 26 Aug 2008, 05:26 PM
  4. Blank Pages
    By smillard in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 6 Sep 2007, 01:10 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •