Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2005
    Posts
    28
    Plugin Contributions
    0

    Default Zen Light Box does not work with latest version of FireFox and Safari browsers

    I just upgraded my browsers, FireFox and Safari to the latest versions this week and now Zen Lightbox no longer displays the larger images.


    I am running Zen Cart 1.3.8a. What is the latest version of Zen Lightbox I can install that will work with Zen Cart 1.3.8a?

    I am running an older version of Zen Lightbox now. I'm not sure what version it was but it was installed around April 2010.

    The reason for upgrading Zen Lightbox is because the version installed no longer works with the latest browsers for Mac at least anyway as I haven't tested it on PC browsers but presume it will not work on PC as well.

    Is anyone else having such issues ?
    Why would Zen Lightbox stop working with the current web browsers?
    Can I change something in Zen Lightbox for it to work with the latest browsers ?

    I don't want to upgrade Zen Cart because that's a massive task as my Zencart is very customised.

    Any help would be very appreciated !

    Thanks

    Dom

  2. #2
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    49

    Default Re: Zen Light Box does not work with latest version of FireFox and Safari browsers

    Quote Originally Posted by domnz View Post
    I am running Zen Cart 1.3.8a.

    I don't want to upgrade Zen Cart because that's a massive task as my Zencart is very customised.
    I guess you like leaving your site open to security problems more than you like protecting your customers data and transactions.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3

    Default Re: Zen Light Box does not work with latest version of FireFox and Safari browsers

    Quote Originally Posted by domnz View Post
    I just upgraded my browsers, FireFox and Safari to the latest versions this week and now Zen Lightbox no longer displays the larger images.
    That's because you're using outdated software (both ZC and ZLB) with modern, updated browsers.


    Quote Originally Posted by domnz View Post
    I am running Zen Cart 1.3.8a. What is the latest version of Zen Lightbox I can install that will work with Zen Cart 1.3.8a?
    For ZC 138, you can only use the version of ZLB designed to work with that version of ZC.


    Quote Originally Posted by domnz View Post
    Is anyone else having such issues ?
    Anyone running ZC138 and an equally old version of ZLB would be having the same issues.


    Quote Originally Posted by domnz View Post
    Why would Zen Lightbox stop working with the current web browsers?
    Zen Lightbox is updated as browsers are updated. This is because Zen Lightbox and browsers work together to serve your page's content (as would be expected). Additionally, Zen Lightbox is updated as Zen Cart is updated so they will be compatible together.


    Quote Originally Posted by domnz View Post
    Can I change something in Zen Lightbox for it to work with the latest browsers?
    ZLB is already updated to work with the latest browser. But it won't work in your very old, very unsecure store.


    Quote Originally Posted by domnz View Post
    I don't want to upgrade Zen Cart because that's a massive task as my Zencart is very customised.
    I completely understand what you're saying here - it can be a daunting task to upgrade when you have a heavily customized store, but this is a poor excuse for putting your customer's data and financial safety at risk. If you're going to be in business, then you have a responsibility to those people who keep you in business - your customers. You owe it to them to have a safe, secure store which protects their data, their finances, and their identities.

    Best advice - put your nose to the grindstone and do the upgrade. It's not as hard as you think it is. The instructions appear overwhelming because there are so many steps when you're heavily customized....but all those steps are PRECISELY what makes it easier to upgrade than it would appear because they walk you through the process.

    If you don't want to do this, then your alternative is to say goodbye to the lightbox (and to other addons as well) as they will likely begin to fail one by one as technology leaves your store/business in the dust.

    Your choice.

    Good luck and happy Zenning :)
    Go that extra mile, you never know what's at the end of the road

    Empowerment Sanctuary

  4. #4
    Join Date
    Jun 2005
    Posts
    28
    Plugin Contributions
    0

    Default Re: Zen Light Box does not work with latest version of FireFox and Safari browsers

    Thanks for the replies - much appreciated. I do agree regarding the security side and protecting my customers data very much so and that's one of the reasons I hadn't upgraded.

    One of the reasons I've held off upgrading is that I am unable to manage upgrading this myself. I've done small tweaks myself ie stylesheets and installed a couple of basic plug-in modules etc but for any main coding changes to customise the layout and the entire look of the site, I originally used someone offshore who is no longer available. I designed the look of the site myself as I'm from a design background and useless when it comes to php or any real coding at all.

    When I first developed the site I had no customer information or orders of course. But now I have accumulated a lot of orders over this time and I'm quite nervous about having someone I don't really know upgrade the site as they will have access to all the customers info, orders etc. I'm in New Zealand and I can't find any recommended Zen Cart developers down here. I felt if I had a zen cart developer in my own country then it would be easier get to get together and discuss the development and I generally felt safer having a local person access all this personal information rather than someone offshore. Is there some list of highly recommend zen cart developers that you could recommend to me not necessarily from NZ of course. Once I have someone that has been recommended I'll be inclined to go ahead with the upgrade.

    Cheers

    Dom

  5. #5

    Default Re: Zen Light Box does not work with latest version of FireFox and Safari browsers

    On the main page of the forum, there's a link to oDesk - a website where you can hire designers, coders, or folks familiar with ZC for other projects, such as updating your store to the newest version. I tried to post the link, but it's too long to parse. Just go to the main forum page and scroll down until you see "Commercial Help Wanted".

    As with any project that you're hiring someone for, make sure you check them out first. Remember, cheapest is not always best (nor is the most expensive). People who know what they're doing and are highly skilled tend to charge professional rates for their services (as they should), but don't fall in to the trap of "the more I pay, the better job they do" mindset. Select someone who is willing to provide references that you can contact, someone who is willing to discuss your needs and get the specifics of your site from you so that they can give an accurate quote, and preferably someone who guarantees their work.

    Good luck and happy Zenning
    Last edited by ScriptJunkie; 1 May 2012 at 02:29 AM. Reason: remove broken link
    Go that extra mile, you never know what's at the end of the road

    Empowerment Sanctuary

  6. #6
    Join Date
    Sep 2005
    Location
    Waikato, New Zealand
    Posts
    1,494
    Plugin Contributions
    3

    Default Re: Zen Light Box does not work with latest version of FireFox and Safari browsers

    I am suprised you are still able to use 1.3.8 most local hosts seem to have upgraded their php to 5.3 and caused it to break

    For Zen Lightbox, First you need to know what version you have, and go and check out the support thread for it from the release date of the next version onwards as there are bound to be people asking if the newer versions work on 1.3.8, I am fairly sure the latest version doesn't as they removed all the old code from it, so it was cleaner for zen 1.5

    Zen lightbox 1.61 "may" work for you, although i don't know if it was release before or after IE9 changed its CSS stuff
    (I fixed the IE9 bug in ImageHandler, but i can't remember when we spotted it, and i'm not sure if that particular IE "improvement" caused any issues in Zen Lightbox)

    But yeah updating is the way to go.
    Webzings Design
    The last couple of Zen-Cart sites we have worked on, Darncat Designs, Nags to Riches, Magic Brow Bands.

 

 

Similar Threads

  1. Zen Cart Light Box
    By Prasanna in forum All Other Contributions/Addons
    Replies: 0
    Last Post: 3 Mar 2010, 06:18 PM
  2. Zen Light Box no close button
    By powerdog69 in forum All Other Contributions/Addons
    Replies: 2
    Last Post: 27 Jul 2009, 06:22 PM
  3. what is the latest version of zen cart?
    By ebaobao in forum General Questions
    Replies: 2
    Last Post: 9 Aug 2008, 07:22 AM
  4. Protx with latest version of Zen
    By Musicademy in forum Upgrading from 1.3.x to 1.3.9
    Replies: 0
    Last Post: 2 Mar 2007, 07:45 PM
  5. Can't download latest version of zen-cart from sourceforge
    By lvanderb in forum General Questions
    Replies: 18
    Last Post: 22 Oct 2006, 04:59 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •