Page 1 of 3 123 LastLast
Results 1 to 10 of 30
  1. #1
    Join Date
    May 2009
    Location
    Italy
    Posts
    19
    Plugin Contributions
    0

    Default Has anyone gotten this error upon upgrading to 1.5?

    PHP Fatal error: 1146:Table 'cesmush8_zc2.project_version' doesn't exist :: select * from project_version WHERE project_version_key = 'Zen-Cart Database' in /home/cesmush8/public_html/nautilus/includes/classes/db/mysql/query_factory.php on line 101

    Any idea what this is or how to fix it?

    Jeremy

  2. #2
    Join Date
    May 2009
    Location
    Italy
    Posts
    19
    Plugin Contributions
    0

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    As a follow up to my original note, this error appears when I try to log in to the new admin page. The site appears to be working ok by itself, but I can't access admin. I've looked through this forum and have read other problems with admin, but I haven't yet seen this particular problem.

    However, it does appear that my configure.php file is different from others in this forum. Following is the one that auto-installed during the upgrade process for me. I'm disturbed that there do not appear to be any references at all to admin or a path for admin in this file.

    Should I be using a different configure.php?

    Thanks,

    Jeremy

    <?php
    /**
    * @package Configuration Settings circa 1.3.8
    * @copyright Copyright 2003-2007 Zen Cart Development Team
    * @copyright Portions Copyright 2003 osCommerce
    * @license http://www.zen-cart.com/license/2_0.txt GNU Public License V2.0
    */


    /*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/
    /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/

    // Define the webserver and path parameters
    // HTTP_SERVER is your Main webserver: eg, http://www.yourdomain.com
    // HTTPS_SERVER is your Secure webserver: eg, https://www.yourdomain.com
    define('HTTP_SERVER', 'http://www.edizioninautilus.it');
    define('HTTPS_SERVER', 'https://www.edizioninautilus.it');

    // Use secure webserver for checkout procedure?
    define('ENABLE_SSL', 'false');

    // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
    // * DIR_WS_* = Webserver directories (virtual/URL)
    // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
    define('DIR_WS_CATALOG', '/');
    define('DIR_WS_HTTPS_CATALOG', '/');

    define('DIR_WS_IMAGES', 'images/');
    define('DIR_WS_INCLUDES', 'includes/');
    define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
    define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
    define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
    define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
    define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
    define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

    define('DIR_WS_PHPBB', '/');

    // * DIR_FS_* = Filesystem directories (local/physical)
    //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
    define('DIR_FS_CATALOG', '/home/cesmush8/public_html/nautilus/');

    define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
    define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
    define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
    define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
    define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

    // define our database connection
    define('DB_TYPE', 'mysql');
    define('DB_PREFIX', 'zen_');
    define('DB_SERVER', 'localhost');
    define('DB_SERVER_USERNAME', 'my_username');
    define('DB_SERVER_PASSWORD', 'my_password');
    define('DB_DATABASE', 'my_DB');
    define('USE_PCONNECT', 'false'); // use persistent connections?
    define('STORE_SESSIONS', 'db'); // use 'db' for best support, or '' for file-based storage

    // The next 2 "defines" are for SQL cache support.
    // For SQL_CACHE_METHOD, you can select from: none, database, or file
    // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache
    // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
    // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash
    define('SQL_CACHE_METHOD', 'database');
    define('DIR_FS_SQL_CACHE', '/home/cesmush8/public_html/nautilus/cache');

    // EOF

  3. #3
    Join Date
    May 2009
    Location
    Italy
    Posts
    19
    Plugin Contributions
    0

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    I've now added these lines to no avail:

    define('DIR_WS_ADMIN', '/zcadmin/');
    define('DIR_WS_HTTPS_ADMIN', '/zcadmin/');

    define('DIR_FS_ADMIN', '/home/cesmush8/public_html/nautilus/zcadmin/');

    Thought a direct reference to the new admin location that was created by the install script might do the trick, but it did not. Any idea why and attempt to access www.edizioninautilus.it/zcadmin/login.php would give me this error on my browser:

    WARNING: An Error occurred, please refresh the page and try again.

    and this error in my logs:

    PHP Fatal error: 1146:Table 'cesmush8_zc2.project_version' doesn't exist :: select * from project_version WHERE project_version_key = 'Zen-Cart Database' in /home/cesmush8/public_html/nautilus/includes/classes/db/mysql/query_factory.php on line 101

    Can anyone tell me if the table cesmush8_zc2.project_version is a ZenCart table or is this something from an addon perhaps?

    Thanks,

    Jeremy

  4. #4
    Join Date
    Apr 2012
    Location
    Wittenberg, Germany (Sa.Anhalt)
    Posts
    15
    Plugin Contributions
    0

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    have the same Problem with my electric cigarettes shop

    PHP Fatal error: 1146:Table 'DBName.project_version' doesn't exist :: select * from project_version WHERE project_version_key = 'Zen-Cart Database' in /users/DBName/www/includes/classes/db/mysql/query_factory.php on line 101

    Please help...Thanks

  5. #5
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    Simple: it means your DB_PREFIX setting in your two configure.php files is incorrect.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6
    Join Date
    Apr 2012
    Location
    Wittenberg, Germany (Sa.Anhalt)
    Posts
    15
    Plugin Contributions
    0

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    And where are the Fault?
    Thank you for answer me!

    /*************** NOTE: This file is similar, but DIFFERENT from the "admin" version of configure.php. ***********/
    /*************** The 2 files should be kept separate and not used to overwrite each other. ***********/

    // Define the webserver and path parameters
    // HTTP_SERVER is your Main webserver: eg-http://www.your_domain.com
    // HTTPS_SERVER is your Secure webserver: eg-https://www.your_domain.com
    define('HTTP_SERVER', 'http://e-zigarette-preiswert.com');
    define('HTTPS_SERVER', 'https://e-zigarette-preiswert.com');

    // Use secure webserver for checkout procedure?
    define('ENABLE_SSL', 'false');

    // NOTE: be sure to leave the trailing '/' at the end of these lines if you make changes!
    // * DIR_WS_* = Webserver directories (virtual/URL)
    // these paths are relative to top of your webspace ... (ie: under the public_html or httpdocs folder)
    define('DIR_WS_CATALOG', '/');
    define('DIR_WS_HTTPS_CATALOG', '/');

    define('DIR_WS_IMAGES', 'images/');
    define('DIR_WS_INCLUDES', 'includes/');
    define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');
    define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');
    define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');
    define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');
    define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');
    define('DIR_WS_TEMPLATES', DIR_WS_INCLUDES . 'templates/');

    define('DIR_WS_PHPBB', '/');

    // * DIR_FS_* = Filesystem directories (local/physical)
    //the following path is a COMPLETE path to your Zen Cart files. eg: /var/www/vhost/accountname/public_html/store/
    define('DIR_FS_CATALOG', '/users/USERNAME/www/');

    define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');
    define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');
    define('DIR_WS_UPLOADS', DIR_WS_IMAGES . 'uploads/');
    define('DIR_FS_UPLOADS', DIR_FS_CATALOG . DIR_WS_UPLOADS);
    define('DIR_FS_EMAIL_TEMPLATES', DIR_FS_CATALOG . 'email/');

    // define our database connection
    define('DB_TYPE', 'mysql');
    define('DB_PREFIX', '');
    define('DB_CHARSET', 'utf8');
    define('DB_SERVER', 'localhost');
    define('DB_SERVER_USERNAME', '***');
    define('DB_SERVER_PASSWORD', '***');
    define('DB_DATABASE', '****');

    // The next 2 "defines" are for SQL cache support.
    // For SQL_CACHE_METHOD, you can select from: none, database, or file
    // If you choose "file", then you need to set the DIR_FS_SQL_CACHE to a directory where your apache
    // or webserver user has write privileges (chmod 666 or 777). We recommend using the "cache" folder inside the Zen Cart folder
    // ie: /path/to/your/webspace/public_html/zen/cache -- leave no trailing slash
    define('SQL_CACHE_METHOD', 'none');
    define('DIR_FS_SQL_CACHE', '/users/USERNAME/www/cache');

  7. #7
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    What is the DB_PREFIX on the database you imported from?

    In phpMyAdmin, do all your tablenames start with a prefix, such as maybe "zen_"? ie: is your "admin" table actually named "zen_admin"? If so, then your DB_PREFIX needs to be set to "zen_".
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  8. #8
    Join Date
    Apr 2012
    Location
    Wittenberg, Germany (Sa.Anhalt)
    Posts
    15
    Plugin Contributions
    0

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    No Prefixes there...
    alone my ftp admin folder is changed, now ad...

  9. #9
    Join Date
    Jan 2004
    Posts
    60,419
    Blog Entries
    4
    Plugin Contributions
    144

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    Quote Originally Posted by edampfer View Post
    PHP Fatal error: 1146:Table 'DBName.project_version' doesn't exist :: select * from project_version WHERE project_version_key = 'Zen-Cart Database' in /users/DBName/www/includes/classes/db/mysql/query_factory.php on line 101
    "DBName.project_version" literally means "in the database named 'DBName', find the table named "project_version".
    So, when it says "DBName.project_version doesn't exist", that means that when it's looking in the database named "DBName", it can't find the table named "project_version".

    So, either your "project_version" table has a different name, or the "DBName" is incorrect.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  10. #10
    Join Date
    Apr 2012
    Location
    Wittenberg, Germany (Sa.Anhalt)
    Posts
    15
    Plugin Contributions
    0

    Default Re: Has anyone gotten this error upon upgrading to 1.5?

    And where is the "project_version" table?

 

 
Page 1 of 3 123 LastLast

Similar Threads

  1. Forgot Password Page error after upgrading to 1.3.9g plus one more error
    By starruby in forum Upgrading from 1.3.x to 1.3.9
    Replies: 5
    Last Post: 26 Oct 2010, 08:48 AM
  2. upgrading from 1.3.8 to 1.3.9d error
    By tpeck in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 15 Jul 2010, 02:59 AM
  3. Error when upgrading
    By billscheltema in forum Upgrading from 1.3.x to 1.3.9
    Replies: 4
    Last Post: 3 Aug 2008, 06:55 PM
  4. Error when upgrading to 1.3.8.
    By elnaraniall in forum Upgrading from 1.2 to 1.3.x
    Replies: 4
    Last Post: 12 Feb 2008, 12:11 AM
  5. Error after upgrading
    By seattleannie in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 22 Feb 2007, 06:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •