Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default "certain patches may need upgrading" when upgrading 1.3.9 to 1.5

    Hi my website is www.artbylowell.com and I got a email advising my to upgrade to 1.5 from 1.3.9 so I did. Now I have a banner warning that certain patches may need upgrading, go to admin/tools/server info. When I go to said page there is a great deal of info that I do not understand, and no clue as to what I am supposed to do.
    In the meantime, although most of my site is in good shape, the main page and other pages are missing all the images and language I designed and have reverted to default page defines. I checked my file manager and all my page defines are gone. I am attempting to extract the backup files from Softaculous, but doesn't seem to be working. Please help, I'm at sea here, Lowell

  2. #2
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,024
    Plugin Contributions
    25

    Default Re: upgrading 1.3.9 to 1.5

    backup files from Softaculous
    Did you follow a "one-click" upgrade from Softaculous? That is guaranteed to be a disaster, as those programs inherently cannot preserve and upgrade your customized files. I cannot even imagine why they try to offer an "upgrade" service.

    V1.3.9h is stable and secure, so assuming you are able to recover backups you should revert to that and study the tutorials on upgrading, then do it manually on a test copy of your site. When you have it down, THEN you upgrade your live site.
    We cannot help with recovery; that is something your host will have to assist you with.

  3. #3
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default Re: upgrading 1.3.9 to 1.5

    Thank you, I was afraid of that. I guess I have a lot of work to do. But regarding the big red warning banner at the top of my page:
    Your database appears to need patching to a higher level. See Admin->Tools->Server Information to review patch levels.
    I don't know what to do with that. the server info doesn't mean anything to me.

  4. #4
    Join Date
    Jul 2005
    Location
    Upstate NY
    Posts
    22,024
    Plugin Contributions
    25

    Default Re: upgrading 1.3.9 to 1.5

    It means the upgrade didn't complete, leaving the database probably at the 1.3.9 level. If you post the server info minus database/usernames/passwords etc., somebody may be able to advise you better.

  5. #5
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default Re: upgrading 1.3.9 to 1.5

    Quote Originally Posted by gjh42 View Post
    It means the upgrade didn't complete, leaving the database probably at the 1.3.9 level. If you post the server info minus database/usernames/passwords etc., somebody may be able to advise you better.
    Server Host: artbylowell.com
    Server OS: Linux server4.websitehostserver.net 2.6.18-408.el5.lve0.8.58 #1 SMP Wed Mar 14 14:10:01 EDT 2012 x86_64 Database: MySQL 5.0.95-community
    Server Date: 05/02/2012 10:27:33 Database Date: 05/02/2012 10:27:33
    Server Up Time: Unsupported HTTP Server: Apache
    PHP Version: 5.2.17 (Zend: 2.2.0) PHP Memory Limit: 64M PHP Safe Mode: Off
    PHP File Uploads: On Max Size: 10M POST Max Size: 10M
    Database Data Size: 823 kB Database Index Size: 474 kB


    Zen Cart 1.5.0
    Database Patch Level: 1.3.9h
    v1.3.9h [2012-01-01 11:44:04] (Fresh Installation)
    v1.3.9h [2012-01-01 11:44:04] (Fresh Installation)



    PHP Version 5.2.17

  6. #6
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default Re: upgrading 1.3.9 to 1.5

    Should I try re-installing 1.5? or is there a way to re-install 1.3.9 (or is it too late for that?)

  7. #7
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    Default Re: upgrading 1.3.9 to 1.5

    Quote Originally Posted by Lowell37 View Post
    Should I try re-installing 1.5? or is there a way to re-install 1.3.9 (or is it too late for that?)
    Any ideas? Anyone?

  8. #8
    Join Date
    Jan 2004
    Posts
    60,593
    Blog Entries
    4
    Plugin Contributions
    145

    Default Re: upgrading 1.3.9 to 1.5

    It would have been smart to ask your hosting company for help immediately when that problem started so they could restore your site from backups.

    But, since it's several days since then it's probably too late for that now, not only because their backups are probably gone, but also because if your storefront is operational then you've got new data in there too, and a restore would wipe that out.

    It's impossible for anyone here to tell you exactly what was done by that automated script, which also means it's also impossible for us to tell you what exactly still needs to be done. All we can do is react to error messages. But *you* should go and follow the upgrade instructions and do a complete upgrade on your site the proper way: www.zen-cart.com/upgrade.

    As for the error message, it's telling you that the database doesn't match the PHP files. So you need to resolve that. In the upgrade instructions you'll see the part where it tells you to upload the zc_install files and run that and choose the database-upgrade option. That will deal with the error message. But that's ALL it will deal with.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  9. #9
    Join Date
    Jan 2012
    Location
    Catalina, Arizona
    Posts
    28
    Plugin Contributions
    0

    help question Re: upgrading 1.3.9 to 1.5

    Quote Originally Posted by DrByte View Post
    It's impossible for anyone here to tell you exactly what was done by that automated script, which also means it's also impossible for us to tell you what exactly still needs to be done. All we can do is react to error messages. But *you* should go and follow thAs for the error message, it's telling you that the database doesn't match the PHP files. So you need to resolve that. In the upgrade instructions you'll see the part where it tells you to upload the zc_install files and run that and choose the database-upgrade option. That will deal with the error message. But that's ALL it will deal with.
    e upgrade instructions and do a complete upgrade on your site the proper way: www.zen-cart.com/upgrade.

    OK, I'm looking at the step by step instructions, which is confusing for me because I am very ignorant.. I am stuck when I am advised to "RUN" the zc_install/index.php file. How do I "Run" it? I've found it, but what do I do to "RUN" it? THanks

  10. #10
    Join Date
    Jan 2004
    Posts
    60,593
    Blog Entries
    4
    Plugin Contributions
    145

    Default Re: upgrading 1.3.9 to 1.5

    Quote Originally Posted by Lowell37 View Post
    OK, I'm looking at the step by step instructions, which is confusing for me because I am very ignorant.. I am stuck when I am advised to "RUN" the zc_install/index.php file. How do I "Run" it? I've found it, but what do I do to "RUN" it? THanks
    Open your browser, type in your store URL, and add zc_install/index.php to the end .... ie: www.your_store.com/zc_install/index.php
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Admin when UPgrading
    By ideasgirl in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 2 Feb 2011, 08:16 AM
  2. Question about upgrading and installin security patches
    By SyberTemplates in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 28 Oct 2010, 12:53 PM
  3. certain customers not able to view cart after upgrading
    By volks65 in forum Upgrading from 1.3.x to 1.3.9
    Replies: 1
    Last Post: 7 May 2010, 06:10 PM
  4. Replies: 3
    Last Post: 19 Jun 2008, 12:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •