Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2011
    Posts
    124
    Plugin Contributions
    0

    Default My database needs patching from 1.3.9 to 1.5.0

    I've installed 1.5.0 via Hostgator's QuickInstall. The install was painless, as was the application of the theme I'm using. Ran into problems when I did the database import. The database is a database I put together on a 1.3.9 site that I had.

    I'm getting a message on the Admin login screen that says:
    database upgrade required. please run the 1.3.9-to-1.5.0 upgrade via zc_install

    On the website itself there is a red bar up top that says:
    Your database appears to need patching to a higher level. See Admin->Tools->Server Information to review patch levels.

    The problem I'm having is that I can't access the Admin section AND there isn't a zc_install file on the server because I used the host's QuickInstall feature.

    Need some help. What's my next move here? Do I download 1.5 and try to use the install folder or do I delete what I have, manual install 1.3.9, then apply database and finally upgrade to 1.5 and then apply theme?

  2. #2
    Join Date
    Jan 2004
    Posts
    60,435
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: My database needs patching from 1.3.9 to 1.5.0

    Yes, if you're going to use an old database on a new site, you'll need to download the original Zen Cart code, upload the zc_install folder to your site, and run the database-upgrade step.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Jul 2011
    Posts
    124
    Plugin Contributions
    0

    Default Re: My database needs patching from 1.3.9 to 1.5.0

    I have the zc_install folder downloaded. How do you run the database upgrade step?

  4. #4
    Join Date
    Jan 2004
    Posts
    60,435
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: My database needs patching from 1.3.9 to 1.5.0

    Let's step back a bit.

    You're doing an upgrade here.

    You need to follow the upgrade instructions: www.zen-cart.com/upgrade

    There are all manner of things you've not disclosed here, including the list of changes you made to the old 1.3.9 site you're upgrading from, the list of addons you'd added to it, and more. The database-upgrade will NOT take those into account. And installing old addons on newer versions can also be problematic.

    Also, what you're talking about here is also essentially "moving to another server" ... even if it's "from my local PC, to my webserver". And it's not recommended to switch versions in-the-midst-of-an-upgrade such as you're attempting here. One of the biggest problems there is that your next post is going to be "it worked fine on my old one, but now it's not working on the new one; how do I fix it?" ... but when you're changing servers AND upgrading at the same time there are an exponential number of increased factors which could cause the problems you have. Keep that in mind as you proceed.

    Running zc_install to do database-upgrade is described in the upgrade instructions mentioned above.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  5. #5
    Join Date
    Jul 2011
    Posts
    124
    Plugin Contributions
    0

    Default Re: My database needs patching from 1.3.9 to 1.5.0

    I've added the zc_install folder and ran into an issue already. The name of the admin folder has been changed, the installer is giving me an error message:
    /admin/includes/configure.php does not exist

    I tried renaming the folder back to admin and changed permissions on the two configure files and edited the admin lines with the new (stock) folder name etc. When I did it this way it didn't like the password I entered for the database. I'm certain I have the pw written down corectly. What am I missing?

  6. #6
    Join Date
    Jan 2004
    Posts
    60,435
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: My database needs patching from 1.3.9 to 1.5.0

    For a database-upgrade it's not necessary to rename the admin folder to 'admin'. That message doesn't prevent you from choosing the "database upgrade" option.

    The password it's requesting is the admin login password you used in the old 1.3.9 database that you imported. It's not the password you used when you did the 1.5.0 install. You wiped out the 1.5.0 password when you replaced the database content with the 1.3.9 content.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  7. #7
    Join Date
    Jul 2011
    Posts
    124
    Plugin Contributions
    0

    Default Re: My database needs patching from 1.3.9 to 1.5.0

    That did it, thank you!

 

 

Similar Threads

  1. Database needs patching
    By cheapmanuals in forum Upgrading from 1.3.x to 1.3.9
    Replies: 2
    Last Post: 29 Jan 2011, 03:15 AM
  2. Database needs patching ?
    By satter9 in forum Installing on a Linux/Unix Server
    Replies: 18
    Last Post: 11 Feb 2008, 09:42 PM
  3. Upgrade 1.3.5 -> 1.3.7 database needs patching
    By lucky__starre in forum Upgrading from 1.3.x to 1.3.9
    Replies: 5
    Last Post: 3 May 2007, 12:26 PM
  4. database needs patching
    By zas in forum General Questions
    Replies: 6
    Last Post: 5 Apr 2007, 05:49 AM
  5. Database needs patching
    By Minnie Mouse in forum Upgrading from 1.3.x to 1.3.9
    Replies: 3
    Last Post: 30 Jan 2007, 12:38 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •