Thread: PxPay Issues

Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2009
    Posts
    8
    Plugin Contributions
    0

    Default PxPay Issues

    Hi guys

    I'm trying to setup the PxPay module located here http://www.zen-cart.com/downloads.php?do=file&id=658 on our site, I've installed it and set it up with our PaymentExpress account, however when I try checkout using the module I'm redirected to the PaymentExpress page correctly, enter the test CC number and have the transaction approved. But this is where it goes wrong, on clicking next I'm not redirected to the order confirmed page on our zen-cart but just a blank page as if there is some sort of PHP error or something. (but no errors appear in the cache folder) (also the order is not complete and the item is still in my cart)

    Next I setup the site on a local WAMP test server to try troubleshoot the problem, but here it works perfectly!! redirected to the order confirmation page and the order is created!! thus I believe the issue is with the server config.
    My local server is running PHP Version 5.3.13 and the online server is running PHP Version 5.3.8 and both have CURL installed correctly (I think). the php versions are pretty similar so I don't think that's the problem?

    could anyone give me any tips on how to track down this problem??

    Thanks!
    Rob.

    EDIT: basically the same issue as this: http://www.zen-cart.com/showthread.php?194116 I'm thinking it has to do with the url return length...
    Last edited by RobThePyro; 28 Jun 2012 at 02:46 PM. Reason: added info..

  2. #2
    Join Date
    Aug 2009
    Posts
    8
    Plugin Contributions
    0

    Default Re: PxPay Issues

    For anyone looking, I solved my problem:
    I had to change the server side PHP.ini variable 'suhosin.get.max_value_length' from 512 to 3000 to allow for the long PaymentExpress URL's
    got the tip from this thread: http://www.zen-cart.com/showthread.p...ighlight=pxpay

    Rob. :)

 

 

Similar Threads

  1. v150 CC via MIGS Payment Gateway Issues and/or zenID Issues?
    By smcelligott in forum Addon Payment Modules
    Replies: 5
    Last Post: 21 Apr 2013, 02:25 AM
  2. v139h DPS Pxpay warning after upgrading to php 5.3
    By tone2 in forum Addon Payment Modules
    Replies: 0
    Last Post: 19 May 2012, 09:16 AM
  3. Sometimes return from payment fails -pxpay
    By wrxh8r in forum Addon Payment Modules
    Replies: 3
    Last Post: 12 Jan 2012, 10:01 PM
  4. Notification Email Issues in German -Issues with Umlaute-
    By HEAT in forum Managing Customers and Orders
    Replies: 7
    Last Post: 5 Nov 2010, 02:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •