Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2008
    Location
    Simi, CA, USA
    Posts
    60
    Plugin Contributions
    0

    Default Trying to use old DB with fresh install

    I had an old site that was not being used and longer but a new client with the exact same business
    wanted a site that sells the same product. The old site took HOURS to create so I wanted to use the
    old DB with the new site. The hosting site I use has an ANCIENT version of PHPadmin so I could not
    get the DB to backup properly to move the old DB to the new site. I edited the config and pointed to
    the old server and tried to run the upgrade but get error after error. The site comes up and shows
    all the entries but when I got into the Admin I get this error and cannot see a way to fix it:
    Sorry, your security clearance does not allow you to access this resource.
    Please contact your site administrator if you believe this to be incorrect.
    Sorry for any inconvenience.
    I also tried to run the SQL patches directly through PHPadmin with no success.
    The site is http://www.supremospizza.com
    Any suggestions????
    My Zen Cart Store
    www.cheapservicemanuals.net

  2. #2
    Join Date
    Nov 2006
    Location
    Dartmouth, NS Canada
    Posts
    2,369
    Plugin Contributions
    0

    Default Re: Trying to use old DB with fresh install

    I'm a little confused about why you want so desperately to use the old DB. Sure, it will contain some things that affect the site template and functionality, some admin settings and perhaps some SQL setups required by old mods. But...

    Some of those old mods, perhaps all of them if the site was that old, will not work in the latest ZC. And you'll have to get those old SQL-inserted changes out of the old DB.
    The admin settings are easy to replicate; just go into the old admin and make notes. (Many of us use screen captures of the admin screens in such a case.)

    One of the best things you can do to a really old site when upgrading is... don't upgrade. Update instead. Update the whole site, adding new mods as needed and even adding a new template. It seems a little more work at first, but compared to what you're trying to do it may be less work.

    Rob
    Breakfast: the most important donut of the day.

  3. #3
    Join Date
    Jan 2008
    Location
    Simi, CA, USA
    Posts
    60
    Plugin Contributions
    0

    Default Re: Trying to use old DB with fresh install

    The issue has nothing to do with plugins but the product being sold. There were a TON of attributes added to the old site that took HOURS to setup and are needed for the new site. Here is an example: http://www.supremospizza.com/index.p...products_id=47
    My Zen Cart Store
    www.cheapservicemanuals.net

  4. #4
    Join Date
    Jan 2008
    Location
    Simi, CA, USA
    Posts
    60
    Plugin Contributions
    0

    Default Re: Trying to use old DB with fresh install

    I fixed the issue by installed the same version that was installed previously so the
    site is now working fine. I will see about upgrading the site to a new version later.
    My Zen Cart Store
    www.cheapservicemanuals.net

  5. #5
    Join Date
    May 2006
    Posts
    28
    Plugin Contributions
    0

    Default Re: Trying to use old DB with fresh install

    Let me give you some idea on my upgrade path.
    First, backup everything. Next load up new files (1.5.0) and connect to old database. Run a database upgrade. Do modification base on new file.
    It took me roughly 3 days to complete. Not an easy task but still can be done.

 

 

Similar Threads

  1. Fresh install but old data
    By hamid84 in forum Installing on a Linux/Unix Server
    Replies: 11
    Last Post: 4 Oct 2010, 09:55 AM
  2. Wanting to do a fresh install - with SOME of my old database
    By ArtsygalDotNet in forum General Questions
    Replies: 2
    Last Post: 9 Apr 2010, 01:18 PM
  3. 1.3.2 to 1.3.5 upgrade with fresh install and old DB.
    By linkedla in forum Upgrading from 1.3.x to 1.3.9
    Replies: 14
    Last Post: 4 Oct 2006, 12:11 AM
  4. Fresh install (1.3.5) with old products ?
    By Typhoon in forum General Questions
    Replies: 8
    Last Post: 8 Sep 2006, 10:51 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •