Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2012
    Posts
    2
    Plugin Contributions
    0

    Default Trouble Installing FirstData/Linkport/YourPay API Not Configured SSL

    Hi,

    I am currently having a difficult time attempting to install my FirstData/Linkport/YourPay API because ZenCart refuses to recognise the current active ssl. It has been verified by both me and my hosting company that it works. I then followed the instructions that were provided here:

    http://www.zen-cart.com/content.php?56

    I had my hosting provider check my work to be sure that I followed the steps properly and I did. ZenCart still will not allow me to install this payment option and I cannot proceed until this is completed. Please help. Thank You!

  2. #2
    Join Date
    Jan 2004
    Posts
    59,807
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Trouble Installing FirstData/Linkport/YourPay API Not Configured SSL

    Quote Originally Posted by bigdog View Post
    I then followed the instructions that were provided here:

    http://www.zen-cart.com/content.php?56
    Did you do this part of Step 3, directly quoted from that article:
    ADMIN SECURITY NOTE: In Zen Cart v1.x, if you want to secure all your ADMIN pages with SSL, set the HTTP_SERVER in your "/admin/includes/configure.php" to the same working URL as your HTTPS_SERVER setting. (You will then have both an HTTP_SERVER and HTTPS_SERVER defined to the same value.) (Also, if your DIR_WS_ADMIN looks something like '/adminfoldername/' and doesn't have references to $p1 or any other $ variables in it, then do the same with DIR_WS_ADMIN to make it match DIR_WS_HTTPS_ADMIN.) THIS IS REQUIRED FOR PCI COMPLIANCE, and will happen automatically with new installations of v1.5.x and newer.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Mar 2013
    Posts
    10
    Plugin Contributions
    0

    Default Re: Trouble Installing FirstData/Linkport/YourPay API Not Configured SSL

    Quote Originally Posted by DrByte View Post
    Did you do this part of Step 3, directly quoted from that article: [/B]
    Hello. So, I'm using zencart 1.5 and I'm having the same issue. Do I still need to set the http_server and the https_server to https://yourshop.com? Or is there something else I need to do?

  4. #4
    Join Date
    Mar 2013
    Posts
    10
    Plugin Contributions
    0

    Default Re: Trouble Installing FirstData/Linkport/YourPay API Not Configured SSL

    Quote Originally Posted by vintageshop View Post
    Hello. So, I'm using zencart 1.5 and I'm having the same issue. Do I still need to set the http_server and the https_server to https://yourshop.com? Or is there something else I need to do?
    Well, I guess I did. Once I set everything to https for all servers it allowed me to install it. I had just missed one in the admin/includes directory the first time around.

 

 

Similar Threads

  1. FirstData/Linkpoint/YourPay showing First 4 of Credit Card?
    By jsquared in forum Built-in Shipping and Payment Modules
    Replies: 1
    Last Post: 29 Nov 2011, 11:50 PM
  2. FirstData/Linkpoint/YourPay API - API Standard or API Web?
    By sashafiero in forum Built-in Shipping and Payment Modules
    Replies: 4
    Last Post: 13 Oct 2011, 09:24 PM
  3. Pmt Mod FirstData API vs Connect
    By spence in forum Built-in Shipping and Payment Modules
    Replies: 12
    Last Post: 6 Jul 2011, 09:31 PM
  4. Replies: 8
    Last Post: 27 Apr 2010, 07:19 PM
  5. YourPay API payment module will not show up
    By fabrikation in forum Addon Payment Modules
    Replies: 1
    Last Post: 24 Oct 2006, 12:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •