Results 1 to 5 of 5
  1. #1
    Join Date
    Nov 2005
    Posts
    152
    Plugin Contributions
    0

    Default security patch 1.3.0.x what to do?

    Latest security patch is causin gthis problem:


    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/mogultra/public_html/artscrafts/includes/classes/shopping_cart.php:3573) in /home/mogultra/public_html/artscrafts/includes/functions/sessions.php on line 100

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/mogultra/public_html/artscrafts/includes/classes/shopping_cart.php:3573) in /home/mogultra/public_html/artscrafts/includes/functions/sessions.php on line 100

    Warning: Cannot modify header information - headers already sent by (output started at /home/mogultra/public_html/artscrafts/includes/classes/shopping_cart.php:3573) in /home/mogultra/public_html/artscrafts/includes/init_includes/init_templates.php on line 78

    When I undid it, still the above message remained when website was downloaded. I wonder what can i do?

  2. #2
    Join Date
    Apr 2005
    Location
    NSW - Australia
    Posts
    46
    Plugin Contributions
    0

    Default Re: security patch 1.3.0.x what to do?

    Hello ZenArtMan,

    On the very bottom of the file:
    /includes/classes/shopping_cart.php

    Remove the extra blank lines !!!


    I just had the exact same problem after I altered things this morning.
    Quickly deleting those blank lines worked wonders for me !

    Brad

  3. #3
    Join Date
    Nov 2005
    Posts
    152
    Plugin Contributions
    0

    Default Re: security patch 1.3.0.x what to do?

    Bang!. You made it work. Thank you very much. This FTP program is something that I am not completely accustomed to still.

  4. #4
    Join Date
    Apr 2005
    Location
    NSW - Australia
    Posts
    46
    Plugin Contributions
    0

    Default Re: security patch 1.3.0.x what to do?

    Quote Originally Posted by zenartman
    Bang!. You made it work. Thank you very much. This FTP program is something that I am not completely accustomed to still.
    No problems !
    I personally use CutFTP Pro editor - and I even came up with the error, editing on the server

    I'll remember to check the bottom of all files next time however !

    Have a great weekend !

    Brad

  5. #5
    Join Date
    Jan 2004
    Posts
    60,305
    Blog Entries
    4
    Plugin Contributions
    51

    Default Re: security patch 1.3.0.x what to do?

    Quote Originally Posted by aussie
    I personally use CutFTP Pro editor - and I even came up with the error, editing on the server
    1. Editing on the server will often end up leaving a blank line at the end of files.

    2. CuteFTP is moderately reliable. I find FileZilla to be flawless in terms of reliability.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 

Similar Threads

  1. Replies: 19
    Last Post: 18 Sep 2006, 09:39 AM
  2. Security Patch and Custom Template
    By pdxbray in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 18 Aug 2006, 10:41 PM
  3. Security patch for 1.3x: Where to put edited files
    By pdxbray in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 18 Aug 2006, 09:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •