Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2005
    Posts
    276
    Plugin Contributions
    0

    Default Database import - not going to plan 1.27-1.32

    Hi

    I have installed zen 1.32 (in a test area) - & created a database

    I now want to import my db from 1.27 into this database.

    I have backed up the database as a gzipped file then I went to php admin for my new 1.32 version database and then imported the gzipped file - however I keep getting errors the


    -- phpMyAdmin SQL Dump
    -- version 2.6.4-pl3
    -- http://www.phpmyadmin.net
    --
    -- Host: localhost:3306
    -- Generation Time: Aug 22, 2006 at 09:52 AM
    -- Server version: 4.1.19
    -- PHP Version: 5.0.5
    --
    -- Database: `vine_zen`
    --
    CREATE DATABASE `vine_zen` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci

    the database I am inprting into is called organic

    I am a designer and just need pointed in the right direction - do I need to take out the following lines before importing

    -- Database: `vine_zen`
    --
    CREATE DATABASE `vine_zen` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci

    ?

    Thanks have looked through the faqs and have followed the upgrade instructions - but I am lost at the bit which says

    Restore your database from the backup in step #1 earlier into your NEW database just created.


    I am trying to import - is that the same thing?

  2. #2
    Join Date
    Jan 2004
    Posts
    59,773
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Database import - not going to plan 1.27-1.32

    You will need to add ## before any CREATE DATABASE or USE DATABASE lines in your backup file before importing.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  3. #3
    Join Date
    Feb 2005
    Posts
    276
    Plugin Contributions
    0

    Default Re: Database import - not going to plan 1.27-1.32

    HI Dr Byte

    I removed those lines and managed to get it to import but then I had duplicate entries - as my 1.27 table had prefixes - I then open my sql file up removed all the pre fixes and reimported - got funny charachters appreaing (a's with wee hats) so I am just starting from scratch.

    I will create a new database install zen 1.32 - then import a prefix free 1.27 database table and remove the create database line

    Hopefully this will be ok?

    Thanks again for your quick response

  4. #4
    Join Date
    Jan 2004
    Posts
    59,773
    Blog Entries
    4
    Plugin Contributions
    133

    Default Re: Database import - not going to plan 1.27-1.32

    There's nothing wrong with continuing to work with prefixes.

    If you set up your 1.3 site to use the same prefix as your old site, it'll make life a lot easier.

    After you've got things upgraded, you can rename all your tables using a quick script. But for now, keep the prefix and you won't accidentally remove any incorrect content from your backup files.

    You might also re-backup your 1.2.7 database, but click on your actual database first to select it, then choose the Export option, which should naturally skip inserting those CREATE DATABASE and USE DATABASE statements.
    (You'll know you've got it right when the "File Name Template" next to the "Save As File" checkbox shows __DB__ instead of __SERVER__)
    This just makes it easier so you don't have to edit the SQL file at all.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.

  5. #5
    Join Date
    Feb 2005
    Posts
    276
    Plugin Contributions
    0

    Default Re: Database import - not going to plan 1.27-1.32

    Thanks again - and apologies for the spelling.

    Fingers crossed all will go well this time.

    I just couldn't find anything which actually told me to make those changes to the sql file and not having a clue I followed the instructions quite literally.

  6. #6
    Join Date
    Sep 2005
    Posts
    453
    Plugin Contributions
    0

    Default Re: Database import - not going to plan 1.27-1.32

    Quote Originally Posted by peanut77
    Thanks again - and apologies for the spelling.

    Fingers crossed all will go well this time.

    I just couldn't find anything which actually told me to make those changes to the sql file and not having a clue I followed the instructions quite literally.

    Hey people!

    Do you get your scandinavian characters working with upgrade?
    To me all the customer names, addresses, product names and descriptions get mixed with corrupted , , , , etc.
    I have tried different options to change the sql dump as utf8 (originally latin1) but nothing seems to help... there are thousands of products, hundreds of customers and I can't simply start changing the info letter by letter!

    Now = √, = √∂, = √, so a complete mess with words.

    Anyway to get the database information fixed?

    Elli
    I may be blond but at least I found Zen.

 

 

Similar Threads

  1. Can't install 1.32 but 1.27 is fine
    By peanut77 in forum Installing on a Linux/Unix Server
    Replies: 5
    Last Post: 21 Aug 2006, 07:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •