Page 65 of 79 FirstFirst ... 1555636465666775 ... LastLast
Results 641 to 650 of 786
  1. #641
    Join Date
    Oct 2008
    Posts
    27
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by ses707 View Post
    MySQL is being really helpful here, simply remove the line
    Code:
    ALTER TABLE `orders` DROP `total_weight`;
    and then rerun the install sql. That is not a necessary line and in most ZC installs it will simply show an error as a bar at the top of the screen after it has been run. What version of MySQL is balking at you?
    Tried that. It ran, but error:
    9 statements processed.
    ERROR: Cannot ADD column total_weight because it already exists.
    Note: 1 statements ignored. See "upgrade_exceptions" table for additional details

    Still no configuration settings.

  2. #642
    Join Date
    Dec 2003
    Location
    Astoria, Or
    Posts
    455
    Plugin Contributions
    2

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by sailsport1 View Post
    Tried that. It ran, but error:
    9 statements processed.
    ERROR: Cannot ADD column total_weight because it already exists.
    Note: 1 statements ignored. See "upgrade_exceptions" table for additional details

    Still no configuration settings.
    Not sure what version of ZC/PHP/MySQL you are on but sounds like ZC 1.5? If it only processed 9 statements then you probably used the install-1.3.9, the install-1.5.0 includes an additional 4 statements which register the addon in admin access control.

  3. #643
    Join Date
    Jun 2009
    Location
    Orange County, California
    Posts
    505
    Plugin Contributions
    17

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    @ses707:

    I've posted your latest version, just in case someone clicks my link. Thanks for removing all the 'Return' items from SQL. Would you be so kind as to double-check the Page Registration? This process is new as of v1.5, and I haven't found much documentation for correct syntax.

    @SPembleton:

    Did you try the latest version by ses707? And, did you hit refresh while you were on that error page, or after you clicked the back button?

    I think the error appears when there are residual configurations left from failed installations of this module. An alternative is to go into your admin_pages table, delete any rows for USPS AutoFill, and it might be a good idea to do the same in configuration table. Then install fresh files and run the latest SQL for your version of Zen Cart (click ses707's link above).
    Jackie Taferner - JT Website Design
    Custom Website Design and Ecommerce
    **Support the community. Don't Private Message, post your questions in the forum.**

  4. #644
    Join Date
    Oct 2008
    Posts
    27
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by ses707 View Post
    Not sure what version of ZC/PHP/MySQL you are on but sounds like ZC 1.5? If it only processed 9 statements then you probably used the install-1.3.9, the install-1.5.0 includes an additional 4 statements which register the addon in admin access control.
    I'm using ZC 1.3.9h
    mySQL 5.1.52-cll
    PHP 5.3.6

  5. #645
    Join Date
    Jun 2009
    Location
    Orange County, California
    Posts
    505
    Plugin Contributions
    17

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    @sailsport:

    Try going into your database and manually remove any rows that reference USPS in the configuration and configuration_group tables.

    It may be useful to use your browser's "search" function to easily find USPS on the page.

    Then, download ses707's copy of the SQL and try running it again.
    Jackie Taferner - JT Website Design
    Custom Website Design and Ecommerce
    **Support the community. Don't Private Message, post your questions in the forum.**

  6. #646
    Join Date
    Oct 2008
    Posts
    27
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by jackie.taferner View Post
    @sailsport:

    Try going into your database and manually remove any rows that reference USPS in the configuration and configuration_group tables.

    It may be useful to use your browser's "search" function to easily find USPS on the page.

    Then, download ses707's copy of the SQL and try running it again.
    Tried that again. Still no luck.
    I do have Super Orders installed and I'm thinking that may be the problem?

  7. #647
    Join Date
    Dec 2003
    Location
    Astoria, Or
    Posts
    455
    Plugin Contributions
    2

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by sailsport1 View Post
    Tried that again. Still no luck.
    I do have Super Orders installed and I'm thinking that may be the problem?
    Nope, issue was the SQL, please download and run this one. This includes SQL updates for 1.3.9 and 1.5.

  8. #648
    Join Date
    Apr 2006
    Location
    Midland TX
    Posts
    277
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by sailsport1 View Post
    Tried that again. Still no luck.
    I do have Super Orders installed and I'm thinking that may be the problem?
    Try this so you will know what/where mod files are installed.

    Step 1 --- Make backups of your database and shopping cart and download to your computer.
    Step 2 -- Using Beyond Compare or equal load your shopping cart into Right Side and load the latest version of USPS Click-n-Ship into the Left side.
    Step 3 --- Click on "Select all" then "Compare contents" then "Expand all"
    Step 4 --- All files should be "=" except maybe the "order.php" if you have FEC installed or other mod that is sharing this file then it will be "Not=". If you see any files that are blue in color (orphan file) that means you do not have it installed in the correct place, so you need to find where you installed that file and remove it. Then install the orphan file.
    Step 5 --- Open your Database and scroll down to "configuration_group", look in main body for "configuration_group_id" number for "USPS Auto-Fill Config"
    Step 6 --- Click on "configuration" in main body delete all entry's with that "configuration_group_id" number. May be on the last page. After removing all the "usps.sql" entry's go back to "configuration_group"
    Step 7 Click on "configuration_group" in main body scroll down to "USPS Auto-Fill Config" and Delete this entry.
    Step 8 Upload the Shopping cart back to your server.
    Step 9 --- Now install the USPS "install-1.3.9.sql" file.
    Now it should work

  9. #649
    Join Date
    Oct 2008
    Posts
    27
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by ses707 View Post
    Nope, issue was the SQL, please download and run this one. This includes SQL updates for 1.3.9 and 1.5.
    OK That one ran, but it only gives me 9 configuration settings - and there is no USPS autofill button on the orders page anymore.

    That patch only had a blank line added different than the one I ran before.

  10. #650
    Join Date
    Dec 2003
    Location
    Astoria, Or
    Posts
    455
    Plugin Contributions
    2

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by sailsport1 View Post
    OK That one ran, but it only gives me 9 configuration settings - and there is no USPS autofill button on the orders page anymore.

    That patch only had a blank line added different than the one I ran before.
    The key differences are the addition of ; on the last line before the
    Code:
    ALTER TABLE orders DROP total_weight;
    ALTER TABLE orders ADD total_weight FLOAT NOT NULL DEFAULT '-1';
    And the alters lost the '
    Can you confirm those items are different in the sql you are running?
    And 9 statements is correct for a 1.3.9, only 1.5 requires additional statements.

 

 
Page 65 of 79 FirstFirst ... 1555636465666775 ... LastLast

Similar Threads

  1. Checkout Button - click once then hide - possible ?
    By DogTags in forum General Questions
    Replies: 1
    Last Post: 1 Sep 2006, 06:30 PM
  2. Can't log in to admin
    By redman in forum Customization from the Admin
    Replies: 2
    Last Post: 30 May 2006, 03:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •