Page 9 of 80 FirstFirst ... 78910111959 ... LastLast
Results 81 to 90 of 796
  1. #81
    Join Date
    Feb 2004
    Posts
    1,776
    Plugin Contributions
    14

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by tcustomgolf View Post
    Using the 1.3.7 version and and IE7 and getting an "error on page" when clicking the USPS button...nothing loads, I just stay at the admin page??

    Also, as an FYI, I replaced the orders.php, but if you decide not to and do manually, the instructions in the read me does not include this line which is in the replacement orders.php
    Does the included orders.php file work with IE7?

  2. #82
    Join Date
    Dec 2005
    Location
    NY
    Posts
    188
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Does the included orders.php file work with IE7?
    I am using the included order.php with IE7. When the orders page loads in admin, I get the little yellow triangle with the exclamation point in it in the lower left and it says "Done, but with errors on the page". Then when I click the USPS button, same triangle with an "Errors on page." message, and nothing else happens.

    Is that normally the message you get on a javascript error?
    Custom Golf Clubs - A ZenCart Site!
    Get fitted online for a better game!

  3. #83
    Join Date
    Feb 2004
    Posts
    1,776
    Plugin Contributions
    14

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by tcustomgolf View Post
    I am using the included order.php with IE7. When the orders page loads in admin, I get the little yellow triangle with the exclamation point in it in the lower left and it says "Done, but with errors on the page". Then when I click the USPS button, same triangle with an "Errors on page." message, and nothing else happens.

    Is that normally the message you get on a javascript error?
    well I get an error on FF only because it doesn't like how i am calling a javascript submit button...It gives "document.getElementById("labelInformationForm") has no properties.
    But I haven't found any better way to do it. IE might get the error but usually skips it and continues. Opera also. FF stops on the error and won't continue.

    I've tried turning on the IE script debugger, which is supposed to stop the page load and give a popup error if there is an error, it doesn't stop anything. It just works properly. Then I tried viewing the javascript console in Opera while I clicked the button... no error here either.

    Try it on another PC. Also verify you do have the includes/modules/usps_autofill_button.php file.

  4. #84
    Join Date
    Dec 2005
    Location
    NY
    Posts
    188
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    The usps_autofill_button.php is in:

    admin/includes/modules/usps_autofill_button.php

    and just did a test here at work (using IE6!!) and same result...errors on page when loading the customers/orders page in admin, and nothing when clicking the button.

    I also noticed as stated below that the attached orders.php file, and the manual procedures listed in the .rtf file are different (the orders.php shows four steps included in the file as opposed to 3 in the manual install). I tried the manual version with the same results.

    I will go through the install procedures again and make sure all is in place.
    Custom Golf Clubs - A ZenCart Site!
    Get fitted online for a better game!

  5. #85
    Join Date
    Feb 2004
    Posts
    1,776
    Plugin Contributions
    14

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by tcustomgolf View Post
    The usps_autofill_button.php is in:

    admin/includes/modules/usps_autofill_button.php

    and just did a test here at work (using IE6!!) and same result...errors on page when loading the customers/orders page in admin, and nothing when clicking the button.

    I also noticed as stated below that the attached orders.php file, and the manual procedures listed in the .rtf file are different (the orders.php shows four steps included in the file as opposed to 3 in the manual install). I tried the manual version with the same results.

    I will go through the install procedures again and make sure all is in place.
    What version of zen-cart are you using ? Version 0.3 is for zc137, and 0.2 is for zc136. Also, do you have all the DB settings for the contrib correctly? You should see 16 settings under Configuration->USPS Autofill config

    I just tested Opera 9, IE6 at work, Opera 9, IE7 at home, and Opera 9, IE6 on my second PC. All worked fine. Can you tell me the error you get when you double click the little yellow shield in the corner?
    Last edited by qhome; 23 Jan 2007 at 12:05 AM.

  6. #86
    Join Date
    Dec 2005
    Location
    NY
    Posts
    188
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Q, running 1.3.7 and using the 0.3 version (though the included sql patch in the downloadable 0.3 mod is v. 0.2b...assuming that is correct?)

    All 16 settings are in the admin, the button is displaying fine. Attached gif after double-clicking the yellow shield. Thanks for the help...wouldn't make a fuss, but this is a mod I truly need!!
    Attached Images Attached Images  
    Custom Golf Clubs - A ZenCart Site!
    Get fitted online for a better game!

  7. #87
    Join Date
    Dec 2005
    Location
    NY
    Posts
    188
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    And got this message when I went right into an order screen of a customer. The line # is 398 at the top if you cannot read it.
    Attached Images Attached Images  
    Custom Golf Clubs - A ZenCart Site!
    Get fitted online for a better game!

  8. #88
    Join Date
    Feb 2004
    Posts
    1,776
    Plugin Contributions
    14

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Quote Originally Posted by tcustomgolf View Post
    And got this message when I went right into an order screen of a customer. The line # is 398 at the top if you cannot read it.
    FIXED!

    Well we fixed it! After much pain and suffering, tcustomgolf set me up with a temporary admin account so I could debug the problems. It turns out he had an apostrophe (') in his return address for his company name and that was tricking the javascript into thinking it was a string terminator.. thus breaking my code .

    The fix was easy, so anyone else who has any problem with the contrib not working and need to use an apostrophe in your company name, like "Bob's Fun World", simply add a \ right before the ' making it: Bob\'s Fun World.

    The code will use that as an escape character and use the ' as part of the string, but the code will ignore the literal value of \ so it will still display fine.

    In the next version I will try to programtically ignore apostrophes by auto-escaping them. But for now we at least got a quick fix.

    Glad we got it resolved for you tcustomgolf, and thanks for your help in finding out the problem for future reference.

    Enjoy!

  9. #89
    Join Date
    Dec 2005
    Location
    NY
    Posts
    188
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    Bingo!

    Works great...thanks for sticking with it qhome!!
    Custom Golf Clubs - A ZenCart Site!
    Get fitted online for a better game!

  10. #90
    Join Date
    Jan 2007
    Posts
    15
    Plugin Contributions
    0

    Default Re: usps.com Click-n-ship AutoFill Button Contrib

    any word on the attributes total weight fix? thanks again

 

 
Page 9 of 80 FirstFirst ... 78910111959 ... LastLast

Similar Threads

  1. Checkout Button - click once then hide - possible ?
    By DogTags in forum General Questions
    Replies: 1
    Last Post: 1 Sep 2006, 06:30 PM
  2. Can't log in to admin
    By redman in forum Customization from the Admin
    Replies: 2
    Last Post: 30 May 2006, 03:41 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •