Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Default USPS Shipping Not Showing Up

    I have installed and enabled the USPS Shipping Module but it is not showing up when I check it by using the estimate shipping button. I beleive for production mode you have to have an account with USPS, I have both types of accounts with them, one for shipping tools and a regular account. With the tools account they sent an IS but no password in the email.
    Any help is appreciated. Thanks

  2. #2
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: USPS Shipping Not Showing Up

    Does USPS show up during checkout ?

    What version of Zen Cart are you using?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3

    Default Re: USPS Shipping Not Showing Up

    Yes but I get that common error message " Unable to find a quote suitable for your mailing address .......

  4. #4

    Default Re: USPS Shipping Not Showing Up

    Version:
    1.3.0.2

  5. #5
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: USPS Shipping Not Showing Up

    1. What is your store's ZIP code as defined in Admin->Configuration->Shipping/Packaging?
    2. What is your test customer's ZIP code ?
    3. What is the weight of the order you're testing?
    4. What delivery options have you enabled in your USPS settings? Try enabling "more" of them.
    5. In Admin->Configuration->Shipping/Packaging, what are your tare settings? (okay, it doesn't say "tare", but that's what it is ... list all your settings from that section)
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6

    Default Re: USPS Shipping Not Showing Up

    1. 61832
    2. test is the same: 61832
    3. 10 lbs.
    4. I have enabled all with no luck
    5. Tare Settings: If you mean "Package Tare Small to Medium - added percentage:weight" it is set to 0:3

  7. #7

    Default Re: USPS Shipping Not Showing Up

    1. 61832
    2. test is the same: 61832
    3. 10 lbs.
    4. I have enabled all with no luck
    5. Tare Settings: If you mean "Package Tare Small to Medium - added percentage:weight" it is set to 0:3



    In number one (1) question the zip code is set to 60540 not 61832

    I have these items drop shipped from that zip code

  8. #8
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: USPS Shipping Not Showing Up

    Then the problem is likely related to any of:
    1. server firewall is blocking external communication on port 80
    2. server PHP configuration has blocked/prohibited use of fileopen() calls to external sites
    3. you've entered an invalid USPS user ID (password is irrelevant anymore)

    You might get a bit of information by editing your /includes/modules/shipping/usps.php file as follows:
    approx line 416:
    Code:
          //  mail('you@yourdomain.com','USPS rate quote response',$body,'From: <you@yourdomain.com>');
    a) remove the // at the front
    b) change "you@yourdomain.com" in both places to your own email address
    c) try testing some quotes
    If you get no extra emails containing USPS quote data, then the problem is #1 or #2 above.
    If you do get some emails with raw USPS data, post that data here.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  9. #9

    Default Re: USPS Shipping Not Showing Up

    I have tried in production mode with an error saying I dont have permission to that server etc. I beleive thats because I have not asked them to switch me to the production server.
    When I tried in Test Mode I get this error message:

    <?xml version="1.0"?>
    <Error><Number>-2147219040</Number><Source>SOLServerRatesTest;SOLServerRatesTest.Rate_Respond</Source><Description>RateRequest is no longer supported. Use RateV2Request for canned tests.</Description><HelpFile></HelpFile><HelpContext>1000440</HelpContext></Error>

  10. #10
    Join Date
    Jan 2004
    Posts
    60,160
    Blog Entries
    4
    Plugin Contributions
    139

    Default Re: USPS Shipping Not Showing Up

    Quote Originally Posted by scottyg View Post
    I beleive thats because I have not asked them to switch me to the production server.
    USPS will only give usable quotes if your account is on the production server.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. Configuring Taxes for Canadian Sites/Zones
    By DrByte in forum Currencies & Sales Taxes, VAT, GST, etc.
    Replies: 310
    Last Post: 17 Mar 2014, 05:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •