Page 1 of 5 123 ... LastLast
Results 1 to 10 of 47
  1. #1
    Join Date
    Jun 2006
    Posts
    19
    Plugin Contributions
    0

    Default php 5.2.0 update problem

    Hi,

    today we've tried to upgrade our server from php 5.1.6 to 5.2.0. After this no one is able to log in anymore, neither customers nor admins. We've reverted back now to 5.1.6 and everything is working fine like before. Nevertheless we would like to upgrade because of all the bugs and security issues in php <= 5.1.6. Does anyone know what the problem with ZC and php 5.2.x could be?

    Also: if a customer requests a new password (with php 5.2) the password is send but when trying to use it/log in then apache is closing the connection and php is throwing the same error all the time:

    [03-Nov-2006 13:39:48] PHP Fatal error: Call to a member function Execute() on a non-object in /xxx/includes/functions/sessions.php on line 61

    which is

    $total = $db->Execute($qid);

    in ZC 1.3.x

    So neither old passwords or new ones can be used with php 5.2.0

    Thanks for any help!

  2. #2
    Join Date
    Jan 2004
    Posts
    60,695
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: php 5.2.0 update problem

    What are your compile-options and php.ini options related to sessions settings in your 5.2.0 setup ?
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  3. #3
    Join Date
    Jun 2006
    Posts
    19
    Plugin Contributions
    0

    Default Re: php 5.2.0 update problem

    hi DrByte, our php.ini settings have not been changed for 2 years or so since php 4.3.x or so, IIRC. The session related settings are:

    www:~ # php -i | grep -i session
    session
    Session Support => enabled
    session.auto_start => Off => Off
    session.bug_compat_42 => On => On
    session.bug_compat_warn => On => On
    session.cache_expire => 30 => 30
    session.cache_limiter => nocache => nocache
    session.cookie_domain => no value => no value
    session.cookie_lifetime => 0 => 0
    session.cookie_path => / => /
    session.cookie_secure => Off => Off
    session.entropy_file => no value => no value
    session.entropy_length => 0 => 0
    session.gc_divisor => 100 => 100
    session.gc_maxlifetime => 1440 => 1440
    session.gc_probability => 1 => 1
    session.hash_bits_per_character => 5 => 5
    session.hash_function => 0 => 0
    session.name => PHPSESSID => PHPSESSID
    session.referer_check => no value => no value
    session.save_handler => files => files
    session.save_path => /tmp => /tmp
    session.serialize_handler => php => php
    session.use_cookies => On => On
    session.use_only_cookies => Off => Off
    session.use_trans_sid => 0 => 0
    WDDX Session Serializer => enabled

    php gets compiled as always for apache worker 2.x, the same applies since about 2 years but now we're using apache 2.2.3 on an Opteron system with 1MB RAM (hence the lib64 param but otherwise nothing's been changed in the configure at all, I'm using a script for it so no error on this part, mysql version is 4.1.21 BTW), here are the php ./configure options:

    Configure Command => './configure' '--with-libdir=lib64' '--prefix=/usr/share' '--bindir=/usr/bin' '--datadir=/usr/share/php' '--includedir=/usr/include' '--infodir=/usr/share/info' '--libdir=/usr/share' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--mandir=/usr/share/man' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--with-apxs2=/usr/sbin/apxs2-worker' '--with-config-file-path=/etc' '--with-cyrus' '--with-dom=/usr' '--with-exec-dir=/usr/lib/php/bin' '--with-layout=GNU' '--with-_lib=lib' '--with-bz2' '--with-curl' '--with-db4' '--with-expat-dir=/usr' '--with-ftp' '--with-gd' '--with-gd-dir=/usr/local/lib' '--with-gdbm' '--with-gettext' '--with-gmp' '--with-freetype' '--with-freetype-dir=/usr' '--with-iconv' '--with-jpg' '--with-jpeg-dir=/usr' '--with-ldap' '--with-mcal=/usr' '--with-mcrypt' '--with-mhash' '--with-mysql=/usr' '--with-mysqli=/usr/bin/mysql_config' '--with-ncurses' '--with-ndbm' '--with-openssl' '--with-pcre-regex' '--with-pear=/usr/share/pear' '--with-png' '--with-png-dir=/usr' '--with-readline' '--with-regex=php,apache,system' '--with-snmp=/usr' '--with-tiff-dir=/usr' '--with-ttf' '--with-xml' '--with-xml-rpc' '--with-xpm-dir=/usr/X11R6' '--with-xslt-sablot' '--with-zlib' '--with-zlib-dir=/usr' '--without-oci8' '--enable-bcmath' '--enable-calendar' '--enable-ctype' '--enable-dbase' '--enable-dbx' '--enable-dio' '--enable-discard-path' '--enable-exif' '--enable-fastcgi' '--enable-filepro' '--enable-ftp' '--enable-force-cgi-redirect' '--enable-gd-imgstrttf' '--enable-gd-native-ttf' '--enable-inline-optimization' '--enable-maintainer-zts' '--enable-mcal' '--enable-magic-quotes' '--enable-mbstr-enc-trans' '--enable-mbstring' '--enable-mbregex' '--enable-memory-limit' '--enable-pic' '--enable-shmop' '--enable-sigchild' '--enable-sockets' '--enable-sysvsem' '--enable-sysvmsg' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-ucd-snmp-hack' '--enable-wddx' '--enable-xslt' '--enable-yp' '--enable-zend-multibyte' '--disable-debug'

    Additionally we use imap and pdflib modules plus eaccelerator, but even without all that the error from line 61 remains. Otherwise the shop is loading fine, it's just the login that doesn't work but I didn't have time to check everything since the shop has to be operational so I went back to 5.1.6 for now. Because there are no other errors then I guess something must have been changed which breaks the ZC login in some way. Been looking around in open bugs/php.net but couldn't find anything related yet ...

  4. #4
    Join Date
    Jun 2006
    Posts
    19
    Plugin Contributions
    0

    Default Re: php 5.2.0 update problem

    Oops, sorry, I meant 1GB RAM of course ;)

  5. #5
    Join Date
    Jan 2004
    Posts
    60,695
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: php 5.2.0 update problem

    Quote Originally Posted by ca18 View Post
    Been looking around in open bugs/php.net but couldn't find anything related yet ...
    Well ... it was only released yesterday.
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



  6. #6
    Join Date
    Jun 2006
    Posts
    19
    Plugin Contributions
    0

    Default Re: php 5.2.0 update problem

    Yes, but they had some problems and there where several RC's so I guess not much(other than the security issues reported by Esser etc) should've changed since the latest RC. So any 5.2.0 problems, RC or not, should be known by now with the "final".

  7. #7
    Join Date
    Jun 2006
    Posts
    19
    Plugin Contributions
    0

    Default Re: php 5.2.0 update problem

    The only one similar would be this one:

    http://bugs.php.net/bug.php?id=39331

  8. #8
    Join Date
    Nov 2006
    Posts
    30
    Plugin Contributions
    0

    Default Re: php 5.2.0 update problem

    I got the exact same error after upgrading to php v5.2.0 this morning. Looks like $db is not initialized in session.php?

  9. #9
    Join Date
    Jun 2006
    Posts
    19
    Plugin Contributions
    0

    Default Re: php 5.2.0 update problem

    Thanks for the info linksys, at least I'm not alone with it now

  10. #10
    Join Date
    Jan 2004
    Posts
    60,695
    Blog Entries
    4
    Plugin Contributions
    149

    Default Re: php 5.2.0 update problem

    Quote Originally Posted by linksys View Post
    I got the exact same error after upgrading to php v5.2.0 this morning. Looks like $db is not initialized in session.php?
    Yes, it is, on line 51 (as far as line 61 is concerned).
    .

    Zen Cart - putting the dream of business ownership within reach of anyone!
    Donations always welcome: www.zen-cart.com/donate

    Remember: Any code suggestions you see here are merely suggestions. You assume full responsibility for your use of any such suggestions, including any impact ANY alterations you make to your site may have on your PCI compliance.
    Furthermore, any advice you see here about PCI matters is merely an opinion, and should not be relied upon as "official". Official PCI information should be obtained from the PCI Security Council directly or from one of their authorized Assessors.



 

 
Page 1 of 5 123 ... LastLast

Similar Threads

  1. Email SMTP issues (needed 'smtpauth' instead of 'smtp')
    By petpromises in forum General Questions
    Replies: 23
    Last Post: 8 Nov 2006, 01:48 PM
  2. MySQL and PHP inconsistency Install problem
    By Harleyreb in forum Installing on a Linux/Unix Server
    Replies: 4
    Last Post: 11 Sep 2006, 08:56 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
disjunctive-egg