Results 1 to 5 of 5
  1. #1
    Join Date
    Feb 2005
    Location
    New Jersey
    Posts
    646
    Plugin Contributions
    0

    Default Link Point API Not Working after upgrade (needed to remove+reinstall the module)

    Hi,

    I just upgraded to 1.3.7 and now I am having issues with Linkpoint. When doing a trial transaction, instead of the decline message I expected I got the following:

    at curl_process, incoming data: host = secure.linkpt.net port = 1129 keyfile = /home/xxxxx/public_html/catalog/includes/modules/payment/linkpoint_api/123456.pem configfile = 123456 ordertype = PREAUTH result = LIVE transactionorigin = ECI terminaltype = UNSPECIFIED oid = ip = 68.45.123.22 chargetotal = 6.42 cardnumber = 4111111111111111 cardexpmonth = 01 cardexpyear = 07 cvmindicator = provided cvmvalue = 256 name = Jane Doe company = address1 = 123 Main Street address2 = city = Anytown state = New Jersey country = US phone = 1-555-555-5551 email = janedoe@comcast.net addrnum = 123 Main Street zip = 123456 sname = Jane Doe saddress1 = 123 Main Street saddress2 = scity = Anytown sstate = New Jersey szip = 123456 scountry = US debugging = true debug = true webspace = false sending xml string: PREAUTHLIVE41111111111111110107256providedJane Doe123 Main StreetAnytownNew Jersey123456USJanedoe@comcast.net1-555-555-5551123 Main StreetJane Doe123 Main StreetAnytownNew Jersey123456USUNSPECIFIED68.45.123.22ECI123456 /home/xxxxxxxx/public_html/catalog/includes/modules/payment/linkpoint_api/ 123456.pemsecure.linkpt.net11296.42 server responds: ErrNo:0 server responds: Fri Jan 5 07:54:16 2007SGS-000001: D:Declined:XXUX:442D7B16-459E6697-737-06C16DECLINED1168008855DECLINED
    Warning: Cannot modify header information - headers already sent by (output started at /home/xxxxxx/public_html/catalog/includes/modules/payment/linkpoint_api/ class.linkpoint_api.php:178) in /home/xxxxxx/public_html/catalog/includes/functions/functions_general.php on line 44
    The following is my info:
    PHP Version 4.4.4
    CURL support enabled
    Zen 1.3.7

    I'm not sure about all the info you need. I had no problem with this until the upgrade.
    Last edited by Kim; 5 Jan 2007 at 05:15 PM.

  2. #2
    Join Date
    Mar 2004
    Posts
    16,020
    Plugin Contributions
    5

    Default Re: Link Point API Not Working

    you need to open
    public_html/catalog/includes/modules/payment/linkpoint_api/class.linkpoint_api.php

    and delete the white space from the bottom
    put cursor after last ?> hit delete 10 times save and re-upload

  3. #3
    Join Date
    Feb 2005
    Location
    New Jersey
    Posts
    646
    Plugin Contributions
    0

    Default Re: Link Point API Not Working

    Hi Merlin,

    I checked and there is no white space after the last ?>. I checked the other files in there as well and none of them have any at the end either.

    Thanks,
    Kelly

  4. #4
    Join Date
    Jun 2003
    Posts
    33,823
    Plugin Contributions
    0

    Default Re: Link Point API Not Working

    Did you uninstall and reinstall the module via the admin?
    Please do not PM for support issues: a private solution doesn't benefit the community.

    Be careful with unsolicited advice via email or PM - Make sure the person you are talking to is a reliable source.

  5. #5
    Join Date
    Feb 2005
    Location
    New Jersey
    Posts
    646
    Plugin Contributions
    0

    Default Re: Link Point API Not Working

    Hi Kim,

    No. I hadn't done so until you posted. I did now and woohoo!! it works!


    Thanks,
    Kelly

 

 

Similar Threads

  1. Help with ez-pages
    By yeaboy in forum Templates, Stylesheets, Page Layout
    Replies: 1
    Last Post: 28 Jul 2006, 05:48 AM
  2. Adding "FAQ" in "Information" Sidebox
    By kevnj in forum Basic Configuration
    Replies: 1
    Last Post: 7 Jul 2006, 11:16 AM
  3. Add links in header?
    By drdre in forum Templates, Stylesheets, Page Layout
    Replies: 9
    Last Post: 6 Jul 2006, 05:41 AM
  4. EZ Pages?
    By Robert T in forum Templates, Stylesheets, Page Layout
    Replies: 2
    Last Post: 4 Jul 2006, 04:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •